Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Automatic updates not working

Hybrid View

  1. #1

    Default Automatic updates not working

    I have been trying to get my system (openSUSE Leap 42.1) to update silently with no luck. I find the automatic updates applet in KDE to be annoying, so I have disabled it from the system tray settings. I also have the "Automatic Online Update" in YaST enabled and set to update daily and configured to skip interactive patches and agree with licenses.

    However, the automatic updates is not working. A couple of weeks after turning off the applet, I turned it back on just to make sure that the system has been updating as expected, however, I was surprised to find numerous updates waiting to be installed. I also reviewed the package installation history in "/var/log/zypp/history", and found that no package updates happened in that period of time.

    I have tried turning the automatic updates off and then back on, and repeating the experiment for another week, but I got the same results. No updates happen, and the KDE updates applet shows a lot of updates that need to be installed.

    What could be the problem? And how can I diagnose it or verify that it got fixed?

    It might be worthy to note that I am using my system as a desktop, and I tend to turn on the PC as soon as I wake up, and turn it off when I go to sleep. So, it gets a decent amount of powered on time, but it is shutdown daily.

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Automatic updates not working

    it depends on the repo's you have, it's probobly a dependency issue that requires your attention, the default is if something is not sure don't do it unless the user agrees, it happens to me now and then when using the plasma applet
    so run
    Code:
    zypper up

  3. #3

    Default Re: Automatic updates not working

    Quote Originally Posted by I_A View Post
    it depends on the repo's you have, it's probobly a dependency issue that requires your attention, the default is if something is not sure don't do it unless the user agrees, it happens to me now and then when using the plasma applet
    It does not seem like I am having a problem with dependencies. I ran "zypper up" and there is nothing problematic. It seems to me like the update command is simply not running.

    Updating using the Plasma Applet seems to work well.

    Quote Originally Posted by gogalthorp
    Pretty sure the online update configures the desktop widget / apper.
    Could someone confirm or deny this? And if this is true, what is the best way to get silent updates? I really find the desktop applet quite annoying, with sound and pop-ups distracting the user, and it happens quite frequently. The openSUSE team seems to release updates multiple times per day (which is awesome, except for the annoying pop-ups).

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,648

    Default Re: Automatic updates not working

    I set mine for once a week rather then everyday though it does run at each login. Try the setting where I pointed you to Configure Desktop -Appr Software press the wrench to get to appr settings. Some updates require a reboot ie kernel and some other X related packages. Also some require manual accepting of license.

  5. #5

    Default Re: Automatic updates not working

    Quote Originally Posted by zaidgs View Post
    Could someone confirm or deny this?
    This is wrong.
    YaST's Online Update Configuration does not configure any desktop applets, it wouldn't even be able to as it runs as root...

    Actually it should set up a cron job that runs "zypper up" regularly.

    I have no idea whether it works in 42.1 (the last time I used it was years ago).
    One thing could be that daily cron jobs are configured to run at a time when your computer is off.
    Have a look at /etc/sysconfig/cron and try to set DAILY_TIME to a time when your computer is usually running, maybe that helps.

    The openSUSE team seems to release updates multiple times per day (which is awesome, except for the annoying pop-ups).
    Actually this is a bug in the applet in 42.1, it actually checks for updates every hour regardless of the settings (mainly because PackageKit is configured in openSUSE to shut itself down after 15 seconds to not block YaST/zypper).

    Will be fixed in 42.2, maybe an update for 42.1 will be released as well.

    Quote Originally Posted by gogalthorp View Post
    I set mine for once a week rather then everyday though it does run at each login. Try the setting where I pointed you to Configure Desktop -Appr Software press the wrench to get to appr settings.
    There is no Apper in Leap, and that config module doesn't exist either.

    Right click on the icon in the system tray and select "Software Updater Settings" instead.

  6. #6

    Default Re: Automatic updates not working

    Quote Originally Posted by wolfi323 View Post
    This is wrong.
    YaST's Online Update Configuration does not configure any desktop applets, it wouldn't even be able to as it runs as root...

    Actually it should set up a cron job that runs "zypper up" regularly.

    I have no idea whether it works in 42.1 (the last time I used it was years ago).
    One thing could be that daily cron jobs are configured to run at a time when your computer is off.
    Have a look at /etc/sysconfig/cron and try to set DAILY_TIME to a time when your computer is usually running, maybe that helps.
    Yes, this is what I expected. A cron job. Anyhow, I looked inside /etc/sysconfig/cron (which I didn't modify), and found this:
    Code:
    ## Type:         string
    ## Default:      ""
    #
    # At which time cron.daily should start. Default is 15 minutes after booting
    # the system. Example setting would be "14:00".
    # Due to the fact that cron script runs only every 15 minutes,
    # it will only run on xx:00, xx:15, xx:30, xx:45, not at the accurate time
    # you set.
    DAILY_TIME=""
    Which means that the update should run 15 minutes after booting the system. Or am I mistaken?

    I also found a script named: "/etc/cron.daily/opensuse.org-online_update", which I assume is the one that runs the cron job.

  7. #7

    Default Re: Automatic updates not working

    Quote Originally Posted by zaidgs View Post
    Which means that the update should run 15 minutes after booting the system. Or am I mistaken?
    Yes, should, or maybe did years ago.
    I'm not sure that this still works that way nowadays (I don't know, but I do notice that the daily cron jobs run at the same time every day here on 13.2 even though that setting is empty, so 15 minutes after boot is definitely not true, except maybe the first time after a fresh installation).

    Anyway, just try to set it explicitly, this should definitly work.
    You can always revert your change again...

    I also found a script named: "/etc/cron.daily/opensuse.org-online_update", which I assume is the one that runs the cron job.
    Yes.
    Last edited by wolfi323; 03-Nov-2016 at 12:10.

  8. #8

    Default Re: Automatic updates not working

    Alright, thank you wolfi323 for the information.

    I have set the daily time to "19:00" which is a time the PC is almost always powered on, and I will check if the updates work.

    Thanks again, and I will report my findings within a couple of days.

  9. #9

    Default Re: Automatic updates not working

    Quote Originally Posted by zaidgs View Post
    I have set the daily time to "19:00" which is a time the PC is almost always powered on, and I will check if the updates work.

    Thanks again, and I will report my findings within a couple of days.
    Just one thing that just struck my mind, please check that cron.service is enabled:
    Code:
    systemctl status cron
    If cron is not running, it won't be starting the cron jobs either, of course...

  10. #10

    Default Re: Automatic updates not working

    Alright, I am still facing the same problem, however, I have discovered a little more about the nature of the problem.

    1- The cron job is working as expected.
    2- The update command is the problem as it seems that the update command updates makes very few actual updates.

    Look at this log file in /var/log/zypp/history:

    2016-11-08 19:01:01|command|root@zaidpc|'/usr/bin/zypper' '--non-interactive' '--quiet' 'patch' '--skip-interactive' '--auto-agree-with-licenses' '--recommends'|
    2016-11-08 19:01:01|install|bind-libs|9.9.9P1-42.1|x86_64||repo-update|4cbff927c96be44e2fe91d59c2fb08c0a784ad88e8935ee8a8163c4a1f08dfe5|
    2016-11-08 19:01:01|install|bind-utils|9.9.9P1-42.1|x86_64||repo-update|89b65c4ac980c604353ee2a7a9d65faf89ab12d36ed4151ff2a47cdc939132ae|
    From the log file above, it looks like the update command did run at the expected time of 19:00, which means that the cron job is working as expected. However, only two packages were installed: "bind-libs" and "bind-utils".

    So, to double check this theory, I ran the following command:
    sudo zypper --non-interactive --quiet patch --skip-interactive --auto-agree-with-licenses --recommends
    And immediately after the command completed (btw, it didn't find any updates), I checked the available updates through the plasma update tool, and it found 25 pending updates.

    Could someone explain why this behavior is happening? And how to make the update job update everything?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •