Page 5 of 5 FirstFirst ... 345
Results 41 to 42 of 42

Thread: System crashes when using OpenGL 3.1 for desktop compositing

  1. #41
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    717

    Default Re: System crashes when using OpenGL 3.1 for desktop compositing

    So Tumbleweed finally switched to Kernel 4.9.0 today. I updated and restarted, and now this is what I get when running the previously mentioned commands:

    Code:
    mircea@linux-qz0r:~> /sbin/modinfo amdgpu | grep 6811
    alias:          pci:v00001002d00006811sv*sd*bc*sc*i*
    mircea@linux-qz0r:~> /sbin/modinfo radeon | grep 6811
    alias:          pci:v00001002d00006811sv*sd*bc*sc*i*
    Code:
    mircea@linux-qz0r:~> /sbin/lspci -nnk | grep -A3 VGA
    03:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Curacao PRO [Radeon R7 370 / R9 270/370 OEM] [1002:6811] (rev 81)
            Subsystem: Gigabyte Technology Co., Ltd Device [1458:2015]
            Kernel driver in use: radeon
            Kernel modules: radeon, amdgpu
    Does this mean I'm finally running on the amdgpu driver? That last line suggests both drivers are now available, but I'm still using just radeon. How would I go about changing that, the cleanest safest and most correct way?
    openSUSE Tumbleweed x64, KDE Framework 5

  2. #42
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    717

    Default Re: System crashes when using OpenGL 3.1 for desktop compositing

    I found instructions on how to get the driver running and attempted them. What I did was add the following files, based on examples from this repository:

    /etc/X11/xorg.conf.d/20-amdgpu.conf

    Code:
    Section "Device"
       Identifier "AMD Graphics Core Next GPU"
       Driver "amdgpu"
       Option "DRI" "3"
       Option "TearFree" "true"
    EndSection
    /etc/modprobe.d/50-radeon.conf

    Code:
    blacklist radeon
    As expected, it did not work for some given reason. There was however no error message of any sort: After the system finished booting, it simply remained in its initial runlevel. Hitting control + alt + f7 to go to the normal runlevel simply presented me with a black screen that had a blinking cursor at the top-left. Any thoughts on this?
    openSUSE Tumbleweed x64, KDE Framework 5

Page 5 of 5 FirstFirst ... 345

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •