Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 42

Thread: System crashes when using OpenGL 3.1 for desktop compositing

  1. #21
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,302
    Blog Entries
    15

    Default Re: System crashes when using OpenGL 3.1 for desktop compositing

    Quote Originally Posted by MirceaKitsune View Post
    Hmmm... interesting. I still haven't fully understood the steps to enable it, and some posts stated that xorg stopped working after they added in the amdgpu configuration. Isn't there any x11 command that can be used cleanly, or do system files need to be manually hacked?
    Hi
    Install xf86-video-amdgpu and reboot, in theory it should start using it, if you get a black screen and get booted to a VT login, add those two files and run the command mkinitrd and reboot all should be good.

    At present is xf86-video-amdgpu installed? If so you should see both kernel modules present in the lspci output?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  2. #22
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    705

    Default Re: System crashes when using OpenGL 3.1 for desktop compositing

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Install xf86-video-amdgpu and reboot, in theory it should start using it, if you get a black screen and get booted to a VT login, add those two files and run the command mkinitrd and reboot all should be good.

    At present is xf86-video-amdgpu installed? If so you should see both kernel modules present in the lspci output?
    All amdgpu packages are installed. Oddly enough however, I do not see it in that output.

    Code:
    00:00.0 Host bridge: Intel Corporation 5520/5500/X58 I/O Hub to ESI Port (rev 13)
    00:01.0 PCI bridge: Intel Corporation 5520/5500/X58 I/O Hub PCI Express Root Port 1 (rev 13)
    00:02.0 PCI bridge: Intel Corporation 5520/5500/X58 I/O Hub PCI Express Root Port 2 (rev 13)
    00:03.0 PCI bridge: Intel Corporation 5520/5500/X58 I/O Hub PCI Express Root Port 3 (rev 13)
    00:10.0 PIC: Intel Corporation 7500/5520/5500/X58 Physical and Link Layer Registers Port 0 (rev 13)
    00:10.1 PIC: Intel Corporation 7500/5520/5500/X58 Routing and Protocol Layer Registers Port 0 (rev 13)
    00:11.0 PIC: Intel Corporation 7500/5520/5500 Physical and Link Layer Registers Port 1 (rev 13)
    00:11.1 PIC: Intel Corporation 7500/5520/5500 Routing & Protocol Layer Register Port 1 (rev 13)
    00:13.0 PIC: Intel Corporation 7500/5520/5500/X58 I/O Hub I/OxAPIC Interrupt Controller (rev 13)
    00:14.0 PIC: Intel Corporation 7500/5520/5500/X58 I/O Hub System Management Registers (rev 13)
    00:14.1 PIC: Intel Corporation 7500/5520/5500/X58 I/O Hub GPIO and Scratch Pad Registers (rev 13)
    00:14.2 PIC: Intel Corporation 7500/5520/5500/X58 I/O Hub Control Status and RAS Registers (rev 13)
    00:15.0 PIC: Intel Corporation 7500/5520/5500/X58 Trusted Execution Technology Registers (rev 13)
    00:1a.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #4
    00:1a.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #5
    00:1a.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #6
    00:1a.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #2
    00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
    00:1c.0 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1
    00:1c.1 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Port 2
    00:1c.4 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 5
    00:1c.5 PCI bridge: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 6
    00:1d.0 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #1
    00:1d.1 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #2
    00:1d.2 USB controller: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #3
    00:1d.7 USB controller: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #1
    00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 90)
    00:1f.0 ISA bridge: Intel Corporation 82801JIR (ICH10R) LPC Interface Controller
    00:1f.2 SATA controller: Intel Corporation 82801JI (ICH10 Family) SATA AHCI Controller
    00:1f.3 SMBus: Intel Corporation 82801JI (ICH10 Family) SMBus Controller
    01:00.0 SATA controller: Marvell Technology Group Ltd. 88SE9128 PCIe SATA 6 Gb/s RAID controller (rev 11)
    02:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 03)
    03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Curacao PRO [Radeon R7 370 / R9 270/370 OEM] (rev 81)
    03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]
    05:00.0 SATA controller: JMicron Technology Corp. JMB363 SATA/IDE Controller (rev 02)
    05:00.1 IDE interface: JMicron Technology Corp. JMB363 SATA/IDE Controller (rev 02)
    06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 03)
    07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 03)
    08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8185 IEEE 802.11a/b/g Wireless LAN Controller (rev 20)
    08:06.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link)
    3f:00.0 Host bridge: Intel Corporation Xeon 5500/Core i7 QuickPath Architecture Generic Non-Core Registers (rev 05)
    3f:00.1 Host bridge: Intel Corporation Xeon 5500/Core i7 QuickPath Architecture System Address Decoder (rev 05)
    3f:02.0 Host bridge: Intel Corporation Xeon 5500/Core i7 QPI Link 0 (rev 05)
    3f:02.1 Host bridge: Intel Corporation Xeon 5500/Core i7 QPI Physical 0 (rev 05)
    3f:03.0 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller (rev 05)
    3f:03.1 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Target Address Decoder (rev 05)
    3f:03.4 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Test Registers (rev 05)
    3f:04.0 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 0 Control Registers (rev 05)
    3f:04.1 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 0 Address Registers (rev 05)
    3f:04.2 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 0 Rank Registers (rev 05)
    3f:04.3 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 0 Thermal Control Registers (rev 05)
    3f:05.0 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 1 Control Registers (rev 05)
    3f:05.1 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 1 Address Registers (rev 05)
    3f:05.2 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 1 Rank Registers (rev 05)
    3f:05.3 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 1 Thermal Control Registers (rev 05)
    3f:06.0 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 2 Control Registers (rev 05)
    3f:06.1 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 2 Address Registers (rev 05)
    3f:06.2 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 2 Rank Registers (rev 05)
    3f:06.3 Host bridge: Intel Corporation Xeon 5500/Core i7 Integrated Memory Controller Channel 2 Thermal Control Registers (rev 05)
    openSUSE Tumbleweed x64, KDE Framework 5

  3. #23
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,302
    Blog Entries
    15

    Default Re: System crashes when using OpenGL 3.1 for desktop compositing

    Quote Originally Posted by MirceaKitsune View Post
    All amdgpu packages are installed. Oddly enough however, I do not see it in that output.

    Code:
    03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Curacao PRO [Radeon R7 370 / R9 270/370 OEM] (rev 81)
    Hi
    Use;
    Code:
    /sbin/lspci -nnk | grep -A3 VGA
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #24
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    705

    Default Re: System crashes when using OpenGL 3.1 for desktop compositing

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Use;
    Code:
    /sbin/lspci -nnk | grep -A3 VGA
    Code:
    linux-qz0r:/home/mircea # /sbin/lspci -nnk | grep -A3 VGA
    03:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Curacao PRO [Radeon R7 370 / R9 270/370 OEM] [1002:6811] (rev 81)
            Subsystem: Gigabyte Technology Co., Ltd Device [1458:2015]
            Kernel driver in use: radeon
            Kernel modules: radeon
    openSUSE Tumbleweed x64, KDE Framework 5

  5. #25
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,302
    Blog Entries
    15

    Default Re: System crashes when using OpenGL 3.1 for desktop compositing

    Quote Originally Posted by MirceaKitsune View Post
    Code:
    linux-qz0r:/home/mircea # /sbin/lspci -nnk | grep -A3 VGA
    03:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Curacao PRO [Radeon R7 370 / R9 270/370 OEM] [1002:6811] (rev 81)
            Subsystem: Gigabyte Technology Co., Ltd Device [1458:2015]
            Kernel driver in use: radeon
            Kernel modules: radeon
    Hi
    So your sure xf86-video-amdgpu is installed?

    Code:
    zypper if xf86-video-amdgpu
    
    /sbin/modinfo amdgpu |grep 6811
    alias:          pci:v00001002d00006811sv*sd*bc*sc*i*
    
    /sbin/modinfo radeon |grep 6811
    alias:          pci:v00001002d00006811sv*sd*bc*sc*i
    So it's supported by both, but should show both as well in the lspci output.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #26
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    705

    Default Re: System crashes when using OpenGL 3.1 for desktop compositing

    Quote Originally Posted by malcolmlewis View Post
    Hi
    So your sure xf86-video-amdgpu is installed?

    Code:
    zypper if xf86-video-amdgpu
    
    /sbin/modinfo amdgpu |grep 6811
    alias:          pci:v00001002d00006811sv*sd*bc*sc*i*
    
    /sbin/modinfo radeon |grep 6811
    alias:          pci:v00001002d00006811sv*sd*bc*sc*i
    So it's supported by both, but should show both as well in the lspci output.
    They are all installed, I checked via YaST Package Manager. This is definitely pretty weird.

    Code:
    linux-qz0r:/home/mircea # zypper if xf86-video-amdgpu
    Loading repository data...
    Reading installed packages...
    
    
    Information for package xf86-video-amdgpu:
    ------------------------------------------
    Repository     : openSUSE-Tumbleweed-Oss                  
    Name           : xf86-video-amdgpu                        
    Version        : 1.1.2-1.1                                
    Arch           : x86_64                                   
    Vendor         : openSUSE                                 
    Installed Size : 153.6 KiB                                
    Installed      : Yes                                      
    Status         : up-to-date                               
    Summary        : AMDGPU video driver for the Xorg X server
    Description    :                                          
        amdgpu is an Xorg driver for AMD video cards.
        Its autodetects whether your hardware has a CI or newer AMD Graphics Card
    As for the other two commands, the amdgpu grep returns nothing, whereas the radeon one does.

    Code:
    linux-qz0r:/home/mircea # /sbin/modinfo amdgpu | grep 6811
    
    linux-qz0r:/home/mircea # /sbin/modinfo radeon | grep 6811
    alias:          pci:v00001002d00006811sv*sd*bc*sc*i*
    openSUSE Tumbleweed x64, KDE Framework 5

  7. #27
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,302
    Blog Entries
    15

    Default Re: System crashes when using OpenGL 3.1 for desktop compositing

    Quote Originally Posted by MirceaKitsune View Post
    They are all installed, I checked via YaST Package Manager. This is definitely pretty weird.

    Code:
    linux-qz0r:/home/mircea # zypper if xf86-video-amdgpu
    Loading repository data...
    Reading installed packages...
    
    
    Information for package xf86-video-amdgpu:
    ------------------------------------------
    Repository     : openSUSE-Tumbleweed-Oss                  
    Name           : xf86-video-amdgpu                        
    Version        : 1.1.2-1.1                                
    Arch           : x86_64                                   
    Vendor         : openSUSE                                 
    Installed Size : 153.6 KiB                                
    Installed      : Yes                                      
    Status         : up-to-date                               
    Summary        : AMDGPU video driver for the Xorg X server
    Description    :                                          
        amdgpu is an Xorg driver for AMD video cards.
        Its autodetects whether your hardware has a CI or newer AMD Graphics Card
    As for the other two commands, the amdgpu grep returns nothing, whereas the radeon one does.

    Code:
    linux-qz0r:/home/mircea # /sbin/modinfo amdgpu | grep 6811
    
    linux-qz0r:/home/mircea # /sbin/modinfo radeon | grep 6811
    alias:          pci:v00001002d00006811sv*sd*bc*sc*i*
    Hi
    Ahh, ok, so I guess either run 4.9.x or when 4.10.x released or run my kmp... https://build.opensuse.org/package/s...:AMDgpu/amdgpu
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #28
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    705

    Default Re: System crashes when using OpenGL 3.1 for desktop compositing

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Ahh, ok, so I guess either run 4.9.x or when 4.10.x released or run my kmp... https://build.opensuse.org/package/s...:AMDgpu/amdgpu
    Best option is to wait for 4.9. I assume amdgpu will automatically replace radeon then? I understand it should, but at the same time many articles say 4.9 will only offer it experimentally and the Kernel needs to be hacked.
    openSUSE Tumbleweed x64, KDE Framework 5

  9. #29
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,302
    Blog Entries
    15

    Default Re: System crashes when using OpenGL 3.1 for desktop compositing

    Quote Originally Posted by MirceaKitsune View Post
    Best option is to wait for 4.9. I assume amdgpu will automatically replace radeon then? I understand it should, but at the same time many articles say 4.9 will only offer it experimentally and the Kernel needs to be hacked.
    Hi
    I see my bug fix (fdo#97471) is now in 4.8.5, so may be sooner than expected.

    Hacking is a bit harsh Just enabling the CONFIG_DRM_AMDGPU_CIK option which is done now AFAIK from 4.8.x
    https://lists.opensuse.org/opensuse-.../msg00040.html

    At some point you should see the amdgpu module appear in the lspci output along with radeon.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #30
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    705

    Default Re: System crashes when using OpenGL 3.1 for desktop compositing

    Quote Originally Posted by malcolmlewis View Post
    Hi
    I see my bug fix (fdo#97471) is now in 4.8.5, so may be sooner than expected.

    Hacking is a bit harsh Just enabling the CONFIG_DRM_AMDGPU_CIK option which is done now AFAIK from 4.8.x
    https://lists.opensuse.org/opensuse-.../msg00040.html

    At some point you should see the amdgpu module appear in the lspci output along with radeon.
    Wonderful! I will wait for >= 4.8.5 and try again then. Thanks for all the useful info
    openSUSE Tumbleweed x64, KDE Framework 5

Page 3 of 5 FirstFirst 12345 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •