Results 1 to 3 of 3

Thread: alt+tab switcher "cover switch" and "flip-switch" not working

  1. #1
    Join Date
    May 2015
    Location
    Italy
    Posts
    368

    Default alt+tab switcher "cover switch" and "flip-switch" not working

    Hi, I have a problem with the "cover switch" and "flip switch" effetcs of the alt+tab task switcher.

    If I go to "System Settings > Workspace > Window Management > Task Switcher" and select "Cover Switch" or "Flip Switch" from the drop-down list of effects, I instead get the default "Breeze" effect.

    Also if I look at "System Settings > Workspace > Desktop Behavior > Desktop Effects" I cannot find those two effects, while I seem to remember seeing them previously.

    Anybody else having this problem?

    Here is information about my Tumbleweed release, if it is of any help:

    Code:
    cristiano@xmper8q3:~> lsb_release -a
    LSB Version:    core-2.0-noarch:core-3.2-noarch:core-4.0-noarch:core-2.0-x86_64:core-3.2-x86_64:core-4.0-x86_64:desktop-4.0-amd64:desktop-4.0-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.2-amd64:graphics-3.2-noarch:graphics-4.0-amd64:graphics-4.0-noarch
    Distributor ID: openSUSE Tumbleweed
    Description:    openSUSE Tumbleweed
    Release:        20161014
    Codename:       n/a
    
    cristiano@xmper8q3:~> plasmashell -v
    plasmashell 5.8.2
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  2. #2

    Default Re: alt+tab switcher "cover switch" and "flip-switch" not working

    Quote Originally Posted by Cris70 View Post
    Hi, I have a problem with the "cover switch" and "flip switch" effetcs of the alt+tab task switcher.

    If I go to "System Settings > Workspace > Window Management > Task Switcher" and select "Cover Switch" or "Flip Switch" from the drop-down list of effects, I instead get the default "Breeze" effect.

    Also if I look at "System Settings > Workspace > Desktop Behavior > Desktop Effects" I cannot find those two effects, while I seem to remember seeing them previously.
    Both of those switchers require OpenGL compositing, so have a look at "System Settings > Display and Monitor > Compositor".
    If the "Rendering backend" is set to XRender, switch it to OpenGL (2.0 or 3.1), and they should reappear in "Desktop Effects" (which only shows working effects)
    kwin automatically switches to XRender if there is a problem with OpenGL (or it crashes).

  3. #3
    Join Date
    May 2015
    Location
    Italy
    Posts
    368

    Default Re: alt+tab switcher "cover switch" and "flip-switch" not working

    Quote Originally Posted by wolfi323 View Post
    Both of those switchers require OpenGL compositing, so have a look at "System Settings > Display and Monitor > Compositor".
    If the "Rendering backend" is set to XRender, switch it to OpenGL (2.0 or 3.1), and they should reappear in "Desktop Effects" (which only shows working effects)
    kwin automatically switches to XRender if there is a problem with OpenGL (or it crashes).
    That was exactly my case, thank you wolfi323!!

    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •