Results 1 to 10 of 10

Thread: The KDE Splash Screen Theme

  1. #1

    Default The KDE Splash Screen Theme

    My Tumbleweed laptop now (since installing a boat load of updates this morning) has three options for the KDE splash screen (none, Breeze or
    "openSUSE" (which is the green lightbulb on black background theme which originally appeared in either 13.2 or 42.1 (I don't remember exactly which it was)). Its using the openSUSE theme by default.

    Interestingly, my similarly updated Tumbleweed desktop only has the first two options (none or Breeze). Why the difference? Missing package on the desktop? I don't think I've ever made a user intervention that would have accounted for the difference.... I just found it odd that there wasn't consistency brought about with the update

    (PS -- you can find what I'm talking about in System Settings > Appearance > Workspace Theme > Splash Screen )

  2. #2

    Default Re: The KDE Splash Screen Theme

    Is plasma5-theme-openSUSE installed?
    That's new in the Plasma 5.8 branding, I'm not sure currently what should pull it in.

    Maybe you just encountered a "bug" in our package dependencies...
    Last edited by wolfi323; 11-Oct-2016 at 12:48.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,848
    Blog Entries
    14

    Default Re: The KDE Splash Screen Theme

    Looks like a missing openSUSE-*-branding package. Are the installs identical re. applications?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: The KDE Splash Screen Theme

    Quote Originally Posted by wolfi323 View Post
    Is plasma5-theme-openSUSE installed?
    not on the desktop (imaging it is on the laptop )
    That's new in the Plasma 5.8 branding, I'm not sure currently what should pull it in.
    okay, thanks

    Maybe you just encountered a "bug" in our package dependencies...
    trying to install it hits the likely reason that it didn't get pulled in: kdebase4-openSUSE-lang-13.3-1.11.noarch requires kdebase4-openSUSE

    After (removal of the old and) a reboot, I'm happy to say that the desktop is now with the green light bulb too

  5. #5

    Default Re: The KDE Splash Screen Theme

    Quote Originally Posted by Knurpht View Post
    Are the installs identical re. applications?
    Nah. The desktop has a lot more stuff installed on it. The laptop is pretty barebones ... though, to the best of my knowledge, it doesn't have anything installed that the desktop doesn't also have on it.

  6. #6

    Default Re: The KDE Splash Screen Theme

    Quote Originally Posted by Tyler_K View Post
    trying to install it hits the likely reason that it didn't get pulled in: kdebase4-openSUSE-lang-13.3-1.11.noarch requires kdebase4-openSUSE
    Thanks for finding that out.

    So apparently an Obsoletes has been forgotten (for the kdebase4-openSUSE-lang package it seems), no idea why the openQA tests haven't found this yet... :/ (they do test upgrades from 13.2 with KDE4)
    Maybe because the tests only do an english installation...

    I will look at this tomorrow and try to submit a fix.
    Last edited by wolfi323; 11-Oct-2016 at 13:48.

  7. #7

    Default Re: The KDE Splash Screen Theme

    Quote Originally Posted by wolfi323 View Post
    Thanks for finding that out.

    So apparently an Obsoletes has been forgotten (for the kdebase4-openSUSE-lang package it seems), no idea why the openQA tests haven't found this yet... :/ (they do test upgrades from 13.2 with KDE4)
    Maybe because the tests only do an english installation...

    I will look at this tomorrow and try to submit a fix.
    I have an idea, but sadly, when I went to go check upon this in yast software mgmt, I now discover that it will not open. Yikes. I'm going to reboot again, but if it (yast-sw mgmt) is still not working, then I know that the only changes that have been made since the last time it worked are listed above (addition of the the plasma5 pkg(s) and removal of the older kdebase4-openSUSE package)

  8. #8

    Default Re: The KDE Splash Screen Theme

    Don't worry.
    I created https://build.opensuse.org/request/show/434383 already.

  9. #9

    Default Re: The KDE Splash Screen Theme

    Quote Originally Posted by wolfi323 View Post
    Don't worry.
    I created https://build.opensuse.org/request/show/434383 already.
    Okie dokie

    Sadly, my new yast problem persists .... will take up this new problem in another thread (perhaps tomorrow, as time permits) as it would appear to be quite unrelated to KDE splash screens

  10. #10

    Default Re: The KDE Splash Screen Theme

    Quote Originally Posted by Tyler_K View Post
    Sadly, my new yast problem persists .... will take up this new problem in another thread (perhaps tomorrow, as time permits)
    Just for posterity's sake, the yast problem disappeared after today's updates (which did indeed inlcude some yast packages)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •