Results 1 to 2 of 2

Thread: virtualbox does not start

  1. #1

    Default virtualbox does not start

    Hi there,
    I have tried to upgrade to the latest virtualbox but unfortunately I can not launch it anymore.

    Code:
    apa@myhost:~> VirtualBox 
    VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: /usr/lib/virtualbox/VirtualBox.so: undefined symbol: _ZNK10QTableView16viewportSizeHintEv
    Code:
    apa@myhost:~> rpm -qa | grep VirtualBox                                                                                                                                   
    VirtualBox-5.1-5.1.6_110634_openSUSE132-1.x86_64

    so what it might causing this problem? I guess this is coming from the linker not being able to link with the appropriate library.
    Any ideas? Running opensuse 13.1
    Alex

  2. #2

    Default Re: virtualbox does not start

    Quote Originally Posted by alaios View Post
    Hi there,
    I have tried to upgrade to the latest virtualbox
    And how have you tried to upgrade it exactly?

    Code:
    apa@myhost:~> VirtualBox 
    VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: /usr/lib/virtualbox/VirtualBox.so: undefined symbol: _ZNK10QTableView16viewportSizeHintEv
    Looks like you have some incompatible packages installed.

    Code:
    apa@myhost:~> rpm -qa | grep VirtualBox                                                                                                                                   
    VirtualBox-5.1-5.1.6_110634_openSUSE132-1.x86_64
    so what it might causing this problem? I guess this is coming from the linker not being able to link with the appropriate library.
    Any ideas? Running opensuse 13.1
    The package you show above is for 13.2.
    It probably won't work on 13.1.

    Either upgrade your system (13.1 is not supported officially any more since February, and Evergreen support is also going to end soon), or install the 13.1 package instead.

    PS: Oracle's repo for 13.1 is here:
    http://download.virtualbox.org/virtu...opensuse/13.1/

    Unfortunately they do not offer VBox 5.1.x for 13.1 (maybe because it uses Qt5 now, and I also think that the latest versions require kernel 3.16 at least), so you need to stick to 5.0 if you don't want to upgrade to openSUSE 13.2 or higher.
    Last edited by wolfi323; 10-Oct-2016 at 11:05.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •