Page 1 of 5 123 ... LastLast
Results 1 to 10 of 45

Thread: adjusting the hours

  1. #1
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default adjusting the hours

    The time of my netBook is 3 hours more.
    I've tried to set the time and region in two ways
    1-by icon that appears on the taskbar
    2-by YaST
    I can set the time, but after a few minutes, the clock back to stay over three hours.
    How do you adjust the time permanently?

    Thanks in advance

  2. #2

    Default Re: adjusting the hours

    Quote Originally Posted by sergelli View Post
    I can set the time, but after a few minutes, the clock back to stay over three hours.
    Well, if the time changes back "automatically", it's likely caused by NTP (which regularly synchronizes your clock with some time server) I'd say.

    Try to disable it in YaST->System->Date and Time or YaST->Network Services->NTP as a test.

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,884

    Default Re: adjusting the hours

    That is indeed something to test.

    And it would not be bad if you provided some hard information like:
    What are the setings when it is wrong:
    Code:
    date
    Tell what you changed from what into what.
    Show the settings again after you changed them with the same command (and hopefully before they are changed back to the wrong settings.

    And as you say you do this for the system (using YaST) and also for the user (by some icon in a desktop unidentified by you), which each have their own settings, please do so for both the user and for root.
    Henk van Velden

  4. #4
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,131

    Default Re: adjusting the hours

    Brazil is 3 hours behind GMT (UTC)

    I think that you have set your system time to UTC by failing to set a TimeZone.

    This is set in various places, each one over-riding the previous.

    YaST → System → Date and Time

    [KDE]
    System Settings → Regional Settings → Date and Time → Timezone

    Clock application -- e.g. Digital Clock Settings → Time Zone

    Try setting all of these to Brasil/São Paulo
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  5. #5
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default Re: adjusting the hours

    I tested all the suggestions, no matter what mode I use to set the clock
    In a few minutes after the adjustment, time continues to advance two hours;.
    What else can I do?

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,884

    Default Re: adjusting the hours

    Quote Originally Posted by sergelli View Post
    I tested all the suggestions, no matter what mode I use to set the clock
    In a few minutes after the adjustment, time continues to advance two hours;.
    What else can I do?
    So, where is the output I asked for?

    In your first post you talked about three hours. No you talk about two hours.

    You realy should post facts and not fairy tails.
    Henk van Velden

  7. #7

    Default Re: adjusting the hours

    Quote Originally Posted by sergelli View Post
    What else can I do?
    Post the output of:
    Code:
    systemctl status ntpd
    timedatectl

  8. #8
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default Re: adjusting the hours

    Quote Originally Posted by hcvv View Post
    So, where is the output I asked for?

    In your first post you talked about three hours. No you talk about two hours.

    You realy should post facts and not fairy tails.
    Sorry about my fault. the correct is three hours
    Code:
    sergio@linux-7vcz:~> date
    Qua Out 12 11:38:42 UTC 2016
    and after changes
    Code:
    sergio@linux-7vcz:~> date
    Qua Out 12 08:39:48 UTC 2016

  9. #9
    Join Date
    Aug 2013
    Location
    Jundiai, São Paulo, Brazil
    Posts
    464

    Default Re: adjusting the hours

    Quote Originally Posted by wolfi323 View Post
    Post the output of:
    Code:
    systemctl status ntpd
    timedatectl
    The result is :
    Code:
    sergio@linux-7vcz:~> systemctl status ntpd
    ntpd.service - NTP Server Daemon
       Loaded: loaded (/usr/lib/systemd/system/ntpd.service; enabled)
       Active: active (running) since Qua 2016-10-12 08:27:26 UTC; 22min ago
         Docs: man:ntpd(1)
     Main PID: 22645 (ntpd)
       CGroup: /system.slice/ntpd.service
               ├─22645 /usr/sbin/ntpd -p /var/run/ntp/ntpd.pid -g -u ntp:ntp -i /var/lib/ntp -c /etc/ntp...
               └─22646 ntpd: asynchronous dns resolver

  10. #10

    Default Re: adjusting the hours

    Quote Originally Posted by sergelli View Post
    The result is :
    Code:
    sergio@linux-7vcz:~> systemctl status ntpd
    ntpd.service - NTP Server Daemon
       Loaded: loaded (/usr/lib/systemd/system/ntpd.service; enabled)
       Active: active (running) since Qua 2016-10-12 08:27:26 UTC; 22min ago
    So you didn't disable NTP.

    Run "sudo systemctl stop ntpd" and see whether the problem persists.
    To disable it permanently run "sudo systemctl disable ntpd".

    If it helps, we know that NTP is causing your problem, and can further investigate.
    Most likely it is some confusion between local time and UTC though, as already has been suggested.

    So again, please also post the output of "timedatectl".

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •