Results 1 to 8 of 8

Thread: Leap 42.1 How to get Dolphin (Google Drive) KF5 to work

  1. #1
    Join Date
    Dec 2015
    Location
    Atoka, Tennessee USA
    Posts
    49

    Default Leap 42.1 How to get Dolphin (Google Drive) KF5 to work

    Since switching to Leap 42.1 last year, I can't find a GDrive replacement that I used successfully in Kubuntu. I have installed the KIO Google Drive from the repository that wolfi has created. But when I click on it to log on to Google, it doesn't do anything. What the best way to integrate this program and get it up and running? Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,260
    Blog Entries
    1

    Default Re: Leap 42.1 How to get Dolphin (Google Drive) KF5 to work


  3. #3
    Join Date
    Dec 2015
    Location
    Atoka, Tennessee USA
    Posts
    49

    Default Re: Leap 42.1 How to get Dolphin (Google Drive) KF5 to work

    Quote Originally Posted by deano_ferrari View Post
    I saw that thread earlier. I am not that good yet. Please give me a little more command line instructions. I can click on links, but I don't know how to input the code in the command line. I want to learn, but I need some more detail and baby steps, I guess. Thank you for your patience.

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Leap 42.1 How to get Dolphin (Google Drive) KF5 to work

    Quote Originally Posted by louparker View Post
    I saw that thread earlier. I am not that good yet. Please give me a little more command line instructions. I can click on links, but I don't know how to input the code in the command line. I want to learn, but I need some more detail and baby steps, I guess. Thank you for your patience.
    you need to install kio-gdrive from wolfi or from the 42.2 kde:applications repo
    https://software.opensuse.org/package/kio-gdrive
    to get write support LEAP users need an update to libkgapi
    https://phabricator.kde.org/T1566
    you can write to bugzilla and ask for a fix
    https://bugzilla.opensuse.org

  5. #5

    Default Re: Leap 42.1 How to get Dolphin (Google Drive) KF5 to work

    Quote Originally Posted by I_A View Post
    you need to install kio-gdrive from wolfi or from the 42.2 kde:applications repo
    Actually it is in KDE:Extra...

    you can write to bugzilla and ask for a fix
    https://bugzilla.opensuse.org
    Sorry, but no.
    We won't release a libkgapi upgrade for Leap 42.1.

    You can get the latest version from KDE:Applications though.
    And it has been submitted to 42.2 (and kio-gdrive as well, though it hasn't been accepted yet).

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,763
    Blog Entries
    14

    Default Re: Leap 42.1 How to get Dolphin (Google Drive) KF5 to work

    Quote Originally Posted by wolfi323 View Post
    Actually it is in KDE:Extra...


    Sorry, but no.
    We won't release a libkgapi upgrade for Leap 42.1.

    You can get the latest version from KDE:Applications though.
    And it has been submitted to 42.2 (and kio-gdrive as well, though it hasn't been accepted yet).
    A bit off topic: could we get it for TW?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7

    Default Re: Leap 42.1 How to get Dolphin (Google Drive) KF5 to work

    Quote Originally Posted by Knurpht View Post
    A bit off topic: could we get it for TW?
    It has been submitted to Factory already, but it has to go through the usual process first.
    See https://build.opensuse.org/request/show/432132

    As mentioned it is available in KDE:Applications (also for Tumbleweed), and kio-gdrive is available in KDE:Extra for this combination, if you don't want to wait.
    Last edited by wolfi323; 08-Oct-2016 at 07:11.

  8. #8

    Default Re: Leap 42.1 How to get Dolphin (Google Drive) KF5 to work

    PS: As I just saw, libkgapi cannot even be built for plain 42.1 because it requires KDEPIM 16.08 (which cannot be built for 42.1 either, as it requires Qt 5.6).
    So an update for 42.1 would actually be right impossible.

    There is the new KDE:Frameworks5:LTS repo though that offers Plasma 5.8 LTS for 42.1 too (needs KDE:Qt56 for Qt 5.6), and KDE:Applications is being built for that combination (which makes it possible to also get KDEPIM 16.08.1 on 42.1):
    http://download.opensuse.org/reposit...USE_Leap_42.1/
    Last edited by wolfi323; 08-Oct-2016 at 07:45.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •