Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24

Thread: [KDE] No wallet auto-login

  1. #21

    Default Re: [KDE] No wallet auto-login

    Quote Originally Posted by wolfi323 View Post
    If using Auto-Login, the same change in /etc/pam.d/sddm-autologin should work.
    I re-enabled auto-login. Here's my /etc/pam.d/sddm-autologin and it did not work:

    Code:
    #%PAM-1.0
    auth     required       pam_permit.so
    -auth     optional       pam_kwallet5.so
    account  include        common-account
    password include        common-password
    session  required       pam_loginuid.so
    session  include        common-session
    -session  optional       pam_kwallet5.so
    From the log:
    Code:
    Oct 22 20:19:21 skylake sddm-helper[2350]: [PAM] Starting...
    Oct 22 20:19:21 skylake sddm-helper[2350]: pam_kwallet5(sddm-autologin:auth): (null): pam_sm_authenticate
    Oct 22 20:19:21 skylake sddm-helper[2350]: [PAM] Authenticating...
    Oct 22 20:19:21 skylake sddm-helper[2350]: pam_kwallet5(sddm-autologin:auth): pam_kwallet5: Couldn't get password (it is empty)
    Oct 22 20:19:21 skylake sddm-helper[2350]: [PAM] Preparing to converse...
    Oct 22 20:19:21 skylake sddm-helper[2350]: [PAM] Conversation with 1 messages
    Oct 22 20:19:21 skylake audit[2350]: USER_AUTH pid=2350 uid=0 auid=4294967295 ses=4294967295 msg='op=PAM:authentication grantors=pam_permit,pam_kwallet5 acct="bsmith" exe="/usr/lib/sddm/sddm-helper" hostname=? add
    Oct 22 20:19:21 skylake sddm-helper[2350]: [PAM] returning.
    Oct 22 20:19:21 skylake audit[2350]: USER_ACCT pid=2350 uid=0 auid=4294967295 ses=4294967295 msg='op=PAM:accounting grantors=pam_unix acct="bsmith" exe="/usr/lib/sddm/sddm-helper" hostname=? addr=? terminal=? res=
    Oct 22 20:19:21 skylake sddm[2251]: Authenticated successfully
    Oct 22 20:19:21 skylake sddm-helper[2350]: pam_kwallet5(sddm-autologin:setcred): pam_kwallet5: pam_sm_setcred
    Oct 22 20:19:21 skylake audit[2350]: CRED_ACQ pid=2350 uid=0 auid=4294967295 ses=4294967295 msg='op=PAM:setcred grantors=pam_permit,pam_kwallet5 acct="bsmith" exe="/usr/lib/sddm/sddm-helper" hostname=? addr=? term
    Oct 22 20:19:21 skylake sddm-helper[2350]: pam_unix(sddm-autologin:session): session opened for user bsmith by (uid=0)
    Appears auto-login does not parse the user's password therefor pam_kwallet receives nothing.

  2. #22

    Default Re: [KDE] No wallet auto-login

    Quote Originally Posted by LinuxMechanic View Post
    Appears auto-login does not parse the user's password therefor pam_kwallet receives nothing.
    Yeah, right.
    That is indeed the problem.
    But the file is correct...

    Btw, they added this to sddm upstream recently:
    https://github.com/sddm/sddm/commit/...66ef12b04d4c55
    https://github.com/sddm/sddm/commit/...17187b0b3bf43f

    I find the comment of the latter one (for the auto-login case) funny now:
    Code:
    Note: It is only working with an empty kwallet password.
    If the kwallet password is empty, you don't need pam_kwallet5 in the first place anyway...
    IOW, that second commit is completely pointless, I'd say.
    Last edited by wolfi323; 22-Oct-2016 at 17:44.

  3. #23

    Default Re: [KDE] No wallet auto-login

    Quote Originally Posted by wolfi323 View Post
    If using Auto-Login, the same change in /etc/pam.d/sddm-autologin should work.

    Btw, to all others: I remember now that we actually use /etc/pam.d/xdm for sddm as well in openSUSE IIANM, so if changing /etc/pam.d/sddm doesn't help, try changing /etc/pam.d/xdm instead.
    tried both but it doesn't works

    my system is running opensuse leap 42.1 with plasma 5.8.2:
    Laptop=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz
    upgraded 13.2 to leap 42.1, using wolfi repos. I'm running KDE 4.14.18 and plasma 5.8.2, KDE frameworks 5.27.0, KDE applications 16.08.2, Kernel 4.1.34-33-default, nvidia drivers, libreoffice 5.1.5.2


  4. #24

    Default Re: [KDE] No wallet auto-login

    Quote Originally Posted by pier_andreit View Post
    tried both but it doesn't works
    Both what?
    /etc/pam.d/sddm and /etc/pam.d/xdm?

    As has been pointed out, it cannot work with auto-login, i.e. changing sddm-autologin doesn't help much.

    So you need to disable auto-login if it's enabled, and then doing the mentioned change to /etc/pam.d/sddm (or xdm?) should work.

    But the above may only apply to sddm (/etc/pam.d/sddm definitely at least), you didn't say what login manager you are using.
    As I wrote already, you may also try to do the changes to common-auth and common-session (and maybe common-password too), that should work for any login manager.

    And also note that you need to use Blowfish encryption for your wallet (not GPG), and the wallet password must be the same as your user login password.
    Last edited by wolfi323; 23-Oct-2016 at 09:22.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •