Results 1 to 6 of 6

Thread: After updates seem there's theme issue with YaST,smplayer

  1. #1

    Default After updates seem there's theme issue with YaST,smplayer

    I'm not sure whats the issue is as when i did updates "zypper dup" after i restarted log back in seems issue with the theme i'm using (Arc Gray) which was working before. Just isn't taking affect to smplayer or YaST or software management.

    However it is working in file manager and if i do su as root file manager it works


    I'm using GNOME DE

  2. #2

    Default Re: After updates seem there's theme issue with YaST,smplayer

    Anybody else having problems, WAS THERE AN UPDATE FOR GNOME? seems themes don't work for smplayer, YaST. Anybody know a fix seems something changed with an update and it just not openSUSE its in my Arch install too.

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,824
    Blog Entries
    15

    Default Re: After updates seem there's theme issue with YaST,smplayer

    Hi
    Works fine here (version 20160923), I don't use smplayer. Maybe force a reintall (metatheme-arc-common-20160923,gtk2-engine-murrine, gtk3-metatheme-arc-20160923 and gtk2-metatheme-arc-20160923) and see if that helps, or swicth to the default theme, restart shell (alt+F2+r) and re-select the arc theme.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4

    Default Re: After updates seem there's theme issue with YaST,smplayer

    AFAIK smplayer is a Qt5 application, and YaST definitely is.
    Unfortunately, the GTK(2) style has been dropped in 5.7.0 (which has been released for Tumbleweed recently), so Qt5 applications cannot use the GTK themes any more.

    See other threads about this topic, and this bug report:
    http://bugzilla.opensuse.org/show_bug.cgi?id=1002900

    A fix is on the way though.

  5. #5

    Default Re: After updates seem there's theme issue with YaST,smplayer

    any fix as of yet??

  6. #6

    Default Re: After updates seem there's theme issue with YaST,smplayer

    Quote Originally Posted by wherewolf View Post
    any fix as of yet??
    Yes, the GTK2 style has been packaged again meanwhile in libqt5-qtstyleplugins-platformtheme-gtk2.
    It's not in Tumbleweed yet, you need to install it from KDE:Qt5 for now:
    http://software.opensuse.org/package...formtheme-gtk2

    Or you can use libqt5-qtct to configure Qt5 applications' look separately from GNOME/GTK.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •