Results 1 to 3 of 3

Thread: KDE doesn't start up: Could not connect to d-bus server

  1. #1

    Default KDE doesn't start up: Could not connect to d-bus server

    I haven't restarted my workstation for a while because I've been busy running simulations for a while. This morning I thought it would be a good idea to update my system and restart it:

    Code:
    sudo zypper up
    sudo reboot
    I'm currently on kernel 4.3.31-30-default, KDE Plasma version no idea, but probably 5+. Is there a way to check without actually being in KDE itself? For example, asking for which version of kate I have installed reports with this:

    Code:
    QXcbConnection: Could not connect to display
    Aborted
    After restarting the system, I get this cryptic error message along with a blank screen:

    Code:
    can't start D-Bus. Can you call qdbus-qt5?


    Rebooting into runlevel 3 gives me no problems (I'm pretty sure this is a desktop issue), so I was able to log in and call qdbus-qt5. This was my output:

    Code:
    Could not connect to D-bus server: org.freedesktop.DBus.Error.NotSupported: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11


    This looks like a related thread, but I think the issue there came down to repositories which I don't have, which it less applicable. Running zypper lr -d comes up with the following:

    Code:
    #  | Alias                           | Name                                                       | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                    | Service---+---------------------------------+------------------------------------------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------------------------------+--------
     1 | devel_languages_python          | Python Modules (openSUSE_Leap_42.1)                        | Yes     | (r ) Yes  | No      |   98     | rpm-md | http://download.opensuse.org/repositories/devel:/languages:/python/openSUSE_Leap_42.1/ |        
     2 | download.nvidia.com-leap        | nVidia Graphics Drivers                                    | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/leap/42.1                                          |        
     3 | download.opensuse.org-non-oss   | Main Repository (NON-OSS)                                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/                      |        
     4 | download.opensuse.org-non-oss_1 | Update Repository (Non-Oss)                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/                                 |        
     5 | download.opensuse.org-oss       | Main Repository (OSS)                                      | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/oss/                          |        
     6 | download.opensuse.org-oss_1     | Main Update Repository                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss                                      |        
     7 | ftp.gwdg.de-suse                | Packman Repository                                         | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_42.1/                          |        
     8 | repo-debug                      | openSUSE-Leap-42.1-Debug                                   | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/                    |        
     9 | repo-debug-non-oss              | openSUSE-Leap-42.1-Debug-Non-Oss                           | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/non-oss/                |        
    10 | repo-debug-update               | openSUSE-Leap-42.1-Update-Debug                            | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/oss                                |        
    11 | repo-debug-update-non-oss       | openSUSE-Leap-42.1-Update-Debug-Non-Oss                    | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/non-oss/                           |        
    12 | repo-source                     | openSUSE-Leap-42.1-Source                                  | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/                   |        
    13 | repo-update                     | openSUSE-Leap-42.1-Update                                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/                                     |        
    14 | science                         | Software for Scientists and Engineers (openSUSE_Leap_42.1) | Yes     | (r ) Yes  | No      |   98     | rpm-md | http://download.opensuse.org/repositories/science/openSUSE_Leap_42.1/                  |

    On this bug report page from ubuntu
    , they recommend you change around some sources (specifically /usr/bin/startkde) to fix the issue, but I don't understand what that does and I'm worried I could create an irreversible change.

    I have qdbus-qt5, but I don't know how to solve this error. I would appreciate any help I could get.

    Cheers,
    C

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,478

    Default Re: KDE doesn't start up: Could not connect to d-bus server

    After booting to (old syntax) Runlevel 3, please post the systemd journal entries for the "--this-boot" following an "init 5".
    At Runlevel 3, you could also post the systemd journal entries related to the D-Bus.
    Are you sure that you have a 4.3 Kernel?
    On my Leap 42.1 system the Kernel is 4.1.31-30-default.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,650
    Blog Entries
    14

    Default Re: KDE doesn't start up: Could not connect to d-bus server

    This is not a dbus issue. The output says there's no display provided by the X server. Whenever NVIDIA is involved this usually means there's something wrong with the driver/kernel module, which should be provided by the nvidia repo.
    What you should be able to do, is to boot the previous kernel, through the Advanced options in the GRUB2 boot menu.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •