Results 1 to 9 of 9

Thread: OpenSUSE keep reinstalling after initial install

  1. #1

    Default OpenSUSE keep reinstalling after initial install

    I have just successfully completed my first ever OpenSUSE installation (42.1) on an AMD computer with 3 distinct Hard Drives. Initially I was running Windows 7 and wanted to install OpenSUSE on the third Hard Drive (640G empty, no partition, but mounted and functional). The second Hard drive D: is for data only and pretty full ( 95% of 640G ) To do so I downloaded OpenSUSE 42.1 ISO file and virtually mounted the ISO file as a virtual DVD drive. Then fired the openSUSE42_1_LOCAL.exe file from Windows7. All went well during installation. My C: drive is where Windows 7 is installed. OpenSUSE automatically chose to install on the empty hard drive marked G: in Windows 7. After the installation completed I got a message for rebooting. Then the choice screen asking for Windows7 or the OpenSUSE Installation ( again ??? ). I chose the second. Some installation procedure completed and I ended up with the same installation screen as before. Just as if I had to install OpenSUSE again. I chose to reboot again, this time selected Windows 7, and, as expected, got my Windows 7 system booted. Rebooted the computer again and tried the second option call OpenSUSE Installation, same thing. I got the same installation screen as if I was to repeat the installation. Bottom line, my newly installed OpenSUSE is not booting properly, instead I boot with the installation procedure.

    What have I done wrong ? How can I fix this ?

    Thank you so much for your help

    PS: My Linux knowledge is equivalent to approximately 0.5 on a scale of 1 to 10. (just to let you know)

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: OpenSUSE keep reinstalling after initial install

    Use a real DVD or USB drive. You confuse things with a virtual DVD. And running installer from Windows simply will not work as you have proven.

    You also need to define how you are to boot. To install on a modern UEFI based machine you need to boot the installer in EFI mode. In any case all OS involved need to boot in the same mode (MBR or EFI) or they won't be able to chain.

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,292
    Blog Entries
    2

    Default Re: OpenSUSE keep reinstalling after initial install

    Although using a virtual cd/dvd device is unusual, it sounds like it might have worked for you.

    If I were to guess, you still have your virtual cd/dvd configured to be loaded on boot, and you're booting to your install media instead of the partition or disk where your install openSUSE exists(unmount your virtual cdrom).

    If that isn't the problem, then your grub may not be pointing to the correct disk and partition for your openSUSE boot, but nowadays, the os-prober should have figured that out when your grub.cfg was created the first time.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  4. #4
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: OpenSUSE keep reinstalling after initial install

    Quote Originally Posted by tsu2 View Post
    Although using a virtual cd/dvd device is unusual, it sounds like it might have worked for you.

    If I were to guess, you still have your virtual cd/dvd configured to be loaded on boot, and you're booting to your install media instead of the partition or disk where your install openSUSE exists(unmount your virtual cdrom).
    ... yes, that is my guess, as well. You beat me to it.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  5. #5

    Default Re: OpenSUSE keep reinstalling after initial install

    Thank you all for your quick feedback, it was inspiring in my attempt to experiment a bit and finally I was able to boot my OpenSUSE installation. I had to physically remove my C: drive and change my BIOS to force boot on the (was) G: as being the OpenSUSE installation drive. Somehow it worked! Don't ask me why, I haven't the slightest clue. The computer booted on OpenSUSE and I was able, for my first time, to peruse the OS! .
    Now, If I plug back my C: Windows 7 drive, I will, as before, boot on Windows 7 with no screen choice for witch OS to boot from. That is because previous to remove my C: drive I ran the uninstall OpenSUSE that was starting automatically at Win7 boot. Running the uninstall removed the initial OS choice screen, hence no more choice. Now I have to revert this remove.

    How can I implement a double boot system with such a configuration ?

    At the moment I have Win7 that boot by default on my C: drive if installed, I have OpenSUSE that boot from the G: drive if the C: drive is physically removed from the computer or if I force my BIOS to choose the OpenSUSE drive as the preferred boot drive.

    How can I implement Dual Boot from this configuration ?
    Thanks again for any help

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: OpenSUSE keep reinstalling after initial install

    Seems you like finding the hard way. Dual boot is not normally that big a problem if you follow the install directions.

    Just a point you are using Windows terminology of X drive this or that and Windows actually designates partitions with drive letters. So saying X drive we don't know what you are talking about LOL. MS likes to confuse people. In Unix/Linux the drivers are designated sdx where x is a letter indicating the drive order and partitions on the drive is indicated by adding a number like sda1 for the first drive first partition.


    First off need to know if you are installing with a EFI boot or MBR boot. It makes a difference how to proceed.

    But since you installed on a secondary drive then replaced it with a new boot you may only need to change the boot order n the BIOS or UEFI which ever one you have. On the other hand I don't understand what you deleted ie "uninstall OpenSUSE that was starting automatically at Win7 boot"

    Since Windows was not there at install openSUSE grub boot loader knows nothing about it so you will have to go to Yast -bootloader and check box to scan for foreign OS This should add it to the boot menu.
    Note that all OS must use the same boot method (EFI or MBR) in order to chain

  7. #7

    Default Re: OpenSUSE keep reinstalling after initial install

    Thank you Gogalthorp for your comments,
    Sorry if my "language" is not quite adapted to the Linux community. As mentioned previously, my knowledge on this filed is about 0.5 on a scale of 1 to 10. I'll attempt to adapt as best to my abilities.
    Just a few clarifications so we understand the technical aspect of the problem. First, When I mention C: D: and G: drive, in this particular case I am referring to really physical drives. So in Linux language they are sda, sdb and sdc respectively. Referring to your first post, I could not use a real DVD because my real DVD caught on fire some time ago and I never bothered replacing it due to lack of need. To me DVD drives are becoming part of a prehistoric era apparatus (so is my computer, but that is another topic in itself) . As for booting with a USB key (with OpenSUSE installer) my bios do not offer the capability to boot on a USB key. Since I had an extra 640G hard drive laying around, I decided I would attempt to install OpenSUSE on that third, newly installed, drive (empty, unformated, blank). Also, UEFI, EFI and MBR are kind of strange concepts for me. I understand that MBR stands for Master Boot Record and it hold a little program to direct the uC to a more elaborate boot sequence, but that's about where my knowledge stand at the moment. I will have to do some substantial reading on the two other terms. In the mean time I need to dual boot with my installation. Thanks for your patience Since I was originally using Win7 my computer was most probably using the MBR option (if that makes any sense). Now, I am glad to read that "Dual boot is not normally that big a problem if you follow the install directions". In my case, since nothing started normally and neither ended up normally, I kind of hesitate to follow the "install directions" as probably it will not cover the intricate details of my installation route.

    Now, at this point it is probably adequate to lay down all my installation details. Standby, it's not too long a list.
    1- Boot with Windows 7 ( HD1 (or sda) contain the Win7 OS and all programs installed 120G - HD2 (or sdb) contain data of all sorts 640G - HD3 (or sdc) contain nothing, empty, not formatted 640G )
    2- From UltraISO app I mounted the "openSUSE-Leap-42.1-DVD-x86_64.iso" as a virtual DVD drive identified as E: in MS jargon. Now I have a virtual drive from which I can start the install .exe
    3- From Windows Explorer I started the "openSUSE42_1_LOCAL.exe" file from the E: DVD virtual drive. I got an install app running in Windows 7 environment.
    4- I followed the instructions with default choices and completed the installation up to the point where the Installation App is requesting a reboot. I found out afterword that OpenSUSE was installed on sdc. Great, that's what I wanted.
    5- At reboot I got a new window asking to choose booting between Windows 7 or OpenSUSE Installation ( Notice here is says "Installation" Why ? that is a mystery to me)
    6- I instinctively chose the OpenSUSE Installation boot choice. I ended up with the same Installation procedure as the one obtained from Windows 7 (see point 4)
    7- Since I had already installed OpenSUSE I decided to abort and retry booting with Windows 7 and see what happen. When I got to the Win7 desktop there was this UnInstall OpenSUSE App that had started automatically. The only choices possible were A) UnInstall OpenSUSE or B) Abort and close the UnInstall App. I decided to Abort.
    8- After a few attempts to reboot with both Win7 and OpenSUSE I decided to proceed and UnInstall OpenSUSE from the Win7 Environment. The process was Very Quick and the App closed.
    9- Rebooted and the Booting choice windows was no longer there, hence booted automatically with Win7.
    10- Then I decided to physically remove my C: drive and command my bios to boot on the drive on which I had installed OpenSUSE. It is then that I was able to boot with OpenSUSE.
    11- This new boot triggered the installation of OpenSUSE again. I repeated the installation successfully and followed instructions up to the Reboot request.
    12- At reboot I got the OpenSUSE environment running well.

    That is exactly what I did and it ended up working.
    Now, If I plug back my C: drive and command the Bios to boot on it, I will get Win7 by default. If I command the Bios to boot on sdc I will get OpenSUSE.
    Can I implement Dual Boot without screwing up everything ? If so, what are the things to watch for ?

    Sorry, I realize this is a long post but it layout pretty much everything I can tell about my adventure.
    Thanks for your patience and help
    Cheers

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,744

    Default Re: OpenSUSE keep reinstalling after initial install

    Of course, leave the BIOS pointing to openSUSE. Since you installed openSUSE without Windows disk openSUSE has no way of knowing anything about Windows. So you must tell it to scan for foreign OS. This can be done from Yast -bootloader. Go there and check the box that says scan for foreign OS. Accept and next boot Windows should appear in boot menu.

    Note if box is checked then uncheck and check again so the program knows you changed something

    Note2 above assumes that both OS are installed using the same boot method ie either MBR or EFI boot. Since you installed in a odd manner it is not entirely sure which boot method was used and how Windows boots. But only worry about it if Windows does not show up in grub boot menu after you have done the above.

  9. #9

    Default Re: OpenSUSE keep reinstalling after initial install

    Thank you Gogalthorp. For some reason that I ignore, when I rebooted with both HD connected and Bios pointing to sdc (openSUSE installation) I suddenly got for the first time a new screen from openSUSE asking me to choose between openSUSE, openSUSE advanced options, and Windows7. So, I guess YaSt did it's job after all, I just had not tried yet this booting scheme with both drives connected simultaneously. Anyway, I am glad that I can dual boot finally. I still went and peruse through YaST just to see what you had described and found the "Scan Foreign OS" (In french though, was a bit tricky to interpret but I managed). I could not see anywhere to confirm whether the OSs were using which boot method, EFI or MBR. That is going to be another topic all together, I guess.

    Anyway, Now I am in a much more comfortable situation. I can Dual Boot and finally I can start learning my new OS openSUSE.
    Thank you Very Much for your help.

    Cheers

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •