Results 1 to 2 of 2

Thread: openSUSE feels slower than it should be, what to check?

  1. #1
    Join Date
    Jan 2009
    Location
    Romania, Bucharest
    Posts
    764

    Default openSUSE feels slower than it should be, what to check?

    I know it's a common tendency for people to feel their operating system is too slow. In my case though, I'm getting the feeling that my openSUSE installation is running a bit slower than it was and than it should be. This mostly comes from the fact that it sometimes takes +10 seconds to open a fresh instance of Dolphin or Konsole or KWrite, which are considerably small programs so this is quite inexplicable! The RAM is almost never more than 40% full, nor do I typically have more than about 8% CPU used idly. I have an i7 920 processor and 9 GB of RAM, so this can't be blamed on an old machine either.

    Although it's unconfirmed, I'm getting the impression that slow drive I/O might be at fault... if not then some kind of driver or Kernel setting. The OS is installed on a SATA2 drive, with my data on a SATA3... other than that I disabled all costly processes I was aware of, such as the evil Baloo file indexer. A problem I can notice and test directly is that if a process is using a hard drive, every other process that attempts to access that drive freezes for several seconds (goes into "disk sleep" mode) which is definitely a huge annoyance but I figure unavoidable. Anything else I can check?
    openSUSE Tumbleweed x64, KDE Framework 5

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: openSUSE feels slower than it should be, what to check?

    Maybe smartctl would give a clue

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •