Results 1 to 3 of 3

Thread: Plasma 5 RPM Install

  1. #1

    Post Plasma 5 RPM Install

    Hi,


    I am kind of new to OpenSuse I need a little help, please

    When I try to install an RPM by right clicking on it and say open with package install i get the following error

    "KDEInit could not launch 'gpk-install-local-file':
    Could not open library 'libkdeinit5_gpk-install-local-file'.
    Cannot load library libkdeinit5_gpk-install-local-file: (libkdeinit5_gpk-install-local-file: cannot open shared object file: No such file or directory)"

    I installed from the DVD and I use Plasma 5 as my Desktop Environment. When I double click it just opens Ark.

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Plasma 5 RPM Install

    the DVD is old, very old
    do an update
    Code:
    sudo zypper up
    then if you want to install a local rpm with yast from dolphin do this:
    #1 create a new desktop file called yast-software-installer so open a terminal and execute this
    Code:
    kate ~/.local/share/applications/yast-software-installer.desktop
    #2 paste this text block in it
    Code:
    [Desktop Entry]
    Name=YaST Software Installer
    Exec=xdg-su -c "/sbin/yast2 sw_single %F"
    MimeType=application/x-rpm;
    NoDisplay=true
    Type=Application
    #3 save the file
    now when right clicking on an rpm in dolphin (or other file managers) you will have a new command "YaST Software Installer" that will allow you to install said rpm file

  3. #3
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,153

    Default Re: Plasma 5 RPM Install

    Quote Originally Posted by Quicken2k View Post
    I am kind of new to OpenSuse

    When I try to install an RPM by right clicking on it and say open with package install i get the following error

    "KDEInit could not launch 'gpk-install-local-file':
    Could not open library 'libkdeinit5_gpk-install-local-file'.
    Cannot load library libkdeinit5_gpk-install-local-file: (libkdeinit5_gpk-install-local-file: cannot open shared object file: No such file or directory)".
    It seems at face value that the RPM in question requires a shared library that is not installed. What RPM, and where did it come from? Installing packages from without the openSUSE or Packman Leap-42.1 repositories is generally not advisable for beginners. If you can install from the default installed repositories with YaST most problems will disappear. It is often easier to compile and install from source than to install an alien package.

    I installed from the DVD and I use Plasma 5 as my Desktop Environment. When I double click it just opens Ark.
    Have you applied the latest patches (with YaST Online Update)? Double-clicking is generally an Apple and Microsoft affectation (to avoid blatant copying of pre-existing Unix systems and enable their copyright an patent claims for trivial variations) -- the default in Unix and Linux derivatives is a single click. RPMs open in Ark because the packages are archives of compressed files (as are Open Document files). The default response to a “click” can be changed in “System Settings -> Applications -> File Associations”.
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •