Results 1 to 9 of 9

Thread: Yast and LANG .. no connection?

  1. #1

    Default Yast and LANG .. no connection?

    running "env" from the command line shows
    LANG=en_IE.US-ASCII

    I want to change this as I definitely want utf-8 support.
    Dont know how ascii got there .. maybe I oversaw some default setting in the installer.
    No matter what I do in YAST - Langauge
    Ive tried setting the primary langauge to German, reboot, back to English etc..nothing seems to alter the LANG envrironment variable .. shouldn't it?
    Isnt this what Yast-Langugae is for setting my locale (including LANG) ?

    Thanks very much in Advance.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,700

    Default Re: Yast and LANG .. no connection?

    Lang is set in at least two places 1 in yast for system function and then in the desktop since different user may want different language settings,

  3. #3

    Default Re: Yast and LANG .. no connection?

    Well what I do in Yast seems to make no difference? Would have thought calling env on the command line is a "system function"?

    In StartMenu - Settings- System Settings - Regional Settings (presumably this is what you mean by the "desktop") , I have
    Preferred Languages:
    British English
    Deutsch


    Neither correspond to US and I cant see anywhere to specify the encoding (ie ascii vs utf-8)

    Any elaboration /clarification would be appreciated

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,700

    Default Re: Yast and LANG .. no connection?

    Yast sets system settings what ever desktop you use sets personal settings. Remember Linux is multi user and each user can have their own settings.

  5. #5

    Default Re: Yast and LANG .. no connection?

    I understand.
    However my question remains:
    How can I use the GUI to change
    "LANG=en_IE.US-ASCII"
    to say
    "LANG=en_US.UTF-8" ?

    And why does neither changing the language setting in Yast nor the StartMenu - Settings- System Settings - Regional Settings
    seem to affect the value of "LANG"?

  6. #6

    Default Re: Yast and LANG .. no connection?

    In general the langauge/locale settings in the ui seem to be a mess.
    Despite having "English" as the main/preferred language in both yast and system settings, my ui is partly in German and partly in English
    (ironically both the yast ui and the ui for system settings are in German even though the settings made there say "use English")!

  7. #7
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,131

    Default Re: Yast and LANG .. no connection?

    Quote Originally Posted by p8mode View Post
    running "env" from the command line shows
    LANG=en_IE.US-ASCII

    I want to change this as I definitely want utf-8 support.
    Dont know how ascii got there .. maybe I oversaw some default setting in the installer.
    No matter what I do in YAST - Langauge
    YaST → System → Language → Details → Use UTF-8 Encoding
    ~Thank you for sharing an interesting problem.
    --
    slàinte mhath,
    rayH

  8. #8

    Default Re: Yast and LANG .. no connection?

    Thanks for the suggestion.
    utf-8 checkbox is selected here. However
    > echo $LANG
    en_IE.US-ASCII

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,515

    Default Re: Yast and LANG .. no connection?

    Quote Originally Posted by p8mode View Post
    Despite having "English" as the main/preferred language in both yast and system settings, my ui is partly in German and partly in English
    (ironically both the yast ui and the ui for system settings are in German even though the settings made there say "use English")!
    Please check /etc/sysconfig/language -- on this machine RC_LANG="de_DE.UTF-8" and INSTALLED_LANGUAGES="de_DE,en_GB" -- both set-up via YaST -->> System -->> Language (Details).
    If YaST is misbehaving, you may have some extraneous characters or an "off-limits" value in /etc/sysconfig/language.
    In addition check the user's .profile and .bashrc files -- in .profile there should be something like export LANG=en_GB.UTF-8 -- this should never be in .bashrc.
    Please note the following comment in .bashrc located in /etc/skel/:
    Code:
    # NOTE: It is recommended to make language settings in ~/.profile rather than
    # here, since multilingual X sessions would not work properly if LANG is over-
    # ridden in every subshell.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •