Results 1 to 10 of 10

Thread: startkde3 not starting automatically and yast2 not working after upgrade 13.2 => 42.1

  1. #1

    Default startkde3 not starting automatically and yast2 not working after upgrade 13.2 => 42.1

    hello!

    just did upgrade from 13.2 to Leap 42.1
    the upgrade was done by upgrading all the repositories to their L42.1 counterpart and choosing update all packages in YaST2 / Software management.
    had a number of conflicts and chose not to upgrade a number of packages to the most recent version to solve those as well as removing 6 packages.
    have been updating my config this way since 12(.1 i think) without problem until now.
    after rebooting the boot ends at the command prompt login where i can login and startx
    not really good as system is supposed to start and always started in the past to runlevel 5.
    once there YaST2 is not starting with

    Code:
    Command: /sbin/yast2 repositories &
    The config 'root' does not exist. Likely snapper is not configured.
    See 'man snapper' for further instructions.
    terminate called after throwing an instance of 'YUIPluginException'
      what():  Couldn't load plug-in qt
    YaST got signal 6 at file /usr/share/YaST2/modules/Wizard.rb:782
      sender PID: 5797
    /sbin/yast2: line 440:  5797 Aborted                 $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    Invalid snapshot ''.
    Command: /sbin/yast2 sw_single &
    The config 'root' does not exist. Likely snapper is not configured.
    See 'man snapper' for further instructions.
    terminate called after throwing an instance of 'YUIPluginException'
      what():  Couldn't load plug-in qt
    YaST got signal 6 at file /usr/share/YaST2/modules/Wizard.rb:782
      sender PID: 5843
    /sbin/yast2: line 440:  5843 Aborted                 $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    Invalid snapshot ''.
    i'm using ext3 for all my Linux partitions because i'm still using (happily) partimage to backup all my OSes on my system and ext3 is the latest that partimage supports + never had any problems with ext3 and really don't care about all the "new" features.

    thus i don't need snapper in any way.

    any idea?
    A strong conviction that something must be done is the parent of many bad measures.
    - Daniel Webster

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,344

    Default Re: startkde3 not starting automatically and yast2 not working after upgrade 13.2 => 42.1

    Need to use zypper dup to do the upgrade. Not certain it can be done from Yast

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,944

    Default Re: startkde3 not starting automatically and yast2 not working after upgrade 13.2 => 42.1

    Quote Originally Posted by gogalthorp View Post
    Not certain it can be done from Yast
    Probably not, because YaST will be amongst the packages upgraded. Also, the OP does not say so, but he could even mean he used YaST from his desktop and thus more packages in use upgraded.

    I am also pretty sure that doing this through YaST software manager as described by the OP is nowhere documented as a valid method.

    Maybe the best starting point is to show to people here what your situation is now:
    Code:
    zypper lr -d
    Henk van Velden

  4. #4

    Default Re: startkde3 not starting automatically and yast2 not working after upgrade 13.2 => 42.1

    Quote Originally Posted by hcvv View Post
    Probably not, because YaST will be amongst the packages upgraded. Also, the OP does not say so, but he could even mean he used YaST from his desktop and thus more packages in use upgraded.

    I am also pretty sure that doing this through YaST software manager as described by the OP is nowhere documented as a valid method.

    Maybe the best starting point is to show to people here what your situation is now:
    Code:
    zypper lr -d
    Code:
    #  | Alias             | Name              | Enabled | GPG Check | Refresh | Priority | Type     | URI                                                                      | Service
    ---+-------------------+-------------------+---------+-----------+---------+----------+----------+--------------------------------------------------------------------------+--------
     1 | KDE3              | KDE3              | Yes     | (r ) Yes  | No      |   10     | rpm-md   | http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_Leap_42.1/  |
     2 | MEGAsync          | MEGAsync          | Yes     | (r ) Yes  | No      |   99     | rpm-md   | http://mega.nz/linux/MEGAsync/openSUSE_Leap_42.1/                        |
     3 | NVidia            | NVidia            | Yes     | (r ) Yes  | No      |   19     | rpm-md   | http://download.nvidia.com/opensuse/leap/42.1/                           |
     4 | OSS_-_Update      | Update - Oss      | Yes     | (r ) Yes  | No      |   28     | rpm-md   | http://download.opensuse.org/update/leap/42.1/oss                        |
     5 | Packman           | Packman           | Yes     | (r ) Yes  | No      |   20     | rpm-md   | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42.1/       |
     6 | RPMs              | RPMs              | Yes     | ( p) Yes  | Yes     |   19     | plaindir | dir:///rpm                                                               |
     7 | Source_-_Non-Oss  | Source - Non-Oss  | No      | ----      | No      |   29     | yast2    | http://download.opensuse.org/source/distribution/leap/42.1/repo/non-oss/ |
     8 | Update_NON-OSS    | Update - Non-Oss  | Yes     | (r ) Yes  | No      |   29     | rpm-md   | http://download.opensuse.org/update/leap/42.1/non-oss/                   |
     9 | google-chrome     | google-chrome     | Yes     | (r ) Yes  | No      |   99     | rpm-md   | http://dl.google.com/linux/chrome/rpm/stable/x86_64                      |
    10 | google-talkplugin | google-talkplugin | Yes     | (r ) Yes  | No      |   59     | rpm-md   | http://dl.google.com/linux/talkplugin/rpm/stable/x86_64                  |
    11 | repo-debug        | Debug             | No      | ----      | No      |   30     | yast2    | http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/      |
    12 | repo-debug-update | Update - Debug    | No      | ----      | No      |   35     | rpm-md   | http://download.opensuse.org/debug/update/leap/42.1/oss                  |
    13 | repo-non-oss      | Non-Oss           | Yes     | (r ) Yes  | No      |   29     | yast2    | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/        |
    14 | repo-oss          | Oss               | Yes     | (r ) Yes  | No      |   28     | yast2    | http://download.opensuse.org/distribution/leap/42.1/repo/oss/            |
    15 | repo-source       | Source            | No      | ----      | No      |   25     | yast2    | http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/     |

    as i mentioned i have been upgrading my openSuSE setup for as long as i can remember. i mentioned as starting point 12(.1) because a couple years ago i ran into problems where a fresh install seemed the easiest way out.

    anyway, did i mention partimage? i can roll back to 13.2 and try the zypper dup approach.
    how does zypper handle conflicts? there were quite a few and i see no reason they wouldn't appear with zypper, no?
    A strong conviction that something must be done is the parent of many bad measures.
    - Daniel Webster

  5. #5

    Default Re: startkde3 not starting automatically and yast2 not working after upgrade 13.2 => 42.1

    Quote Originally Posted by hcvv View Post
    Probably not, because YaST will be amongst the packages upgraded. Also, the OP does not say so, but he could even mean he used YaST from his desktop and thus more packages in use upgraded.

    I am also pretty sure that doing this through YaST software manager as described by the OP is nowhere documented as a valid method.

    [...]
    Code:
    zypper lr -d
    then you wouldn't be able to use YaST2 to upgrade KDE or any other desktop as they are always in use when running YaST2...
    A strong conviction that something must be done is the parent of many bad measures.
    - Daniel Webster

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,944

    Default Re: startkde3 not starting automatically and yast2 not working after upgrade 13.2 => 42.1

    Your repos look OK to me. Apart from the non-openSUSE ones for which I have no comment. IIRC the recommendation is to at least disable them during the zypper dup that does the upgrade. And then after that is succesfull, to change them to their 42.1 versions (if applicable), enable them again and install from them what you need. This includes Packman. First disable it, then after the zypper dup, change to Packman 42.1 and do "the switch" (e.g. zypper dup --from <something-that-identifies-the-Packman-repo>)

    My advice: disable all except OSS, non-OSS and their Updates repos. Then do a
    Code:
    zypper dup
    to get the LEAP 42.1 packages replacing the 13.2 packages.
    Please try that to see if you get any error messages (you can say no to abort it before it does something).
    When in doubt first ask here (of course posting the messages).
    Henk van Velden

  7. #7

    Default Re: startkde3 not starting automatically and yast2 not working after upgrade 13.2 => 42.1

    okay, will try that - not sure i will be able to pull it through today anymore thus would have to wait next weekend.
    thanks for the advice so far.
    A strong conviction that something must be done is the parent of many bad measures.
    - Daniel Webster

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,944

    Default Re: startkde3 not starting automatically and yast2 not working after upgrade 13.2 => 42.1

    I will be on vacation then , but others will help you further.
    Henk van Velden

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,344

    Default Re: startkde3 not starting automatically and yast2 not working after upgrade 13.2 => 42.1

    I notice you have KDE3 repo so I assume that is the desktop you use?? Possible point of conflict.

    Also the error you showed concerns snapper and you use ext3 which I doubt hardly anyone else uses these days. In theory any way snapper is supposed to be usable in ext4 but not in ext3. I suppose that the developers never considered anyone would still use ext3 for the root.

    It may be time to move from the dark ages into the light and do a new install using more modern systems.

  10. #10

    Default Re: startkde3 not starting automatically and yast2 not working after upgrade 13.2 => 42.1

    Probably we should start investigating the "real" problem, that Xorg doesn't start?

    What does "systemctl get-default" say?
    What displaymanager have you set in /etc/sysconfig/displaymanager?
    Code:
    grep DISPLAYMANAGER /etc/sysconfig/displaymanager
    To fix YaST, try to run this:
    Code:
    sudo zypper in -f libyui-qt7 libyui-qt-pkg7

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •