Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 53

Thread: smplayer 16.9 isn't playing video

  1. #21
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: smplayer 16.9 isn't playing video

    Quote Originally Posted by wherewolf View Post
    I'm unclear to what this is supposed to do. How does this help me get smplayer to work
    the first command does a full vendor change with packman, the 2nd sets packman's priority to 90 (lower numbers are higher priorety) so that packman is a proffered repo
    this is specific to your system as packman was repo #5 for you for other people it will be different

  2. #22

    Default Re: smplayer 16.9 isn't playing video

    Well smplayer still isn't working

  3. #23
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: smplayer 16.9 isn't playing video

    does mpv work?
    if so try the smplayer from the oss repo

  4. #24
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: smplayer 16.9 isn't playing video

    I did a check and it looks like smplayer throws that eror if mplayer or mpv is not installed but selected as the decoder,
    as I use mpv I had no issues.
    so in smplayer's preferences select mpv (or mplayer if it's installed) as the proffered multimedia engine


    but as you are using TW it could also be the video card and or driver
    what kind of card do you have?
    if intel (or amd) disable vdpau and use vaapi (as vdpau is nvidia tech and intel has issues with it)

    if you have an nvidia card did you install the propitiatory driver the hard way as novou has issues with hardware decoding

    check if mplayer or mpv are installed they might have been removed
    Code:
    zypper info mplayer mpv
    this is what I get
    Code:
    a@linux:~> zypper info mplayer mpv
    Loading repository data...
    Reading installed packages...
    
    
    Information for package MPlayer:
    --------------------------------
    Repository: Packman Repository
    Name: MPlayer
    Version: 1.2.r37548-6.4
    Arch: x86_64
    Vendor: http://packman.links2linux.de
    Installed: No
    Status: not installed
    Installed Size: 10,1 MiB
    Summary: Multimedia Player
    Description: 
      MPlayer plays most MPEG/VOB, AVI, Ogg/OGM, VIVO, ASF/WMA/WMV, QT/MOV/MP4,
      RealMedia, Matroska, NuppelVideo, FLI, YUV4MPEG, FILM, RoQ, PVA files,
      supported by many native, XAnim, and Win32 DLL codecs. You can watch VideoCD,
      SVCD, DVD, 3ivx, DivX 3/4/5 and even WMV movies..
      
      Note that the GUI frontend "gmplayer" is not part of this package.
      Instead, you must also install the package "gmplayer".
    
    Information for package mpv:
    ----------------------------
    Repository: Packman Repository
    Name: mpv
    Version: 0.20.0-59.1
    Arch: x86_64
    Vendor: http://packman.links2linux.de
    Installed: Yes
    Status: up-to-date
    Installed Size: 1,8 MiB
    Summary: Advanced general-purpose multimedia player
    Description: 
      mpv is a movie player based on MPlayer and mplayer2. It supports a wide variety
      of video file formats, audio and video codecs, and subtitle types.
    edit and my smplayer is from KDE:Extra
    Code:
    a@linux:~> zypper info smplayer
    Loading repository data...
    Reading installed packages...
    
    
    Information for package smplayer:
    ---------------------------------
    Repository: Additional packages maintained by the KDE team (openSUSE_Leap_42.1)
    Name: smplayer
    Version: 16.9.0-29.1
    Arch: x86_64
    Vendor: obs://build.opensuse.org/KDE
    Installed: Yes
    Status: up-to-date
    Installed Size: 4,3 MiB
    Summary: Complete frontend for MPV
    Description: 
      SMPlayer intends to be a complete front-end for MPV/MPlayer, from
      basic features like playing videos, DVDs, and VCDs to more
      advanced features like support for MPV filters and more.
      
      One of the most interesting features of SMPlayer: it remembers the
      settings of all files you play. So you start to watch a movie but
      you have to leave... don't worry, when you open that movie again it
      will resume at the same point you left it, and with the same
      settings: audio track, subtitles, volume...

  5. #25

    Default Re: smplayer 16.9 isn't playing video

    Quote Originally Posted by I_A View Post
    I did a check and it looks like smplayer throws that eror if mplayer or mpv is not installed but selected as the decoder,
    as I use mpv I had no issues.
    so in smplayer's preferences select mpv (or mplayer if it's installed) as the proffered multimedia engine


    but as you are using TW it could also be the video card and or driver
    what kind of card do you have?
    if intel (or amd) disable vdpau and use vaapi (as vdpau is nvidia tech and intel has issues with it)

    if you have an nvidia card did you install the propitiatory driver the hard way as novou has issues with hardware decoding

    check if mplayer or mpv are installed they might have been removed
    Code:
    zypper info mplayer mpv
    this is what I get
    Code:
    a@linux:~> zypper info mplayer mpv
    Loading repository data...
    Reading installed packages...
    
    
    Information for package MPlayer:
    --------------------------------
    Repository: Packman Repository
    Name: MPlayer
    Version: 1.2.r37548-6.4
    Arch: x86_64
    Vendor: http://packman.links2linux.de
    Installed: No
    Status: not installed
    Installed Size: 10,1 MiB
    Summary: Multimedia Player
    Description: 
      MPlayer plays most MPEG/VOB, AVI, Ogg/OGM, VIVO, ASF/WMA/WMV, QT/MOV/MP4,
      RealMedia, Matroska, NuppelVideo, FLI, YUV4MPEG, FILM, RoQ, PVA files,
      supported by many native, XAnim, and Win32 DLL codecs. You can watch VideoCD,
      SVCD, DVD, 3ivx, DivX 3/4/5 and even WMV movies..
      
      Note that the GUI frontend "gmplayer" is not part of this package.
      Instead, you must also install the package "gmplayer".
    
    Information for package mpv:
    ----------------------------
    Repository: Packman Repository
    Name: mpv
    Version: 0.20.0-59.1
    Arch: x86_64
    Vendor: http://packman.links2linux.de
    Installed: Yes
    Status: up-to-date
    Installed Size: 1,8 MiB
    Summary: Advanced general-purpose multimedia player
    Description: 
      mpv is a movie player based on MPlayer and mplayer2. It supports a wide variety
      of video file formats, audio and video codecs, and subtitle types.
    edit and my smplayer is from KDE:Extra
    Code:
    a@linux:~> zypper info smplayer
    Loading repository data...
    Reading installed packages...
    
    
    Information for package smplayer:
    ---------------------------------
    Repository: Additional packages maintained by the KDE team (openSUSE_Leap_42.1)
    Name: smplayer
    Version: 16.9.0-29.1
    Arch: x86_64
    Vendor: obs://build.opensuse.org/KDE
    Installed: Yes
    Status: up-to-date
    Installed Size: 4,3 MiB
    Summary: Complete frontend for MPV
    Description: 
      SMPlayer intends to be a complete front-end for MPV/MPlayer, from
      basic features like playing videos, DVDs, and VCDs to more
      advanced features like support for MPV filters and more.
      
      One of the most interesting features of SMPlayer: it remembers the
      settings of all files you play. So you start to watch a movie but
      you have to leave... don't worry, when you open that movie again it
      will resume at the same point you left it, and with the same
      settings: audio track, subtitles, volume...

    Yep i have both mpv and mplayer installed

    I tried those settings in those screenshots and still doesn't work

    I installed nvidia the hard way i use nvidia. But mpv player isn't even working either


    Are you running tumbleweed?
    should i try to reinstall tumbleweed i can reinstall and install nvida driver hard way again . I'm getting a warning now for some reason on my media usb drive with manjaro. Its saying WARNING : media/home/tj/manjaro.JFKREO>>> is exhausted. happened afater i installed those 3 things from the link which is werid wasn't happening before

  6. #26
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: smplayer 16.9 isn't playing video

    Quote Originally Posted by wherewolf View Post
    Yep i have both mpv and mplayer installed

    I tried those settings in those screenshots and still doesn't work

    I installed nvidia the hard way i use nvidia. But mpv player isn't even working either


    Are you running tumbleweed?
    should i try to reinstall tumbleweed i can reinstall and install nvida driver hard way again . I'm getting a warning now for some reason on my media usb drive with manjaro. Its saying WARNING : media/home/tj/manjaro.JFKREO>>> is exhausted. happened afater i installed those 3 things from the link which is werid wasn't happening before
    As I'm on LEAP it could be TW related, if someone with TW can confirm it doesn't work this could be a bugzilla moment
    https://bugzilla.opensuse.org/

  7. #27

    Default Re: smplayer 16.9 isn't playing video

    I don't even see anything on bugzilla for smplayer related to my problem. I will be reinstalling TW and try again see if it works with the basic nouavu driver first. Then will install the nvidia driver to see if i can point to the problem. If smplayer doesn't work out of the box with nouavu then its TW issue. I might be going back to LEAP as its pretty much the same thing everything was working like a charm.

  8. #28
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,762

    Default Re: smplayer 16.9 isn't playing video

    Start smplayer from command line to see any reported errors

  9. #29

    Default Re: smplayer 16.9 isn't playing video

    Quote Originally Posted by gogalthorp View Post
    Start smplayer from command line to see any reported errors
    That doesn't work as both smplayer and mpv can open just not playing any files put in for both.

  10. #30
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: smplayer 16.9 isn't playing video

    what does
    Code:
    zypper info mpv
    say?
    you did do a zypper dup --from 5?
    if so this could be a build bug with mpv, it was recently updated something could have gone wrong.
    install mplayer and see if that works
    Code:
    zypper in mplayer
    just don't forget to set it as the preferred decoder in smplayer settings

Page 3 of 6 FirstFirst 12345 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •