Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: I broke my KDE

  1. #1

    Default I broke my KDE

    I accidentally broke my KDE by installing pyqt5 :/ i don't know if that's the reason but i think it is while the kde is based on qt5 and i've just reinstalled the pyqt5 ...
    well i'm wondering how to bring it back or reinstall my kde again ?

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: I broke my KDE

    login to a different desktop environment (I think IceWM is included on all opensuse installs) or do a console logon
    and tell us your repos
    Code:
    zypper lr -d
    you probobly have mixed Qt packages

  3. #3

    Default Re: I broke my KDE

    Quote Originally Posted by I_A View Post
    login to a different desktop environment (I think IceWM is included on all opensuse installs) or do a console logon
    and tell us your repos
    Code:
    zypper lr -d
    you probobly have mixed Qt packages
    i also installed the pyqt4 before that i remember ..

    here's the output :
    Code:
    #  | Alias                               | Name                                     | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                            | Service
    ---+-------------------------------------+------------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------------+--------
     1 | download.nvidia.com-leap            | nVidia Graphics Drivers                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/leap/42.1                                  |        
     2 | download.opensuse.org-non-oss       | Main Repository (NON-OSS)                | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/              |        
     3 | ftp.gwdg.de-suse                    | Packman Repository                       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_42.1/                  |        
     4 | google-chrome                       | google-chrome                            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                            |        
     5 | http-download.opensuse.org-1ac5a15e | home:polyconvex                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/polyconvex/openSUSE_Leap_42.2/ |        
     6 | http-download.opensuse.org-22c5742f | openSUSE:Leap:42.2                       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Leap:/42.2/standard/       |        
     7 | http-download.opensuse.org-b9bbe8c5 | home:jgeboski                            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/jgeboski/openSUSE_Leap_42.1/   |        
     8 | http-opensuse-guide.org-bdd5e7dd    | libdvdcss repository                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.1/                             |        
     9 | openSUSE-42.1-0                     | openSUSE-42.1-0                          | No      | ----      | Yes     |   99     | yast2  | hd:///?device=/dev/disk/by-id/scsi-1KingstonDataTraveler_2.0-part2             |        
    10 | packman                             | packman                                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42.1/             |        
    11 | repo-debug                          | openSUSE-Leap-42.1-Debug                 | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/            |        
    12 | repo-debug-non-oss                  | openSUSE-Leap-42.1-Debug-Non-Oss         | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/non-oss/        |        
    13 | repo-debug-update                   | openSUSE-Leap-42.1-Update-Debug          | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/oss                        |        
    14 | repo-debug-update-non-oss           | openSUSE-Leap-42.1-Update-Debug-Non-Oss  | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/non-oss/                   |        
    15 | repo-non-oss                        | openSUSE-Leap-42.1-Non-Oss               | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/              |        
    16 | repo-oss                            | openSUSE-Leap-42.1-Oss                   | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/oss/                  |        
    17 | repo-source                         | openSUSE-Leap-42.1-Source                | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/           |        
    18 | repo-update                         | openSUSE-Leap-42.1-Update                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/                             |        
    19 | repo-update-non-oss                 | openSUSE-Leap-42.1-Update-Non-Oss        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/                         |        
    20 | virtualbox                          | VirtualBox for openSUSE 13.2 / Leap 42.1 | Yes     | ( p) Yes  | Yes     |  120     | rpm-md | http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2

  4. #4
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: I broke my KDE

    Quote Originally Posted by haib610 View Post
    i also installed the pyqt4 before that i remember ..

    here's the output :
    Code:
    #  | Alias                               | Name                                     | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                            | Service
    ---+-------------------------------------+------------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------------+--------
     1 | download.nvidia.com-leap            | nVidia Graphics Drivers                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/leap/42.1                                  |        
     2 | download.opensuse.org-non-oss       | Main Repository (NON-OSS)                | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/              |        
     3 | ftp.gwdg.de-suse                    | Packman Repository                       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_42.1/                  |        
     4 | google-chrome                       | google-chrome                            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                            |        
     5 | http-download.opensuse.org-1ac5a15e | home:polyconvex                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/polyconvex/openSUSE_Leap_42.2/ |        
     6 | http-download.opensuse.org-22c5742f | openSUSE:Leap:42.2                       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Leap:/42.2/standard/       |        
     7 | http-download.opensuse.org-b9bbe8c5 | home:jgeboski                            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/jgeboski/openSUSE_Leap_42.1/   |        
     8 | http-opensuse-guide.org-bdd5e7dd    | libdvdcss repository                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.1/                             |        
     9 | openSUSE-42.1-0                     | openSUSE-42.1-0                          | No      | ----      | Yes     |   99     | yast2  | hd:///?device=/dev/disk/by-id/scsi-1KingstonDataTraveler_2.0-part2             |        
    10 | packman                             | packman                                  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42.1/             |        
    11 | repo-debug                          | openSUSE-Leap-42.1-Debug                 | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/leap/42.1/repo/oss/            |        
    12 | repo-debug-non-oss                  | openSUSE-Leap-42.1-Debug-Non-Oss         | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/42.1/repo/non-oss/        |        
    13 | repo-debug-update                   | openSUSE-Leap-42.1-Update-Debug          | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/oss                        |        
    14 | repo-debug-update-non-oss           | openSUSE-Leap-42.1-Update-Debug-Non-Oss  | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/non-oss/                   |        
    15 | repo-non-oss                        | openSUSE-Leap-42.1-Non-Oss               | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/              |        
    16 | repo-oss                            | openSUSE-Leap-42.1-Oss                   | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/oss/                  |        
    17 | repo-source                         | openSUSE-Leap-42.1-Source                | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/           |        
    18 | repo-update                         | openSUSE-Leap-42.1-Update                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/                             |        
    19 | repo-update-non-oss                 | openSUSE-Leap-42.1-Update-Non-Oss        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/                         |        
    20 | virtualbox                          | VirtualBox for openSUSE 13.2 / Leap 42.1 | Yes     | ( p) Yes  | Yes     |  120     | rpm-md | http://download.virtualbox.org/virtualbox/rpm/opensuse/13.2
    Well, to start with, you have repos for 42.1, 42.2, & 13.1 in there. You should not mix versions.

    Plus, you have a lot of unnecessary repos enabled.

    For now, disable:

    • 4 | google-chrome
    • 5 | http-download.opensuse.org-1ac5a15e (this is 42.2!)
    • 6 | http-download.opensuse.org-22c5742f (this is 42.2!)
    • 7 | http-download.opensuse.org-b9bbe8c5
    • 8 | http-opensuse-guide.org-bdd5e7dd
    • 3 | ftp.gwdg.de-suse (?? why 2 packman??)
    • 10 | packman (?? why 2 packman??)
    • 11 | repo-debug
    • 20 | virtualbox (this is 13.1 !)


    Run these from a command line as root:
    Code:
    zypper clean --all
    zypper ref
    zypper up
    Come back for next steps.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  5. #5

    Default Re: I broke my KDE

    Quote Originally Posted by Fraser_Bell View Post
    Well, to start with, you have repos for 42.1, 42.2, & 13.1 in there. You should not mix versions.

    Plus, you have a lot of unnecessary repos enabled.

    For now, disable:

    • 4 | google-chrome
    • 5 | http-download.opensuse.org-1ac5a15e (this is 42.2!)
    • 6 | http-download.opensuse.org-22c5742f (this is 42.2!)
    • 7 | http-download.opensuse.org-b9bbe8c5
    • 8 | http-opensuse-guide.org-bdd5e7dd
    • 3 | ftp.gwdg.de-suse (?? why 2 packman??)
    • 10 | packman (?? why 2 packman??)
    • 11 | repo-debug
    • 20 | virtualbox (this is 13.1 !)


    Run these from a command line as root:
    Code:
    zypper clean --all
    zypper ref
    zypper up
    Come back for next steps.
    i did zypper rr to the repos u mentioned but i think i made some mistakes and removed another repos :/ , my repos now are :
    Code:
    # | Alias                               | Name                                    | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                          | Service
    --+-------------------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+------------------------------------------------------------------------------+--------
    1 | download.nvidia.com-leap            | nVidia Graphics Drivers                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/leap/42.1                                |        
    2 | download.opensuse.org-non-oss       | Main Repository (NON-OSS)               | Yes     | (r ) Yes  | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/            |        
    3 | http-download.opensuse.org-b9bbe8c5 | home:jgeboski                           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/jgeboski/openSUSE_Leap_42.1/ |        
    4 | openSUSE-42.1-0                     | openSUSE-42.1-0                         | No      | ----      | Yes     |   99     | yast2  | hd:///?device=/dev/disk/by-id/scsi-1KingstonDataTraveler_2.0-part2           |        
    5 | repo-debug-update                   | openSUSE-Leap-42.1-Update-Debug         | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/oss                      |        
    6 | repo-debug-update-non-oss           | openSUSE-Leap-42.1-Update-Debug-Non-Oss | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/update/leap/42.1/non-oss/                 |        
    7 | repo-non-oss                        | openSUSE-Leap-42.1-Non-Oss              | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/            |        
    8 | repo-source                         | openSUSE-Leap-42.1-Source               | No      | ----      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/42.1/repo/oss/         |        
    9 | repo-update-non-oss                 | openSUSE-Leap-42.1-Update-Non-Oss       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/
    and i'm trying to do zypper ref but it gave me some errors like :
    Repository 'nVidia Graphics Drivers' is invalid.
    and
    Repository 'Main Repository (NON-OSS)' is invalid.

  6. #6
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: I broke my KDE

    Okay, first, go into Yast->Software Repositories.

    In there, you can click checkboxes to disable repositories without removing them.

    For now, I would do that with the http-download.opensuse.org-b9bbe8c5 (number 3 in your new list), and leave it disabled until the problem is solved. You can enable it later, if you really need it. That is not an official openSUSE repository, but a user-supplied one. Best not to have things like that enabled when fixing your system.

    Now, disable the nVidia & NON-OSS repositories (and any others) giving you the errors, and uncheck the autorefresh for them.

    On the bottom left corner of the Software Repositories page, click on Add, then check Community Repositories and click Next. Carefully choose the main repositories from the list that shows up.

    This should make sure you have the correct Repositories enabled.

    Finish up, then try the commands again.

    Please note, though, that the exact output that gave you those errors would be valuable to see and you should actually have posted the output. It may be a conflict between the installed software and the correct repositories. So, if you get more errors, please copy and paste the output into your replies so we can actually decipher what is going on.

    All such output can be quite critical to analyzing the problem.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  7. #7
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: I broke my KDE

    Actually, on further thought, I suggest that you should disable all of the repos except the 4 standard repos -- oss, non-oss, update, update-non-oss -- then remove all the packman repos from your list, as well as the nVidia repo.

    Then, go in and add the packman repository and the nVidia repo from that Community Repositories list.

    However, for now, set the nVidia repo to disabled.

    Next, go into Yast->Software Management.

    In there, go across the tabs to Repositories.

    Choose the packman repository in the left pane.

    Now, just above the window with the list of applications, you will see Switch systems packages to the versions in this repository (Packman Repository).

    Click on the underlined Switch systems packages.

    Accept (bottom right of the page) and exit.

    Now, check your list of repositories, make sure the only ones enabled are the 4 standard repos and your newly added and switched Packman repository.

    And make certain they are all 42.1 repos -- check the URLs in your list!

    Once you have confirmed that, then:
    Code:
    zypper ref && zypper dup --no-allow-vendor-change
    Report back. Post any errors, if you get them.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  8. #8

    Default Re: I broke my KDE

    Quote Originally Posted by Fraser_Bell View Post
    Okay, first, go into Yast->Software Repositories.

    In there, you can click checkboxes to disable repositories without removing them.

    For now, I would do that with the http-download.opensuse.org-b9bbe8c5 (number 3 in your new list), and leave it disabled until the problem is solved. You can enable it later, if you really need it. That is not an official openSUSE repository, but a user-supplied one. Best not to have things like that enabled when fixing your system.

    Now, disable the nVidia & NON-OSS repositories (and any others) giving you the errors, and uncheck the autorefresh for them.

    On the bottom left corner of the Software Repositories page, click on Add, then check Community Repositories and click Next. Carefully choose the main repositories from the list that shows up.

    This should make sure you have the correct Repositories enabled.

    Finish up, then try the commands again.

    Please note, though, that the exact output that gave you those errors would be valuable to see and you should actually have posted the output. It may be a conflict between the installed software and the correct repositories. So, if you get more errors, please copy and paste the output into your replies so we can actually decipher what is going on.

    All such output can be quite critical to analyzing the problem.
    I can't use the YAST ! i can't even log into the gui the kde is already down ... i did what you told me using chroot via an ubuntu live cd ... because after i choose opensuse from the grub it gives me just a white screen :/

  9. #9

    Default Re: I broke my KDE

    Quote Originally Posted by haib610 View Post
    I can't use the YAST ! i can't even log into the gui the kde is already down ...
    You should be able to use YaST in text mode even.

    i did what you told me using chroot via an ubuntu live cd ... because after i choose opensuse from the grub it gives me just a white screen :/
    Press Ctrl+Alt+F1 to get to text mode and login.

    The default SDDM login screen uses Qt5 (and some Plasma5 components) as well.
    You may set the DISPLAYMANAGER to "xdm" in /etc/sysconfig/displaymanager to get a graphical system if SDDM doesn't work.

    Though if your Qt5 installation is broken, the YaST GUI won't work either as it uses Qt5 too.

  10. #10

    Default Re: I broke my KDE

    Quote Originally Posted by wolfi323 View Post
    You should be able to use YaST in text mode even.


    Press Ctrl+Alt+F1 to get to text mode and login.

    The default SDDM login screen uses Qt5 (and some Plasma5 components) as well.
    You may set the DISPLAYMANAGER to "xdm" in /etc/sysconfig/displaymanager to get a graphical system if SDDM doesn't work.

    Though if your Qt5 installation is broken, the YaST GUI won't work either as it uses Qt5 too.
    ok i'll try it and tell you the results

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •