Results 1 to 5 of 5

Thread: mime type handling

  1. #1
    Join Date
    Sep 2008
    Posts
    2,997

    Default mime type handling

    I installed the x64 propitiatory foxit reader, it came in a binary installer, I installed it as an ordinary user so no system files wore changed,
    that bugger set it self as an application capable of opening all file types or better said it added it self to the dolphin menu for every possible file type not only pdf
    that blob created (as it wasn't already present) the file
    ~/.config/mimeapps.list
    with the content
    Code:
    [Default Applications]
    application/ppdf=FoxitReader.desktop
    application/x-pdf=FoxitReader.desktop
    application/pdf=FoxitReader.deskto
    application/octet-stream=FoxitReader.desktop
    that last line was bothering me so I removed it.
    it remained in the right click for every file type, I deleted ~/.config/mimeapps.list and rebooted, the open with Foxit reader was still there
    does plasma 5 (or dolphin) cache file types?
    is there another way an ordinary user can change the mime handling except by editing ~/.config/mimeapps?
    here's a screen shot

  2. #2
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: mime type handling

    so I did a bit of thinking and the issue is a badly thought off desktop file
    the FoxitReader.desktop file in ~/.local/share/applications/
    Code:
    [Desktop Entry]
    Name=Foxit Reader
    Comment=View pdf documents
    Keywords=pdf;octet-stream;
    StartupNotify=true
    Terminal=false
    Type=Application
    Categories=Application;Office;Viewer;X-Red-Hat-Base;
    MimeType=application/pdf;application/octet-stream;
    Icon=FoxitReader
    Exec=/home/<me>/opt/foxitsoftware/foxitreader/FoxitReader.sh %F
    the MimeType=application/octet-stream; is the cause of my issues removing it and rebooting fixes things

  3. #3

    Default Re: mime type handling

    Quote Originally Posted by I_A View Post
    is there another way an ordinary user can change the mime handling except by editing ~/.config/mimeapps?
    Systemsettings5 ("Configure Desktop")->Applications->File Associations.

    Unfortunately this only writes to ~/.local/share/applications/mimeapps.list in Plasma 5.5, which was the old location.
    ~/.config/mimeapps.list is the new freedesktop.org standard.

    The "problem" with 5.5 is that the KDE Frameworks do follow the (new) standard already, so ~/.config/mimeapps.list takes precedence over ~/.local/share/applications/mimeapps.list (which is still respected for compatibility if the new one doesn't exist).

    A workaround would be to create one as a symlink of the other.

    This has been fixed in Plasma 5.6, the KDE config module now does write to ~/.config/mimeapps.list.

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: mime type handling

    tanks wolfi but this is a serous bug in Foxit's thinking, setting the reader as the default application for every file types is beyond dumb, I wrote in their forums asking them to stop and "fix" their desktop file and their application should stop writing
    Code:
    [Default Applications]
    .
    .
    .
    application/octet-stream=FoxitReader.desktop
    in the mimeapps.list, I hope they fix it.

  5. #5

    Default Re: mime type handling

    Quote Originally Posted by I_A View Post
    tanks wolfi but this is a serous bug in Foxit's thinking
    Sure.
    I just wanted to answer your question how an ordinary user could "fix" it, i.e. modify the file associations in ~/.config/mimeapps.list without editing it manually in a text editor.
    Though that probably isn't obvious either...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •