Results 1 to 5 of 5

Thread: virtualbox-host-kmp problem prevents zypper dup

  1. #1
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    503

    Default virtualbox-host-kmp problem prevents zypper dup

    Hi,
    since last week i get this error when trying to upgrade my tumbleweed system via: zypper dup

    Code:
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    
    Problem: virtualbox-host-kmp-default-5.1.4_k4.7.2_2-2.2.x86_64 conflicts with virtualbox-guest-kmp provided by virtualbox-guest-kmp-default-5.1.4_k4.7.2_2-2.2.x86_64
     Solution 1: deinstallation of virtualbox-guest-kmp-default-5.1.4_k4.7.2_1-1.3.x86_64
     Solution 2: deinstallation of virtualbox-host-kmp-default-5.1.4_k4.7.2_1-1.3.x86_64
    
    Choose from above solutions by number or cancel [1/2/c] (c):
    normally there is at least an option to skip this package but this time both given options could create new problems i do not want.
    Is this a packaging bug?

  2. #2

    Default Re: virtualbox-host-kmp problem prevents zypper dup

    Choose "Solution 1: Deinstallation of of virtualbox-guest-kmp-default-5.1.4_k4.7.2_1-1.3.x86_64".
    This conflict has been added on purpose to prevent the installation of the guest tools on the host (where they are useless anyway).

  3. #3
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    503

    Default Re: virtualbox-host-kmp problem prevents zypper dup

    Ok thank you i will try this, but i never had this problem before. you say the conflict was added on purpose, was this just recently? And is this ideal, i can imagine that most users will not know what to do here and if it is forced on everyone this could be problematic right?

  4. #4

    Default Re: virtualbox-host-kmp problem prevents zypper dup

    Quote Originally Posted by sabo007 View Post
    Ok thank you i will try this, but i never had this problem before. you say the conflict was added on purpose, was this just recently?
    Yes.
    https://build.opensuse.org/package/r...v=base&rev=119

    And is this ideal, i can imagine that most users will not know what to do here and if it is forced on everyone this could be problematic right?
    No, I don't think this is ideal, because of the manual intervention it requires.
    Somebody filed a bug report already too:
    http://bugzilla.opensuse.org/show_bug.cgi?id=997920

    Actually the conflict was added as a "fix" for http://bugzilla.opensuse.org/show_bug.cgi?id=983927, but I submitted a proper fix meanwhile anyway.

    That's why I raised my voice against this for the 13.2 maintenance update.

    It is not problematic though: again, the guest tools are useless on the host, there is absolutely no point at all in having them installed.

    PS, for clarification: you only got the conflict this one time, because you had virtualbox-guest-kmp-default installed. In the future you won't get conflicts, and virtualbox-guest-kmp-default will not get installed any more either.
    Last edited by wolfi323; 13-Sep-2016 at 15:54.

  5. #5
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    503

    Default Re: virtualbox-host-kmp problem prevents zypper dup

    Thank you very much for clearing this up.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •