Results 1 to 8 of 8

Thread: LibreOffice Writer spell check

  1. #1
    Join Date
    Jul 2016
    Posts
    9

    Default LibreOffice Writer spell check

    I am running Leap 42.1 on a Gnome desktop.

    For no apparent reason, the spell check on LibreOffice Writer doesn't appear to be automatically on, as it is on other applications I use it with.

    Nor is the word count option at the bottom left hand corner of the document automatically working; I have to select the text and only then will it give me a word count.

    How do I turn these two functions on?

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,511

    Default Re: LibreOffice Writer spell check

    Quote Originally Posted by BX View Post
    For no apparent reason, the spell check on LibreOffice Writer doesn't appear to be automatically on, as it is on other applications I use it with.
    Nor is the word count option at the bottom left hand corner of the document automatically working; I have to select the text and only then will it give me a word count.
    For me (with the KDE Plasma 5 Desktop), LibreOffice Version: 5.1.3.2 Writer is showing the character and word counts bottom left. Spell checking is also running OK.

    Quote Originally Posted by BX View Post
    How do I turn these two functions on?
    I haven't found anything which specifically enables or disables this function.
    Do you have a Java Runtime Environment installed and, is it found by and chosen by LibreOffice (Extended set-up tab)?

  3. #3
    Join Date
    Dec 2009
    Location
    B'ham, UK
    Posts
    46

    Default Re: LibreOffice Writer spell check

    You can try to remove the user's configuration of LibreOffice
    Code:
     rm -rf ~/.config/libreoffice

  4. #4
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: LibreOffice Writer spell check

    Quote Originally Posted by dcurtisfra View Post
    For me (with the KDE Plasma 5 Desktop), LibreOffice Version: 5.1.3.2 Writer is showing the character and word counts bottom left. Spell checking is also running OK.
    The same is true in GnomeLand.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  5. #5
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,448

    Default Re: LibreOffice Writer spell check

    Can you access Tools>Options>Languages>Writing aids?

  6. #6

    Default Re: LibreOffice Writer spell check


    It would appear that on Sep 13, dcurtisfra did say:

    > BX;2792242 Wrote:
    > >
    > > For no apparent reason, the spell check on LibreOffice Writer doesn't
    > > appear to be automatically on, as it is on other applications I use it
    > > with.
    > > Nor is the word count option at the bottom left hand corner of the
    > > document automatically working; I have to select the text and only then
    > > will it give me a word count.
    > >

    > I haven't found anything which specifically enables or disables this
    > function.
    > Do you have a Java Runtime Environment installed and, is it found by and
    > chosen by LibreOffice (Extended set-up tab)?


    This may be a bit naive of me, but on my copy of LibreOffice writer when I select the Tools
    menu the first two choices are about spelling along with listing the associated keybindings:

    And while F7 starts a non-automatic spell checking session, <SHIFT>+<F7> toggles the
    automatic spell checking function...

    I discovered this because looking at those little squiggles all the time bugs me. So
    I was happy to find out how to turn automatic spellchecking off.

    I have no clue how to affect the status bar word count display, but the fifth
    choice from the tools menu (Word count) gives me a pop up with the word count data
    for both the selected text {if any} and the whole document whether anything is selected
    or not.

    --
    Joe

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,511

    Default Re: LibreOffice Writer spell check

    Confirmed, the F7 Function key seems to be the only way to influence the spell checking behaviour.
    And, the "Tools" menu drop-down "Word Count" is a detailed summary of the document's word and character counts.

    Returning to the "bottom left" display of word and character count:
    • Have you tried the LibreOffice Writer with a "fresh" newly created (default) Leap 42.1 user?


    If the "only ever Leap 42.1" user's Writer is behaving properly then, assuming that your "normal" (production) user has been migrated from at least one previous openSUSE version or, even from somewhere else, then, it's time to "clean out the Stygian Stables".

    Unfortunately the *NIX migration routines sometimes do not function quite as well as what one would wish -- the extreme way to "clean up" is to move all the user's working files and things such as e-Mail in ~/.local, somewhere else; remove all the user's configuration files in the ~/.xxx directories; copy the latest user skeleton files from /etc/skel/ (also the "hiidden" files); log the user in to set up an initial GUI configuration and then log out; move the user's working files and e-Mails back to the user's login directory; finished.

    Normally Writer then behaves as expected.

  8. #8
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,448

    Default Re: LibreOffice Writer spell check

    Quote Originally Posted by dcurtisfra View Post
    Confirmed, the F7 Function key seems to be the only way to influence the spell checking behaviour.
    Simply not true. See Tools>Options>Languagesettings>Writing aids.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •