Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Can not type my password into some of the "authentication required" boxes

  1. #1

    Default Can not type my password into some of the "authentication required" boxes

    Hi,
    I am using Tumbleweed, xen, Dom0 kernel 4.6.3.1, KDE plasma desktop on 3 monitors.

    Sometimes, when I am required to e.g. connect to Xen in the virtual machine manager, the box appears "Authentication required" with the place to enter root password. The trouble is that I can not enter the password. When I place the cursor in the box and type anything, the symbols hiding the password just do not appear.
    I updated whole system, no help. I ran "zypper dup" and I went to a pain of reinstalling it all. No help. The problem appears even when the regular (non Xen) kernel is booted.

    Some places (such as staring Yast) allows me to enter the password with no problems. Some places allow me to type characters with _huge_ delay. Like I press a character, and corresponding symbol appears only after multiple presses, after several (~15) seconds.

    What do I do? How do I troubleshoot it?

  2. #2

    Default Re: Can not type my password into some of the "authentication required" boxes

    Nothing interesting in the log obtained by `journalctl -b`

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: Can not type my password into some of the "authentication required" boxes

    Some place like su do not echo keystrokes. Are you sure that you are not actually entering the password??

  4. #4

    Default Re: Can not type my password into some of the "authentication required" boxes

    Yes, I am sure, because:
    1. Sometimes a character appear after I press a button like 40 times
    2. When I type my password elsewhere (e.g. in the browser search line), copy it, left click on the password field selecting it, the right-click - paste, full number of the characters in my password appear and it is accepted by the system. In fact that's the only way I found to get past it.
    3. If I pretend to continue typing (although no characters appear) and press "OK" button the empty password is, of course, rejected.

    su from the terminal works just fine. I am concerned with the `graphical su`, whatever the right term is.

    PS.
    There was a thread on this forum dedicated to similar problem, I just can not find it.

  5. #5

    Default Re: Can not type my password into some of the "authentication required" boxes

    Same thing happens when I go to the network manager to configure settings. But getting into, say, Yast is fine

  6. #6

    Default Re: Can not type my password into some of the "authentication required" boxes

    This is not kdesu, this is some other tool. kdesu works perfectly fine.

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,855
    Blog Entries
    14

    Default Re: Can not type my password into some of the "authentication required" boxes

    Quote Originally Posted by mzu2006 View Post
    This is not kdesu, this is some other tool. kdesu works perfectly fine.
    Can you post a screenshot?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8

    Default Re: Can not type my password into some of the "authentication required" boxes

    https://github.com/mnzakharov/person...cle.d13161.png
    I'll be happy to keep the image inside a post, but shame on me as I am unable to find attach button in the post editor

  9. #9
    Join Date
    Jan 2013
    Location
    Germany
    Posts
    289

    Default Re: Can not type my password into some of the "authentication required" boxes

    Is the right keyboard activated? Test it anywhere else: Shell, LibreOffice, ....
    Is the application right configured?

  10. #10

    Default Re: Can not type my password into some of the "authentication required" boxes

    Is the right keyboard activated?
    Yes. This is a laptop with built-in and attached USB keyboard. Both keyboards work elsewhere: Shell, Kate, ... Both keyboards have the same type of problem with "authentication required" dialog boxes.
    s the application right configured?
    Please, elaborate. This behavior is exhibited with at least 2 applications: Virtual Machine Manager and Network Manager.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •