Results 1 to 5 of 5

Thread: LibreOffice paragraph style "properties?" problem...

  1. #1

    Default LibreOffice paragraph style "properties?" problem...


    If it matters I'm using:

    LibreOffice
    Version: 5.1.3.2
    Build ID: 10m0(Build:2)
    CPU Threads: 4; OS Version: Linux 4.1; UI Render: default;
    Locale: en-US (en_US.UTF-8)

    On Opensuse Leap 42.1

    But first let me explain that I'm only using it because I'm writing a series of
    Ebooks and Smashwords.com wants me to upload them as "word documents"

    If I want them to submit the book to other retailers such as Barnes & Noble I need to
    format the book precisely the way they want it. And they want almost all formatting
    done by paragraph styles. Manually inserted formatting is strongly discouraged.

    In order for "me" to make it work I have to clear all formatting and then starting at
    the top, apply carefully crafted custom paragraph styles until I reach the end of
    the document. Then add hyperlinks to the TOC etc...

    It took me a while to craft a complete set of all the paragraph styles I needed well
    enough for the process Smashwords affectionately calls the meatgrinder to convert it
    to all the recommended Ebook formats without throwing errors. Once it did so however,
    I made a copy of the uploaded "word.doc" and wiped all the text content before saving
    it as a preformatted BLANK word.doc with all the paragraph styles I needed to repeat
    the process.

    Somehow, something I never knowingly selected, found it's way into my blank word.doc file.

    Which caused every paragraph style I tried to apply to also add underlining and a
    blueish font color to the text. Eventually I found the "Properties" sidebar option
    where I could untick the bold button. And I could select black instead of blue for
    the font color. But selecting BLACK font color is NOT a good idea for Ebooks because I
    can't control the end readers background color settings. I'm supposed to use a default
    that doesn't preselect the text color so the Ebook reader can automatically adjust the
    text color according to it's background settings. I think Smashwords describes this
    color as "automatic"...

    However I couldn't find any way to deselect the blue without selecting a new default
    color... I know it has to be there somewhere. But almost all the controls are based
    on meaningless {to me} icon like buttons.{I need labels} AND I don't actually compose with
    LibreOffice, to have slowly become familiar with very many of them. I actually compose
    in LyX {which keeps me from fat fingering extra spaces between words and many other
    formatting errors that would prevent my Ebook from making it through Smashwords
    meatgrinder...} Then I wash the text through leafpad so that I can paste a plain text
    version into my "blank" word.doc, and start applying the paragraph styles.

    It may be the "hard way" But as long as my blank word.doc file remained unchanged, it
    was repeatable. Unfortunately something did change. But I really would like to avoid
    recreating the twenty odd paragraph styles from scratch...

    So could somebody explain how to truly undo having any preset font color. So that the
    end user's Ereader can automatically adjust it as needed???

    Thanks

    --
    Joe

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: LibreOffice paragraph style "properties?" problem...

    You are doing a rather specialized job, so I'm not sure if the following might apply.
    1) Avoid any (bluish) background color:
    - open your blank word.doc in LibreOffice Writer
    - hit F11 (the Styles and Formatting panel should open)
    - select the first button if not already selected (should read "Paragraph Styles" while hovering the mouse above it)
    - right-click on "Default Style" then "Modify..."
    - a panel opens, select the "Area" tab, then "Fill > None"
    - "Apply" then "OK".

    Unless you have done something unusual, all your paragraph styles should inherit that "Fill > None" property; if that is not the case, you should repeat the procedure for any custom style still showing the bluish background.

    2) Font color "Automatic"
    - same as the above, but select the "Font Effects" tab
    - select "Font Color: > Automatic"
    - "Apply" then "OK".

    Hope this helps.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  3. #3

    Default Re: LibreOffice paragraph style "properties?" problem...



    It would appear that on Sep 10, OrsoBruno did say:

    > You are doing a rather specialized job, so I'm not sure if the following
    > might apply.
    > 1) Avoid any (bluish) background color:
    > - open your blank word.doc in LibreOffice Writer
    > - hit F11 (the Styles and Formatting panel should open)
    > - select the first button if not already selected (should read
    > "Paragraph Styles" while hovering the mouse above it)
    > - right-click on "Default Style" then "Modify..."
    > - a panel opens, select the "Area" tab, then "Fill > None"
    > - "Apply" then "OK".
    >
    > Unless you have done something unusual, all your paragraph styles should
    > inherit that "Fill > None" property; if that is not the case, you should
    > repeat the procedure for any custom style still showing the bluish
    > background.
    >
    > 2) Font color "Automatic"
    > - same as the above, but select the "Font Effects" tab
    > - select "Font Color: > Automatic"
    > - "Apply" then "OK".
    >
    > Hope this helps.


    Thank you for replying. I must have been real tired when I gave up solving this
    myself last night and asked for help.

    The problem was {note past tense} in the "properties" side bar dialog rather than the
    "styles and formatting" dialog. {I had already checked my paragraph style definitions
    and none of them set underlining nor font color.} But there was something in the
    "properties" dialog that was overriding my custom styles.

    I had already been able to deselect the underline button there. But for some reason
    when I opened the font color selection tool there I didn't recognize the little
    button {above the pallet} that would set the color back to "automatic". For which I
    feel really stupid because it was the ONLY font color setting there that was actually
    labeled.

    I'm also a bit confused. Since these properties seem to be tied to the currently selected
    style, I think it should have resulted in changing the visible settings in the font effect
    tab of the paragraph style definition, where I should have been able to set it back to
    "automatic" and (without) using the font effect settings there. Instead, the font
    effects tab of the style "modify" dialog incorrectly indicated that it was still set
    to automatic and without. And I had to make the fix in the less intuitive "proprieties"
    side bar dialog.

    But in any case it's all good now.

    Thanks again.

    --
    Joe


  4. #4
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: LibreOffice paragraph style "properties?" problem...

    Quote Originally Posted by jtwdyp View Post
    I'm also a bit confused. Since these properties seem to be tied to the currently selected
    style, I think it should have resulted in changing the visible settings in the font effect
    tab of the paragraph style definition, where I should have been able to set it back to
    "automatic" and (without) using the font effect settings there. Instead, the font
    effects tab of the style "modify" dialog incorrectly indicated that it was still set
    to automatic and without. And I had to make the fix in the less intuitive "proprieties"
    side bar dialog.
    Not sure to understand what you actually did, but please be aware that any setting from the "Properties" sidebar, apart from "Styles", is SUPERIMPOSED on your "Paragraph Style", affects only the selected text/character and does NOT change the "Paragraph Style" itself.
    So, if I understand the "meat grinder" correctly, I would NOT TOUCH any setting in the Properties sidebar except for the "Styles" drop down menu.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  5. #5

    Default Re: LibreOffice paragraph style "properties?" problem...


    It would appear that on Sep 11, OrsoBruno did say:

    > jtwdyp;2792047 Wrote:
    > >
    > > I'm also a bit confused. Since these properties seem to be tied to the
    > > currently selected
    > > style, I think it should have resulted in changing the visible settings
    > > in the font effect
    > > tab of the paragraph style definition, where I should have been able to
    > > set it back to
    > > "automatic" and (without) using the font effect settings there. Instead,
    > > the font
    > > effects tab of the style "modify" dialog incorrectly indicated that it
    > > was still set
    > > to automatic and without. And I had to make the fix in the less
    > > intuitive "proprieties"
    > > side bar dialog.
    > >

    >
    > Not sure to understand what you actually did, but please be aware that
    > any setting from the "Properties" sidebar, apart from "Styles", is
    > SUPERIMPOSED on your "Paragraph Style", affects only the selected
    > text/character and does NOT change the "Paragraph Style" itself.
    > So, if I understand the "meat grinder" correctly, I would NOT TOUCH any
    > setting in the Properties sidebar except for the "Styles" drop down
    > menu.


    That would be my plan, especially now that I know about it. What I can't figure out
    is how those two effects got set in the properties sidebar for every single custom
    style I had, when I never ever went there before???

    The only thing I do to LibreOffice is, when it gets upgraded I hunt down and disable
    any and all of the auto correct settings I can find. I really wish they made it easy
    to disable ALL automatic document modifiers in one easy to find master switch...

    And the only time I actually USE LibreOffice {aside from an occasional spreadsheet} is when
    I'm done composing, editing, and typo fixing my LyX document I bypass LyX's output {which
    is more suitable for latex typesetting etc...} by using {ctrl}+{a} then {ctrl}+{c} in LyX's
    composer window. Then pasting it into a text document via leafpad. After which I run

    Code:
    grep -v '^$' input.txt > output.txt
    on the resulting text file to eliminate the blank lines. Next I open that output.txt
    in leafpad and copy the whole thing to the clipboard. Finally I open a copy of that
    blank word.doc with all my custom paragraph styles and paste. Mark all, clear
    formatting and then starting from the top I start applying the paragraph styles in
    such a way as to make the WYSIWYG word.doc closely resemble the pdf output I could
    have generated from LyX. While deleting a few undesirable lines such as LyX's
    frontmatter & backmatter ERT tags as I encounter them. After which I insert bookmarks
    for all the chapter headings, then replace the TOC list with inserted hyperlinks.
    Save the bookname.doc and then save as an bookname.odt document that calibre can convert
    to an bookname.epub. Which I use to give the text & formatting one last sanity
    checking read through, before uploading the bookname.doc to Smashword's meatgrinder.

    And that is ALL I ever do with LibreOffice. So I'm at a complete loss to explain how
    the Properties sidebar settings got changed to superimpose underlining & blue text color
    to all my custom styles in the first place... Unless, until my recent purchase of a
    Kensington Orbit trackball, I was putting up with a wheel mouse. Occasionally I would notice
    that the wheel would scroll some scrollbox settings that I hadn't even selected. {I
    hates wheel mice more than Yosemite Sam hates rabbits...} But I would have thought
    that the properties sidebar would have had to be active for that to have made any
    changes there.

    However, it's all good now. And if it ever happens again, at least I'll know where to
    look for the problem.

    Thanks again

    --
    Joe



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •