Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Time set to hh:mm.ss but only shows hh:mm

  1. #1

    Default Time set to hh:mm.ss but only shows hh:mm

    Recently, I have noticed the time (bottom left corner) only shows hh:mm (not hh:mm:ss) even though I have configured in the Appearance to show seconds. Does anyone here have a clue how to fix this so that it will show hh:mm:ss, instead of hh:mm only?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,857

    Default Re: Time set to hh:mm.ss but only shows hh:mm

    I assume you talk about some GUI desktop. Please which Desktop Environment (KDE, Gnome, Xfce, .....)?
    Henk van Velden

  3. #3

    Default Re: Time set to hh:mm.ss but only shows hh:mm

    It is on a KDE.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,354
    Blog Entries
    3

    Default Re: Time set to hh:mm.ss but only shows hh:mm

    I right-click on the clock, and select "Digital Clock Settings"

    That opens a settings window. There's a box there, marked as "Show seconds". I check that box and save the changes. And seconds appear.

    I then repeat, and uncheck the box (and save), because I really don't need to have the seconds showing.
    openSUSE Leap 15.1; KDE Plasma 5;

  5. #5

    Default Re: Time set to hh:mm.ss but only shows hh:mm

    Quote Originally Posted by nrickert View Post
    I right-click on the clock, and select "Digital Clock Settings"

    That opens a settings window. There's a box there, marked as "Show seconds". I check that box and save the changes. And seconds appear.
    When I first installed LEAP 42.1, I also have that checked and it showed hh:mm:ss. Now, it no longer shows the seconds and only shows hh:mm even though the "Show seconds" has already been checked as mentioned in my OP.

  6. #6
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Time set to hh:mm.ss but only shows hh:mm

    Quote Originally Posted by habibie View Post
    When I first installed LEAP 42.1, I also have that checked and it showed hh:mm:ss. Now, it no longer shows the seconds and only shows hh:mm even though the "Show seconds" has already been checked as mentioned in my OP.
    Did you try unchecking it, exiting, re-entering and re-checking it?
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  7. #7

    Default Re: Time set to hh:mm.ss but only shows hh:mm

    Quote Originally Posted by habibie View Post
    When I first installed LEAP 42.1, I also have that checked and it showed hh:mm:ss. Now, it no longer shows the seconds and only shows hh:mm even though the "Show seconds" has already been checked as mentioned in my OP.
    What time locale are you using?
    There was a bug that prevented the seconds from being shown with certain locales (C e.g.), that was a regression in Plasma 5.5 IIRC.

    Should be fixed since Plasma 5.6.4, but we didn't backport the fix to 42.1.

    See here for how to fix it yourself:
    http://lists.opensuse.org/opensuse-k.../msg00016.html

    If that change helps and you think this warrants an update for 42.1, please file a bug report at http://bugzilla.opensuse.org/.

  8. #8

    Default Re: Time set to hh:mm.ss but only shows hh:mm

    Quote Originally Posted by Fraser_Bell View Post
    Did you try unchecking it, exiting, re-entering and re-checking it?
    Yes and I did those even with a reboot. The problem still persists and time still show hh:mm without :ss.

  9. #9

    Default Re: Time set to hh:mm.ss but only shows hh:mm

    Quote Originally Posted by wolfi323 View Post
    What time locale are you using?
    I am not quite sure which locale I use. The only thing I know is I use a long format date. I also tried short and/ ISO format to no avail.

    There was a bug that prevented the seconds from being shown with certain locales (C e.g.), that was a regression in Plasma 5.5 IIRC.

    Should be fixed since Plasma 5.6.4, but we didn't backport the fix to 42.1.
    My 42.1 is still using Plasma v5.5.5-9.1 and that probably explains why the :ss is missing from the time.

    See here for how to fix it yourself:
    http://lists.opensuse.org/opensuse-k.../msg00016.html

    If that change helps and you think this warrants an update for 42.1, please file a bug report at http://bugzilla.opensuse.org/.
    I tried the above fix and the :ss still won't show up.

  10. #10

    Default Re: Time set to hh:mm.ss but only shows hh:mm

    Quote Originally Posted by habibie View Post
    I am not quite sure which locale I use.
    What are the settings in "Configure Desktop" (systemsettings5)->Locale->Formats?

    The only thing I know is I use a long format date. I also tried short and/ ISO format to no avail.
    You mean in the digital clock settings?
    That's irrelevant in regard to that bug.

    My 42.1 is still using Plasma v5.5.5-9.1 and that probably explains why the :ss is missing from the time.
    At least that version is affected by the bug I'm talking of.

    I tried the above fix and the :ss still won't show up.[/QUOTE]
    Did you logout/reboot?
    That fix definitely works, and I am not aware of a different bug with such an effect.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •