Results 1 to 4 of 4

Thread: Radiotray problems

  1. #1

    Default Radiotray problems

    Im running Leap 42.1 with Gnome 3 and it has been working flawlessly so far, with one exception.
    Radiotray..
    This is the message i get when trying to run it from the terminal:

    Code:
    ** Message: pygobject_register_sinkfunc is deprecated (GstObject)Traceback (most recent call last):
      File "/usr/bin/radiotray", line 15, in <module>
        radiotray.main(sys.argv[1:])
      File "/usr/lib/python2.7/site-packages/radiotray/radiotray.py", line 39, in main
        RadioTray()
      File "/usr/lib/python2.7/site-packages/radiotray/RadioTray.py", line 72, in __init__
        self.audio = AudioPlayerGStreamer(self.mediator, self.cfg_provider, eventManager)
      File "/usr/lib/python2.7/site-packages/radiotray/AudioPlayerGStreamer.py", line 43, in __init__
        self.souphttpsrc = gst.element_factory_make("souphttpsrc", "source")
    gst.ElementNotFoundError: souphttpsrc
    Is there a way around this (by upgrading/downgrading packages)?

    My system is fully updated, so i assume there are some old packages needed, but which ones?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,814
    Blog Entries
    15

    Default Re: Radiotray problems

    Hi
    Install gstreamer-0_10-plugins-good which should contain the missing element.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,814
    Blog Entries
    15

    Default Re: Radiotray problems

    On Wed 31 Aug 2016 12:26:02 PM CDT, malcolmlewis wrote:

    Hi
    Install gstreamer-0_10-plugins-good which should contain the missing
    element.


    Hi
    Looking again, I see the GNOME:Apps version has a patch to port it to
    gtk3 and gstreamer 1.0, I would update the version from there and stick
    with the newer gstreamer.

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.1|GNOME 3.16.2|4.1.27-27-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  4. #4

    Default Re: Radiotray problems

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Looking again, I see the GNOME:Apps version has a patch to port it to
    gtk3 and gstreamer 1.0, I would update the version from there and stick
    with the newer gstreamer.

    --
    Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.1|GNOME 3.16.2|4.1.27-27-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

    Thanks, installing the Gstreamer solved it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •