Results 1 to 8 of 8

Thread: YaST not working

  1. #1

    Post YaST not working

    After upgrading from 13.2 to 42.1, I can't use my Yast at all. It opens but when I click icons, nothing appears. But everything works when I use Yast from terminal. Please help me.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,269
    Blog Entries
    1

    Default Re: YaST not working

    Quote Originally Posted by papabuff View Post
    After upgrading from 13.2 to 42.1, I can't use my Yast at all. It opens but when I click icons, nothing appears. But everything works when I use Yast from terminal. Please help me.
    So you can use YaST ncurses interface ok?

    Since you'ce recently upgraded, check configured repos. Post here for others to review.
    Code:
    zypper lr -d

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,269
    Blog Entries
    1

    Default Re: YaST not working

    BTW, any errors observed when you try to launch graphical interface from the terminal?
    Code:
    xdg-su -c yast2

  4. #4
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: YaST not working

    Hi, a common pitfall on yast when upgrading from OS 13.2 is the lack of one or more of the following packages.
    Please check that all of them are installed, or update accordingly.
    Code:
    LT_B:~ # zypper --no-refresh se -is yui
    Loading repository data...
    Reading installed packages...
    
    S | Name                | Type    | Version     | Arch   | Repository            
    --+---------------------+---------+-------------+--------+-----------------------
    i | libyui-ncurses-pkg7 | package | 2.48.2-1.1  | x86_64 | openSUSE-Leap-42.1-Oss
    i | libyui-ncurses7     | package | 2.47.4-1.2  | x86_64 | openSUSE-Leap-42.1-Oss
    i | libyui-qt-graph7    | package | 2.44.5-1.3  | x86_64 | openSUSE-Leap-42.1-Oss
    i | libyui-qt-pkg7      | package | 2.45.5-1.2  | x86_64 | openSUSE-Leap-42.1-Oss
    i | libyui-qt7          | package | 2.46.21-1.1 | x86_64 | openSUSE-Leap-42.1-Oss
    i | libyui7             | package | 3.2.3-1.2   | x86_64 | openSUSE-Leap-42.1-Oss
    LT_B:~ #
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  5. #5

    Default Re: YaST not working

    Quote Originally Posted by deano_ferrari View Post
    So you can use YaST ncurses interface ok?

    Since you'ce recently upgraded, check configured repos. Post here for others to review.
    Code:
    zypper lr -d
    Here are my repos,

    # | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service
    ---+-----------------------------------+-----------------------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------+--------
    1 | Firefox | Firefox | Yes | (r ) Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...USE_Leap_42.1/ |
    2 | Packman | Packman | Yes | (r ) Yes | No | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_42.1/ |
    3 | X11:xfce | X11:xfce | Yes | (r ) Yes | No | 99 | rpm-md | http://download.opensuse.org/reposit...USE_Leap_42.1/ |
    4 | dvd | dvd | Yes | (r ) Yes | No | 99 | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_42.1/ |
    5 | openSUSE-Leap-42.1-Update | openSUSE-Leap-42.1-Update | Yes | (r ) Yes | No | 99 | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/ |
    6 | openSUSE-Leap-42.1-Update-Non-Oss | openSUSE-Leap-42.1-Update-Non-Oss | Yes | (r ) Yes | No | 99 | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/ |
    7 | openSUSE:Leap:42.1:NonFree | openSUSE:Leap:42.1:NonFree | Yes | ( p) Yes | No | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    8 | repo-debug | openSUSE-leap/42.1-Debug | No | ---- | No | 99 | NONE | http://download.opensuse.org/debug/d...42.1/repo/oss/ |
    9 | repo-debug-update | openSUSE-leap/42.1-Update-Debug | No | ---- | No | 99 | NONE | http://download.opensuse.org/debug/update/leap/42.1/ |
    10 | repo-debug-update-non-oss | openSUSE-leap/42.1-Update-Debug-Non-Oss | No | ---- | No | 99 | NONE | http://download.opensuse.org/debug/u.../42.1-non-oss/ |
    11 | repo-non-oss | openSUSE-leap/42.1-Non-Oss | Yes | (r ) Yes | No | 99 | yast2 | http://download.opensuse.org/distrib.../repo/non-oss/ |
    12 | repo-oss | openSUSE-leap/42.1-Oss | Yes | (r ) Yes | No | 99 | yast2 | http://download.opensuse.org/distrib...42.1/repo/oss/ |
    13 | repo-source | openSUSE-leap/42.1-Source | No | ---- | No | 99 | NONE | http://download.opensuse.org/source/...42.1/repo/oss/ |


  6. #6

    Default Re: YaST not working

    Quote Originally Posted by deano_ferrari View Post
    BTW, any errors observed when you try to launch graphical interface from the terminal?
    Code:
    xdg-su -c yast2
    This error happened, I think I found the answer.

    terminate called after throwing an instance of 'YUIPluginException' what(): Couldn't load plug-in qt
    YaST got signal 6 at file /usr/share/YaST2/modules/Console.rb:209
    sender PID: 2922
    /sbin/yast2: line 440: 2922 Aborted $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS


  7. #7

    Default Re: YaST not working

    Thank you for replying my post. I updated qt-pkg 6 to 7 and everything is fine now. Thank you all.

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,269
    Blog Entries
    1

    Default Re: YaST not working

    Quote Originally Posted by papabuff View Post
    Thank you for replying my post. I updated qt-pkg 6 to 7 and everything is fine now. Thank you all.
    Good that you've managed to resolve the problem. Well done.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •