Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: dbus lockup?

  1. #1
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    168

    Question dbus lockup?

    Hi, I've an OS 13.2 64bit computer using KDE which was working well up to about three weeks ago. It now periodically freezes, usually triggered by right click on an item in Dolphin. I can either wait about 5 mins for it to recover, or restart the dbus service (which kills the Dolphin instance, as well as a few other applications).

    Has anyone seen this before?
    Any advice on what evidence to collect to trace the fault & kill it?

    Thanks
    David

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,651

    Default Re: dbus lockup?

    open a knosole and run top monitor when problem happens see what is eating the cpu.

    What video card/driver

  3. #3
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    168

    Default Re: dbus lockup?

    Thanks. I didn't have time to get back to this, but now it fixed itself. I changed (in Settings) some of the desktop effects, and about 5 minutes later the desktop totally locked up. I couldn't even Ctrl-Alt-F1 to get a terminal, so hard shutdown. After restart it seems fine.

    In answer to one of the questions: plasma-desktop & dbus-daemon were the two most frequent, with plasma-desktop regularly taking 20% CPU.

    hwinfo reports: ATI RV630 [Radeon HD 2600XT]

  4. #4
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    168

    Question Re: dbus lockup?

    It's not fixed, just hiding for a while. :-)

    Following a number of links, I discovered in kmail startup (also very slow):
    Code:
    kmail2(10982)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."
    and tracing that got me to this link, and this:
    Code:
    # qdbus org.kde.kded /kded org.kde.kded.loadModule ktimezoned
    Cannot find 'org.kde.kded.loadModule' in object /kded at org.kde.kded
    This takes about 20secs to come back with the failure message. The delays in startup, right click (in Dolphin) are about 20 secs. Could be a coincidence, but I think not.

    I've tried reinstalling the kde-runtime packages, with no change in behaviour. Any advice?

  5. #5
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    168

    Exclamation Re: dbus lockup-> kdm

    and, I've just found this in kdm.log

    Code:
    klauncher(1126) kdemain: No DBUS session-bus found. Check if you have started the DBUS server. 
    kdeinit4: Communication error with launcher. Exiting!
    kdmgreet(1087)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Not connected to D-Bus server" 
    
    kdmgreet(1087)/kdecore (K*TimeZone*): No time zone information obtained from ktimezoned

  6. #6

    Default Re: dbus lockup?

    Quote Originally Posted by jetojedno View Post
    Following a number of links, I discovered in kmail startup (also very slow):
    Code:
    kmail2(10982)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken."
    and tracing that got me to this link, and this:
    Code:
    # qdbus org.kde.kded /kded org.kde.kded.loadModule ktimezoned
    Cannot find 'org.kde.kded.loadModule' in object /kded at org.kde.kded
    To rule out the most obvious problem: did you run that command as root, e.g. after running "su"? (because of the '#' which is the default prompt for root).
    That won't work, because root cannot see nor access the *user*'s DBUS session.
    So in that case, try it again as user, and kded has been renamed to kded5.

    Are you using KDE4 or Plasma5? And which version of kmail?
    There is no ktimezoned any more in KF5.

    If it is KDE4, check in "Configure Desktop"->Startup and Shutdown->Sevicemanagement that the "Timezone" service is enabled and running.

    This takes about 20secs to come back with the failure message. The delays in startup, right click (in Dolphin) are about 20 secs. Could be a coincidence, but I think not.
    Yes, the dbus timeout is 25 seconds.

    I've tried reinstalling the kde-runtime packages, with no change in behaviour. Any advice?
    Reinstalling random packages normally doesn't solve problems, at least in Linux.

    Quote Originally Posted by jetojedno View Post
    and, I've just found this in kdm.log

    Code:
    klauncher(1126) kdemain: No DBUS session-bus found. Check if you have started the DBUS server. 
    kdeinit4: Communication error with launcher. Exiting!
    kdmgreet(1087)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Not connected to D-Bus server" 
    
    kdmgreet(1087)/kdecore (K*TimeZone*): No time zone information obtained from ktimezoned
    That's irrelevant and normal.
    kdm runs outside of your user session anyway.

  7. #7
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    168

    Default Re: dbus lockup?

    Apologies for the '#.' All was run as normal logged in user.

    "Configure Desktop"->Startup and Shutdown->Sevicemanagement gets me nowhere => 20 sec delay then pop-up saying "Unable to contact KDED"

    here's a selection of installed packages:
    Code:
    kdebase4-workspace-branding-openSUSE-13.2-4.2.8.x86_64
    kdeartwork4-wallpapers-14.12.3-16.11.noarch
    plasma-addons-4.14.3-12.6.x86_64
    kdelibs4-core-4.14.9-27.1.x86_64
    kdepim4-4.14.10-28.2.x86_64
    kdebase4-openSUSE-13.2-4.2.8.x86_64
    kdebase4-workspace-libs-4.11.20-29.5.x86_64
    libkde4-4.14.9-27.1.x86_64
    kde4-l10n-en_GB-doc-4.14.3-4.7.noarch
    kde4-filesystem-4.14-2.1.2.x86_64
    kdebase4-workspace-addons-4.11.20-29.5.x86_64
    kdelibs4-4.14.9-27.1.x86_64
    patterns-openSUSE-kde4_basis-20141007-5.1.x86_64
    patterns-openSUSE-kde-20141007-5.1.x86_64
    kdebase4-workspace-4.11.20-29.5.x86_64
    kde4-l10n-en_GB-4.14.3-4.7.noarch
    kdepim4-runtime-4.14.10-28.1.x86_64
    kdepimlibs4-4.14.10-28.1.x86_64
    libkdecore4-4.14.9-27.1.x86_64
    kded-5.11.0-24.1.x86_64
    kdebase4-runtime-15.08.3-19.1.x86_64
    libkdepim4-4.14.10-28.2.x86_64
    kmail-4.14.10-28.2.x86_64
    kdebase4-session-4.12-3.1.2.noarch
    kdelibs3-3.5.10-83.1.10.x86_64
    kde-gtk-config-2.2.1-4.1.5.x86_64
    kde3-i18n-en_GB-base-3.5.10-29.1.10.noarch
    kde3-i18n-en_GB-3.5.10-29.1.10.noarch
    kde4-l10n-en_GB-data-4.14.3-4.7.noarch
    plasma-addons-akonadi-4.14.3-12.6.x86_64
    I really like computer systems which log "normal" errors - if they're normal why are they errors (or logged)?

  8. #8
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    168

    Default Re: dbus lockup?

    and ...
    Code:
    > qdbus org.kde.kded5 /kded org.kde.kded5.loadModule ktimezoned
    false
    > qdbus org.kde.kded5 /kded org.kde.kded5.loadedModules
    <<nothing>>

  9. #9

    Default Re: dbus lockup?

    Quote Originally Posted by jetojedno View Post
    Apologies for the '#.' All was run as normal logged in user.
    Ok.

    "Configure Desktop"->Startup and Shutdown->Sevicemanagement gets me nowhere => 20 sec delay then pop-up saying "Unable to contact KDED"
    Hm, then the problem may be deeper, if kded doesn't respond at all.

    Can you e.g. run "qdbus org.kde.kwin /KWin supportInformation", or does that hang as well and not output any information?

    How exactly are you logging in?
    Are you using a displaymanager/loginscreen (and which one), or are you running "startx" from text mode?
    Last edited by wolfi323; 19-Sep-2016 at 07:54.

  10. #10
    Join Date
    Aug 2008
    Location
    London, UK
    Posts
    168

    Default Re: dbus lockup?

    Code:
    $ qdbus org.kde.kwin /KWin supportInformation
    KWin Support Information:
    The following information should be used when requesting support on e.g. http://forum.kde.org.
    It provides information about the currently running instance, which options are used,
    what OpenGL driver and which effects are running.
    Please post the information provided underneath this introductory text to a paste bin service
    like http://paste.kde.org instead of pasting into support threads.
    
    ==========================
    
    Version
    =======
    KWin version: 4.11.20
    KDE SC version (runtime): 4.14.9
    KDE SC version (compile): 4.14.9
    Qt Version: 4.8.6
    
    Options
    =======
    focusPolicy: 0
    nextFocusPrefersMouse: false
    clickRaise: true
    autoRaise: false
    autoRaiseInterval: 0
    delayFocusInterval: 0
    shadeHover: false
    shadeHoverInterval: 250
    separateScreenFocus: false
    placement: 4
    focusPolicyIsReasonable: true
    borderSnapZone: 10
    windowSnapZone: 10
    centerSnapZone: 0
    snapOnlyWhenOverlapping: false
    showDesktopIsMinimizeAll: false
    rollOverDesktops: true
    focusStealingPreventionLevel: 1
    legacyFullscreenSupport: false
    operationTitlebarDblClick: 
    commandActiveTitlebar1: 0
    commandActiveTitlebar2: 30
    commandActiveTitlebar3: 2
    commandInactiveTitlebar1: 4
    commandInactiveTitlebar2: 30
    commandInactiveTitlebar3: 2
    commandWindow1: 7
    commandWindow2: 8
    commandWindow3: 8
    commandWindowWheel: 31
    commandAll1: 10
    commandAll2: 3
    commandAll3: 14
    keyCmdAllModKey: 16777251
    showGeometryTip: false
    condensedTitle: false
    electricBorderMaximize: true
    electricBorderTiling: true
    electricBorderCornerRatio: 0.25
    borderlessMaximizedWindows: false
    killPingTimeout: 5000
    hideUtilityWindowsForInactive: true
    inactiveTabsSkipTaskbar: false
    autogroupSimilarWindows: false
    autogroupInForeground: true
    compositingMode: 1
    useCompositing: true
    compositingInitialized: true
    hiddenPreviews: 1
    unredirectFullscreen: true
    glSmoothScale: 1
    colorCorrected: false
    xrenderSmoothScale: false
    maxFpsInterval: 16666666
    refreshRate: 0
    vBlankTime: 6000000
    glDirect: true
    glStrictBinding: false
    glStrictBindingFollowsDriver: true
    glLegacy: false
    glCoreProfile: false
    glPreferBufferSwap: 101
    
    Screen Edges
    ============
    desktopSwitching: false
    desktopSwitchingMovingClients: true
    cursorPushBackDistance: 
    timeThreshold: 300
    reActivateThreshold: 750
    actionTopLeft: 0
    actionTop: 0
    actionTopRight: 0
    actionRight: 0
    actionBottomRight: 0
    actionBottom: 0
    actionBottomLeft: 0
    actionLeft: 0
    
    Screens
    =======
    Multi-Head: no
    Active screen follows mouse:  no
    Number of Screens: 1
    Screen 0 Geometry: 0,0,1920x1080
    
    Decoration
    ==========
    Current Plugin: kwin3_oxygen
    Shadows: yes
    Alpha: yes
    Announces Alpha: yes
    Tabbing: yes
    Frame Overlap: no
    Blur Behind: no
    
    Compositing
    ===========
    Qt Graphics System: native
    Compositing is active
    Compositing Type: OpenGL
    OpenGL vendor string: X.Org
    OpenGL renderer string: Gallium 0.4 on AMD RV630
    OpenGL version string: 3.0 Mesa 10.3.7
    OpenGL shading language version string: 1.30
    Driver: R600G
    GPU class: R600
    OpenGL version: 3.0
    GLSL version: 1.30
    Mesa version: 10.3.7
    X server version: 1.16.1
    Linux kernel version: 3.16.7
    Direct rendering: yes
    Requires strict binding: no
    GLSL shaders:  yes
    Texture NPOT support:  yes
    Virtual Machine:  no
    OpenGL 2 Shaders are used
    Painting blocks for vertical retrace:  no
    
    Loaded Effects:
    ---------------
    kwin4_effect_zoom
    kwin4_effect_dimscreen
    kwin4_effect_slidingpopups
    kwin4_effect_login
    kwin4_effect_minimizeanimation
    kwin4_effect_screenshot
    kwin4_effect_slide
    kwin4_effect_desktopgrid
    kwin4_effect_translucency
    kwin4_effect_maximize
    kwin4_effect_fade
    kwin4_effect_highlightwindow
    kwin4_effect_taskbarthumbnail
    kwin4_effect_dialogparent
    kwin4_effect_blur
    kwin4_effect_logout
    kwin4_effect_dashboard
    kwin4_effect_kscreen
    
    Currently Active Effects:
    -------------------------
    kwin4_effect_blur
    
    Effect Settings:
    ----------------
    kwin4_effect_zoom:
    zoomFactor: 1.2
    mousePointer: 0
    mouseTracking: 0
    enableFocusTracking: false
    followFocus: true
    focusDelay: 350
    moveFactor: 20
    targetZoom: 1
    
    kwin4_effect_dimscreen:
    
    kwin4_effect_slidingpopups:
    fadeInTime: 250
    fadeOutTime: 250
    
    kwin4_effect_login:
    
    kwin4_effect_minimizeanimation:
    
    kwin4_effect_screenshot:
    
    kwin4_effect_slide:
    
    kwin4_effect_desktopgrid:
    zoomDuration: 300
    border: 10
    desktopNameAlignment: 0
    layoutMode: 0
    customLayoutRows: 2
    usePresentWindows: true
    
    kwin4_effect_translucency:
    
    kwin4_effect_maximize:
    
    kwin4_effect_fade:
    
    kwin4_effect_highlightwindow:
    
    kwin4_effect_taskbarthumbnail:
    
    kwin4_effect_dialogparent:
    
    kwin4_effect_blur:
    blurRadius: 12
    cacheTexture: true
    
    kwin4_effect_logout:
    useBlur: true
    
    kwin4_effect_dashboard:
    brightness: 0.5
    saturation: 0.5
    blur: false
    
    kwin4_effect_kscreen:
    I'm logging in from kdm to KDE Plasma Workspace

    Code:
    $ egrep -v '^[[:space:]]*(#|$)' /etc/sysconfig/displaymanager 
    DISPLAYMANAGER_XSERVER="Xorg"
    DISPLAYMANAGER="kdm4"
    DISPLAYMANAGER_STARTS_XSERVER="yes"
    DISPLAYMANAGER_AUTOLOGIN=""
    DISPLAYMANAGER_PASSWORD_LESS_LOGIN="no"
    DISPLAYMANAGER_AD_INTEGRATION="no"
    DISPLAYMANAGER_KDM_LOCALARGS=""
    The system seems to be behaving normally today, but it's done this before and then gone back to its bad behaviour.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •