Results 1 to 2 of 2

Thread: SAGA conflicts with wxWidgets

  1. #1

    Question SAGA conflicts with wxWidgets

    Hi! Trying my first steps in openSUSE and stepped into problem.

    Some applications like Kicad, SAGA require wxWidgets. If I install libwx_baseu-suse1 (and some others libwx_baseu) from openSUSE-Leap-42.1 then I can run Kicad from electronics repo.

    But saga_gui produces following error:
    Code:
    saga_gui: relocation error: /usr/lib64/libsaga_gdi-2.2.3.so: symbol _ZTI10wxListBase, version WXU_3.0 not defined in file libwx_baseu-suse.so.1 with link time reference
    I have tried to use libwx_baseu from Application:Geo repos but then saga_gui crashes without any error and Kicad is not working also.
    Some answers are here http://opensuse.14.x6.nabble.com/New-package-wxWidgets-3-0-nostl-td5066953.html something about STL. Bruno Friedmann-2 Jun 28, 2016; 6:33pm mentioned that: "And we got the same trouble in Application:Geo with Saga having a need for non stl." What is STL?

    Can somebody please explain, what I must do to run SAGA and Kicad on openSUSE Leap 42.1?

    Also tried to compile from sources wxWidgets + SAGA without any success.

    Recently moved from Mint to openSuse. No problems with Kicad and SAGA in Mint.

  2. #2

    Lightbulb Re: SAGA conflicts with wxWidgets

    Ok, managed to solve this problem. Maybe will be useful to someone else.

    The problem was in wxWidgets libs, which are provided in openSUSE OSS repos.
    There are two types of them: with (libwx_baseu-suse1 version 3.0.2-5.11, etc.) and without STL (libwx_baseu-suse-nostl1 version 3.0.2-18.10, etc.) committed by davejplater for Audacity issue. And both are not suitable for SAGA!
    The only libs SAGA can work with are in GEO repos (libwx_baseu-suse1 version 3.0.2-1.54 ad etc.). So the solution is to install libwx_baseu-xxx and libwx_gtk2u_xxx from GEO repos and use them only with SAGA (otherwise other wxWidgets based apps will not work, like Kicad). The installation is obvious, just put them into separate folder and use LD_LIBRARY_PATH to load with SAGA.

    Code:
    Complete list of libs for SAGA:
    libwx_baseu_net-suse.so.1  libwx_gtk2u_aui-suse.so.1   libwx_gtk2u_media-suse.so.1     libwx_gtk2u_richtext-suse.so.1
    libwx_baseu-suse.so.1      libwx_gtk2u_core-suse.so.1  libwx_gtk2u_propgrid-suse.so.1  libwx_gtk2u_stc-suse.so.1
    libwx_baseu_xml-suse.so.1  libwx_gtk2u_gl-suse.so.1    libwx_gtk2u_qa-suse.so.1        libwx_gtk2u_webview-suse.so.1
    libwx_gtk2u_adv-suse.so.1  libwx_gtk2u_html-suse.so.1  libwx_gtk2u_ribbon-suse.so.1    libwx_gtk2u_xrc-suse.so.1
    And bash to load saga:

    Code:
    #!/bin/sh
    LD_LIBRARY_PATH=~/your path to libs folder/
    export LD_LIBRARY_PATH
    exec saga_gui
    Maybe somebody knows the reason of such wxWidgets + STL issues?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •