Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Cannot get higher X resolution than 1024x768

  1. #1

    Default Cannot get higher X resolution than 1024x768

    Hi,

    This is a fresh Leap 42.1 install. No matter what I try, my screen resolution stick to 1024x768.
    I have a Radeon 66xx card. Monitor (DELL 2007FP) connected to the DVI output of the card. There is a HDMI converted attached to the HDMI output of the card.
    I disabled the HDMI output, as I thought maybe the attached hdmi converter cannot work on higher resolutions. But this made no difference.

    I've played around with the /etc/X11/xorg.conf.d/ directory contents, but no luck.

    I've added a new modeline (1600x1200_60.0) based on a cvt output, but this also made no difference.

    If I manually change to a higher resolution with xrandr within the X session, it is working, but I am looking for a way to do it with the xorg.conf files.

    Here are the relevant config files:
    /etc/X11/xorg.conf.d/50-device.conf:
    Code:
    # Having multiple "Device" sections is known to be problematic. Make
    # sure you don't have in use another one laying around e.g. in another
    # xorg.conf.d file or even a generic xorg.conf file. More details can
    # be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.
    #
    Section "Device"
      Identifier "Device0"
    
      Driver "radeon"
    #
    #  ## Required magic for radeon/radeonhd drivers; output name
    #  ## (here: "DVI-0") can be figured out via 'xrandr -q'
      Option "monitor-DVI-0" "Monitor0"
      Option "monitor-HDMI-0" "Monitor1"
    EndSection
    /etc/X11/xorg.conf.d/50-monitor.conf:
    Code:
    # Having multiple "Device" sections is known to be problematic. Make
    # sure you don't have in use another one laying around e.g. in another
    # xorg.conf.d file or even a generic xorg.conf file. More details can
    # be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.
    #
    Section "Device"
      Identifier "Device0"
    
      Driver "radeon"
    #
    #  ## Required magic for radeon/radeonhd drivers; output name
    #  ## (here: "DVI-0") can be figured out via 'xrandr -q'
      Option "monitor-DVI-0" "Monitor0"
      Option "monitor-HDMI-0" "Monitor1"
    EndSection
    /etc/X11/xorg.conf.d/50-screen.conf:
    Code:
    # Having multiple "Screen" sections is known to be problematic. Make
    # sure you don't have in use another one laying around e.g. in another
    # xorg.conf.d file or even a generic xorg.conf file. More details can
    # be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.
    #
    Section "Screen"
      Identifier "Screen0"
    #
      Device "Device0"
    #
    #  ## Doesn't help for radeon/radeonhd drivers; use magic in
    #  ## 50-device.conf instead
      Monitor "Monitor0"
      DefaultDepth 16
      SubSection "Display"
        Depth 16
        Modes "1600x1200_60.0"
      EndSubSection
      SubSection "Display"
        Depth 24
        Modes "1600x1200_60.0"
      EndSubSection
    EndSection
    As far as I can see, Xorg.log doesn't show anything fancy.

    I would appreciate any hints. Or alternatively, how to make the xrandr way to change resolution permanent, so I don't have to enter it every time I start a new X session.

    Edit:
    pastebin link for Xorg.0.log: http://pastebin.com/raw/WqWSgP8n

    Thanks in advance.
    Tamas
    Last edited by tcsabina; 16-Jan-2016 at 10:39. Reason: added link for looooong logfile ;)

  2. #2

    Default Re: Cannot get higher X resolution than 1024x768

    Quote Originally Posted by tcsabina View Post
    As far as I can see, Xorg.log doesn't show anything fancy.
    I'd say that it shows your kernel command line is messy.
    Code:
    [  5819.397] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.1.12-1-default root=UUID=9a5311d9-c1a6-46cf-b33b-42c3f0b3b9b1 isofrom=/dev/disk/by-label/UUI:/openSUSE-Leap-42.1-NET-x86_64.iso isofrom_device=/dev/disk/by-label/UUI isofrom_system=/openSUSE-Leap-42.1-NET-x86_64.iso loader=syslinux resume=/dev/disk/by-uuid/e9c201ee-c6cf-466d-92e6-3f104daa1a6a splash=verbose quiet showopts
    Why don't you clean that up, and do away with your xorg.cong file changes (which, btw, were done incorrectly; see below), and then see what happens by default and report the xorg log for that configuration if it doesn't work automagically.

    Here are the relevant config files:
    /etc/X11/xorg.conf.d/50-device.conf:
    Code:
    # Having multiple "Device" sections is known to be problematic. Make
    # sure you don't have in use another one laying around e.g. in another
    # xorg.conf.d file or even a generic xorg.conf file. More details can
    # be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.
    #
    Section "Device"
      Identifier "Device0"
    
      Driver "radeon"
    #
    #  ## Required magic for radeon/radeonhd drivers; output name
    #  ## (here: "DVI-0") can be figured out via 'xrandr -q'
      Option "monitor-DVI-0" "Monitor0"
      Option "monitor-HDMI-0" "Monitor1"
    EndSection
    /etc/X11/xorg.conf.d/50-monitor.conf:
    Code:
    # Having multiple "Device" sections is known to be problematic. Make
    # sure you don't have in use another one laying around e.g. in another
    # xorg.conf.d file or even a generic xorg.conf file. More details can
    # be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.
    #
    Section "Device"
      Identifier "Device0"
    
      Driver "radeon"
    #
    #  ## Required magic for radeon/radeonhd drivers; output name
    #  ## (here: "DVI-0") can be figured out via 'xrandr -q'
      Option "monitor-DVI-0" "Monitor0"
      Option "monitor-HDMI-0" "Monitor1"
    EndSection
    /etc/X11/xorg.conf.d/50-screen.conf:
    Code:
    # Having multiple "Screen" sections is known to be problematic. Make
    # sure you don't have in use another one laying around e.g. in another
    # xorg.conf.d file or even a generic xorg.conf file. More details can
    # be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.
    #
    Section "Screen"
      Identifier "Screen0"
    #
      Device "Device0"
    #
    #  ## Doesn't help for radeon/radeonhd drivers; use magic in
    #  ## 50-device.conf instead
      Monitor "Monitor0"
      DefaultDepth 16
      SubSection "Display"
        Depth 16
        Modes "1600x1200_60.0"
      EndSubSection
      SubSection "Display"
        Depth 24
        Modes "1600x1200_60.0"
      EndSubSection
    EndSection
    IOW, you defined two device sections simply because that is what both your device.conf and monitor.conf files are doing! ... you, of course, would want your monitor.conf file to reflect "Monitor0"

  3. #3

    Default Re: Cannot get higher X resolution than 1024x768

    Thanks for the fast reply.

    I made a mistake quoting my monitor.conf file. I accidently duplicated the device.conf file...

    Here is the proper content:
    Code:
    # Having multiple "Monitor" sections is known to be problematic. Make
    # sure you don't have in use another one laying around e.g. in another
    # xorg.conf.d file or even a generic xorg.conf file. More details can
    # be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.
    #
    Section "Monitor"
      Identifier "Monitor0"
    #
    #  ## If your monitor doesn't support DDC you may override the
    #  ## defaults here
      HorizSync 30-83
      VertRefresh 56-76
    #
    #  ## Add your mode lines here, use e.g the cvt tool
    #  Modeline "1600x1200@60.0"  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync
      Modeline "1600x1200_60.0"  161.00  1600 1712 1880 2160  1200 1203 1207 1245 +hsync +vsync
      Option "PreferredMode" "1600x1200_60.0"
    EndSection
    
    Section "Monitor"
      Identifier "Monitor1"
      Option "ignore" "true"
    EndSection
    I can see the entry at the top in this file as well, not the create multiple 'Monitor' sections. As I have said, the second Monitor entry was added as a kind of test, to disable the HDMI output. Before it was added, it was also not working.


    Could you give me some tips how to 'clean up' to kernel command line part? I did a fresh Leap42.1 install (from a net.iso, as visible). And the only thing I modified in the boot loader conf is to change from 'silent' to 'verbose', so I can see the loading of modules/services upon booting.
    I have no clue what to do with this.

    In the meainwhile I gave it a try to install the fglrx packages. But that didn't work out well too. I was not even able to start an X session, so I uninstalled it to get back to at least a working, low res mode.

    Another strange thing that after a reboot, the initial login screen (where I have to type in my username and password) is running in 1600x1200, but when I login, the screen mode changes to 1024x768. So it seems that the changes in the config files are going in the good direction, and probably something left in my user's session that changes back to the low res mode.
    For you information, I am using enlightenmnet as window manager.



    What is also strange, that my console (on tty1 for example, by hitting ctrl+alt+F1) is running in a frambuffer mode, but it is not full screen. When I am using a full screen console application, like Midnight commander, only the top left part of the screen is used. Regarding to my monitor, the console runs in 1600x1200. But I could live with this for the time being. My main concern is the X session resolution.


    Thanks,
    Tamas

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,991
    Blog Entries
    1

    Default Re: Cannot get higher X resolution than 1024x768

    Can you show us (via Xorg.0.log) what happens when you don't have any manual configuration? I note that the monitor reports "1600x1200" as a viable display mode
    Code:
    [  5819.538] (II) RADEON(0): Modeline "1600x1200"x60.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (75.0 kHz eP)
    I wonder why it is not used?

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,991
    Blog Entries
    1

    Default Re: Cannot get higher X resolution than 1024x768

    Also, what happens if the 'PreferredMode' option is left out?
    Code:
    Option "PreferredMode" "1600x1200_60.0

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    22,991
    Blog Entries
    1

    Default Re: Cannot get higher X resolution than 1024x768

    This thread may be helpful to you as well

    https://forums.opensuse.org/showthre...n-from-monitor

  7. #7
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,167

    Default Re: Cannot get higher X resolution than 1024x768

    Assuming KDE I guess you changed the res there also since that will override xorg settings

    Also be sure you use kscreen5 I think there is a possibility of some confusion with older code that is still included to support older programs

  8. #8

    Default Re: Cannot get higher X resolution than 1024x768

    Thanks everyone for the support and replies.

    It turned out that my Enlightemnet configuration was overwriting my attempts on the xorg.conf files. After diving deeper into the Enlightemnet configuration I was able to set up the resolution to the preferred 1600x1200 mode. (Settings->All->Screen->Screen setup in this case of the Enlightenment menu.)
    There is no need to add anything manually to the xorg.conf sections. So I removed all the changes I've made.

    I am now a happier Leap42.1 user

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,167

    Default Re: Cannot get higher X resolution than 1024x768

    Yes Linux is multi user and each user can have their own preferences which is controlled by the desktop

  10. #10

    Default Re: Cannot get higher X resolution than 1024x768

    Quote Originally Posted by tcsabina View Post
    I made a mistake quoting my monitor.conf file. I accidently duplicated the device.conf file...
    I had wondered in which manner the copy and paste error applied


    Could you give me some tips how to 'clean up' to kernel command line part? I did a fresh Leap42.1 install (from a net.iso, as visible). And the only thing I modified in the boot loader conf is to change from 'silent' to 'verbose', so I can see the loading of modules/services upon booting.
    I have no clue what to do with this.
    Disregard my comment. I had not looked at it closely, and mistakenly thought I spotted duplicate entries .. plus I was thinking that it was a regular install to disk as opposed to the iso booting

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •