Results 1 to 7 of 7

Thread: Second display not working correctly (after nVidia driver update)

  1. #1

    Question Second display not working correctly (after nVidia driver update)

    Recently I ran 'zypper up' and it updated the nVidia drivers (G04 for my card).

    I have a second monitor which most of the time is turned off but I turn it on when I need more working space. Today I turned it on and I noticed that it stays black (but on) and if I re-configure it using KScreen2 (disable and enable) it works. However this is not remembered and I have to do it on each relogin.

    When I installed Leap some months ago I had a similar issue but at that time only the screen rotation to 90deg was not remembered. At that time I discovered that I can fix it using the NVIDIA X Sever Settings tool and export the configuration, then save it to /etc/X11/xorg.conf. However today that "trick" doesn't work. In fact the conf file which nVidia's utility generates is the same as the one which already exists in /etc/X11/xorg.conf

    Would should I do to make second screen configuration persistent?

    (using Plasma 5 and kdm, everything up to date from official repos)

  2. #2

    Default Re: Second display not working correctly (after nVidia driver update)

    If you want to be sure that the settings in xorg.conf are used, you should disable "KScreen2" in "Configure Desktop"->"Startup and Shutdown"->"Background Services".
    Otherwise KScreen will try to apply its own settings on login and whenever you connect or disconnect (turn on or off) a monitor.

    If you don't want to (as it has been working before) you can also try to delete KScreen's config in ~/.local/share/kscreen/.
    Maybe it somehow got corrupted and therefore kscreen cannot save the monitor state and turns it off at login because that's what its saved settings say apparently.
    Last edited by wolfi323; 06-Aug-2016 at 12:56.

  3. #3

    Default Re: Second display not working correctly (after nVidia driver update)

    Quote Originally Posted by wolfi323 View Post
    If you want to be sure that the settings in xorg.conf are used, you should disable "KScreen2" in "Configure Desktop"->"Startup and Shutdown"->"Background Services".
    Otherwise KScreen will try to apply its own settings on login and whenever you connect or disconnect (turn on or off) a monitor.
    I checked it is disabled. Perhaps I have disabled it the previous time with the earlier issue.

    If you don't want to (as it has been working before) you can also try to delete KScreen's config in ~/.local/share/kscreen/.
    Maybe it somehow got corrupted and therefore kscreen cannot save the monitor state and turns it off at login because that's what its saved settings say apparently.
    In fact it was not working even before, that's why I disabled it. Also in ~/.local/share/kscreen/ I see only one file named c07595fce3ead8117d891a0375d7d775 with date Nov 4 and this content: http://paste.opensuse.org/4dbb5aae which at first glance seems correct.

    I tried to re-enable KScreen2 but nothing changed.

    What would you suggest?

  4. #4

    Default Re: Second display not working correctly (after nVidia driver update)

    Quote Originally Posted by heyjoe View Post
    In fact it was not working even before, that's why I disabled it.
    Well, if KScreen2 is disabled, KDE/Plasma does not handle the displays at all, and the settings you make in "Configure Desktop" have no effect whatsoever.

    So your current problem must lie in your xorg.conf or the nvidia driver itself.

    Maybe post your xorg.conf and the log file /var/log/Xorg.0.log.

    I have absolutely no experience with multi-monitor system, but I suspect that the log file should give a clue why the second monitor is regarded as disabled or why it is not used to display a picture.
    And if the xorg.conf is at fault, one might spot an error by looking at the actual file.

    Also in ~/.local/share/kscreen/ I see only one file named c07595fce3ead8117d891a0375d7d775 with date Nov 4 and this content: http://paste.opensuse.org/4dbb5aae which at first glance seems correct.
    But if KScreen2 is disabled, this is not even loaded.

    What would you suggest? Re-enable KScreen2?
    Would be worth a try.

  5. #5

    Default Re: Second display not working correctly (after nVidia driver update)

    Quote Originally Posted by wolfi323 View Post
    Well, if KScreen2 is disabled, KDE/Plasma does not handle the displays at all, and the settings you make in "Configure Desktop" have no effect whatsoever.

    So your current problem must lie in your xorg.conf or the nvidia driver itself.
    That's what I am thinking too. However the xorg.conf file is the same one which I have on tape backup from 7.Jun, so nothing has changed there.

    Maybe post your xorg.conf and the log file /var/log/Xorg.0.log.
    xorg.conf:
    http://paste.opensuse.org/70a75810

    /var/log/Xorg.0.log:
    http://paste.opensuse.org/421f8979


    I have absolutely no experience with multi-monitor system, but I suspect that the log file should give a clue why the second monitor is regarded as disabled or why it is not used to display a picture.
    And if the xorg.conf is at fault, one might spot an error by looking at the actual file.
    It is a simple setup:
    The main screen is horizontal, the secondary one is rotated at 90deg. I think the config file shows that too. So in case it is the driver - what are my options? I can't find a way to downgrade as in YaST I see only one version.

    But if KScreen2 is disabled, this is not even loaded.

    Would be worth a try.
    Yes, I tried and edited my previous post but I guess you were faster.

  6. #6

    Default Solved (for the moment)

    Update:

    I was lucky to get in touch with NVIDIA's email support. After explaining them the problem in full and a few tests, it finally turned out to be indeed a driver issue.

    I used the following steps suggested by NVIDIA's support in order to downgrade my driver:

    1. remove existing driver using the de-installation procedure here: https://en.opensuse.org/SDB:NVIDIA_drivers

    2. reboot to assure X still starts after removal

    3. locate an older driver (ideally the previous driver you used) by going here http://www.nvidia.com/Download/index.aspx?lang=en-us and selecting from the left bottom area 'Beta and Older Drivers.'
    Fill in the required fields and a number of older drivers are available. Download the one you want.

    4. blacklist the open source nouveau driver that conflicts with the nvidia driver. As root or using sudo, run this command:

    echo 'blacklist nouveau' >/etc/modprobe.d/blacklist-nouveau.conf

    Then run the command mkinitrd and reboot.

    5. stop the X server with the command as root:

    init 3

    6. install dependencies for driver installation by the command as root:

    zypper install libX11-devel kernel-devel make gcc

    7. change directory to the Download directory where the driver got downloaded to. Run the command as root:

    sh <driver_name> and follow on screen instructions

    8. when done, as root:

    init 5
    Following these instructions I uninstalled the existing drivers and installed the previous driver version (361.45.18).

    After running 'init 5' my monitor layout configuration was restored the way it was before and everything works fine. I didn't need to reconfigure anything. And it is persistent (I tried a few logins and a reboot).

    The guys from NVIDIA explained they will fix the problem but it may take some time.


    I hope that info helps others who may run into similar issues.

  7. #7

    Default Re: Second display not working correctly (after nVidia driver update)

    Update:

    The new version of the driver 367-44-26.1 seems to fix the issue.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •