Results 1 to 7 of 7

Thread: ktimer, how to avoid to show window at startup

  1. #1

    Default ktimer, how to avoid to show window at startup

    my system is running opensuse leap 42.1 with plasma 5.7.3:
    Laptop=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz
    upgraded 13.2 to leap 42.1, using wolfi repos. I'm running KDE 4.14.18 and plasma 5.7.3, KDE frameworks 5.24.0, KDE applications 16.04.3, Kernel 4.1.27-27-default

    I use ktimer to show me an advice every few minutes, I found it as an entry in the system tray and I used it, so it correctly appear in the system tray, but at startup ktimer show its window, how can I avoid this??
    manythanks, ciao, pier :-)

  2. #2

    Default Re: ktimer, how to avoid to show window at startup

    Quote Originally Posted by pier_andreit View Post
    I use ktimer to show me an advice every few minutes, I found it as an entry in the system tray and I used it, so it correctly appear in the system tray, but at startup ktimer show its window, how can I avoid this??
    Seems to be a bug in ktimer, it apparently doesn't remember its window state and always opens it even when started by session management.

    Have you tried ktimer5 instead? Maybe it has been fixed in the KF5 port...

    The only workaround I can think of would be to create a window rule that forces ktimer to start minimized (it would still show up in the task switcher though):
    Right-click on the window titlebar (or left-click on the window icon), choose "Other Actions"->"Special Window Settings"->"Size & Position". Enable "Minimized", and set it to "Apply Initialy" and "Yes".

    And/or have a look at kalarm.
    Should be able to do what you want too, it is a lot more sophisticated than ktimer...
    See http://www.astrojar.org.uk/kalarm/index.html or https://www.kde.org/applications/utilities/kalarm/
    Last edited by wolfi323; 06-Aug-2016 at 04:00.

  3. #3

    Default Re: ktimer, how to avoid to show window at startup

    I tried time ago and I didn't like, but now I try to start it but this akonadi error occurred:
    http://paste.opensuse.org/20824573

  4. #4

    Default Re: ktimer, how to avoid to show window at startup

    Quote Originally Posted by wolfi323 View Post
    Seems to be a bug in ktimer, it apparently doesn't remember its window state and always opens it even when started by session management.

    Have you tried ktimer5 instead? Maybe it has been fixed in the KF5 port...
    yes, it is the 5
    ktimer5 - Countdown Launcher

  5. #5

    Default Re: ktimer, how to avoid to show window at startup

    Quote Originally Posted by pier_andreit View Post
    I tried time ago and I didn't like, but now I try to start it but this akonadi error occurred:
    http://paste.opensuse.org/20824573
    If you use KDEPIM5, you also need to use kalarm5.

    KDE4 versions do not work with Akonadi5 and vice-versa.

    And if you ever started Akonadi5, Akonadi4 might not be able to open the database any more (they use the same files).
    Upgrades are supported, but not downgrades...

    And that also applies if you use my repo.
    That only allows you to have both installed, not being able to use both interchangably (as I would have to completely rewrite KDEPIM4 for that...).

    Quote Originally Posted by pier_andreit View Post
    yes, it is the 5
    Well, the KDE4 version shows the same behavior.

    You might want to file a bug report at http://bugs.kde.org about that.
    Last edited by wolfi323; 06-Aug-2016 at 07:04.

  6. #6

    Default Re: ktimer, how to avoid to show window at startup

    Quote Originally Posted by wolfi323 View Post
    The only workaround I can think of would be to create a window rule that forces ktimer to start minimized (it would still show up in the task switcher though):
    Right-click on the window titlebar (or left-click on the window icon), choose "Other Actions"->"Special Window Settings"->"Size & Position". Enable "Minimized", and set it to "Apply Initialy" and "Yes"
    See http://www.astrojar.org.uk/kalarm/index.html or https://www.kde.org/applications/utilities/kalarm/
    manythanks, this workaround works

  7. #7

    Default Re: ktimer, how to avoid to show window at startup

    Quote Originally Posted by wolfi323 View Post
    You might want to file a bug report at http://bugs.kde.org about that.
    just done now

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •