Results 1 to 8 of 8

Thread: Conky won't start

  1. #1
    Join Date
    Jan 2011
    Location
    Guadalajara
    Posts
    173

    Default Conky won't start

    I have conky installed on Tumbleweed Xfce but it won't open at present.


    This is the error message:

    Code:
    ~> conky
    conky: desktop window (1400003) is subwindow of root window (be)
    conky: window type - desktop
    conky: drawing to created window (0x7000001)
    Segmentation fault (core dumped)


    I have had no other problems with Tumbleweed and while this is not a major issue, I would like to fix it.


    What is the remedy? (I already tried uninstalling and reinstalling it).


    TIA

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: Conky won't start

    Quote Originally Posted by d_hinds View Post
    I have conky installed on Tumbleweed Xfce but it won't open at present.


    This is the error message:

    Code:
    ~> conky
    conky: desktop window (1400003) is subwindow of root window (be)
    conky: window type - desktop
    conky: drawing to created window (0x7000001)
    Segmentation fault (core dumped)


    I have had no other problems with Tumbleweed and while this is not a major issue, I would like to fix it.


    What is the remedy? (I already tried uninstalling and reinstalling it).


    TIA
    Hi
    What version of conky, are the configs converted?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jan 2011
    Location
    Guadalajara
    Posts
    173

    Default Re: Conky won't start

    Quote Originally Posted by malcolmlewis View Post
    Hi
    What version of conky, are the configs converted?
    The version is 1.10.2-1.5, which is the current version and was installed using Yast's Software Management application.

    I haven't modified the default configs, as yet. Conky was working fine until a system update (that may have been interrupted), occurred.

    The error message:

    Code:
    Segmentation fault (core dumped)
    indicates something I believe, but I am unsure as to how to deal with it.

    Thanks Malcolm, for the response.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: Conky won't start

    Quote Originally Posted by d_hinds View Post
    The version is 1.10.2-1.5, which is the current version and was installed using Yast's Software Management application.

    I haven't modified the default configs, as yet. Conky was working fine until a system update (that may have been interrupted), occurred.

    The error message:

    Code:
    Segmentation fault (core dumped)
    indicates something I believe, but I am unsure as to how to deal with it.

    Thanks Malcolm, for the response.
    Hi
    I have it running fine here on Tumbleweed... update interrupted? the 4.7.0 kernel update is slow.... leaving it for awhile and see if it does finish.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Jan 2011
    Location
    Guadalajara
    Posts
    173

    Default Re: Conky won't start

    Quote Originally Posted by malcolmlewis View Post
    Hi
    I have it running fine here on Tumbleweed... update interrupted? the 4.7.0 kernel update is slow.... leaving it for awhile and see if it does finish.
    What about the message:

    Code:
    Segmentation fault (core dumped)
    That appears when I attempt to start conky via the Xfce Terminal? I assume that the message is explaining why it doesn't appear.

    This is not a major issue, since a number of widgets for the Xfce4-panel provide the same information and they are working fine.

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: Conky won't start

    Hi
    So what config file are you using, one in your home directory? If so can you post it.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Jan 2011
    Location
    Guadalajara
    Posts
    173

    Default Re: Conky won't start

    Quote Originally Posted by malcolmlewis View Post
    Hi
    So what config file are you using, one in your home directory?
    I suppose so. As mentioned, conky was installed via Yast's Software Management app and the default settings have not been modified.

    Quote Originally Posted by malcolmlewis View Post
    If so can you post it.
    OK but I will have to switch back to the ThinkPad, which is where I have Tumbleweed installed. (I intend to do so on the other computers later. It's been trouble free).

    The file is conky.rc, if I recall.

  8. #8
    Join Date
    Jan 2011
    Location
    Guadalajara
    Posts
    173

    Default Re: Conky won't start

    I was unable to locate the conky.conf or conky.rc file.

    The conky executable is in /user/bin and conky.doc is in /usr/share/doc/packages/

    I did uninstall and reinstall conky with no change.

    After reading the files in conky.doc maybe I will come up with something.

    In any case, thanks for your suggestions.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •