Results 1 to 2 of 2

Thread: Unable to downgrade Xorg

  1. #1

    Default Unable to downgrade Xorg

    Hello,
    I ran into a problem where my AMD drivers does not work with the Xorg version 1.18. To fix this I am trying to downgrade Xorg.
    To do this I tried typing:
    cat /var/log/zypp/history | grep xorg-x11-server
    into the Konsole to find the version I was using
    The output was:
    2014-10-26 09:07:24|install|xorg-x11-server-extra|7.6_1.16.1-2.1|x86_64|root@opensuse|InstallationImage|941cbbc3c10d56ec21c683eb0b34a3ad8cd5aefc255ce9530e31f8992ee8c80f|
    # 2014-10-26 09:07:34 xorg-x11-server.rpm installed ok
    2014-10-26 09:07:34|install|xorg-x11-server|7.6_1.16.1-2.1|x86_64|root@opensuse|InstallationImage|e157d2e5d7cc3e33a0eab72f0eb6cfb6bdb7b8909caabdeae53076484b054bc3|
    2015-01-01 16:32:41|install|xorg-x11-server-extra|7.6_1.16.1-5.1|x86_64||repo-update|2f8ef3d047ab43da83bf26b116f1264c81f906fe130cd2dc4e101da84ff8be0d|
    # 2015-01-01 16:33:24 xorg-x11-server-7.6_1.16.1-5.1.x86_64.rpm installed ok
    2015-01-01 16:33:24|install|xorg-x11-server|7.6_1.16.1-5.1|x86_64||repo-update|f15058bd4731e84bed599698fe8545dd056205a50f3e7c4fb23c31427787ff86|
    2015-04-17 21:31:38|install|xorg-x11-server-extra|7.6_1.16.1-13.1|x86_64||repo-update|2add3dc1497cf79fe5d068d35d3ea7790ec16739334b3c14026abe4b1a3f24e8|
    # 2015-04-17 21:31:46 xorg-x11-server-7.6_1.16.1-13.1.x86_64.rpm installed ok
    2015-04-17 21:31:46|install|xorg-x11-server|7.6_1.16.1-13.1|x86_64||repo-update|64c864ae65502f7be92978c8d2d4abeee57535d5ed1dd9aa0b38a7056d317eec|
    2016-05-15 14:27:58|install|xorg-x11-server-extra|7.6_1.18.3-1.1|x86_64||repo-oss|f52373cfbcdfd06807b408edb706f73a762c086b|
    # 2016-05-15 14:28:56 xorg-x11-server-7.6_1.18.3-1.1.x86_64.rpm installed ok
    2016-05-15 14:28:56|install|xorg-x11-server|7.6_1.18.3-1.1|x86_64||repo-oss|dfb67320c14e32b999d579d8f98d75e7c4c8479c|
    2016-05-21 13:47:10|install|xorg-x11-server-extra|7.6_1.18.3-3.1|x86_64||repo-oss|6f8beea3b3d8c75c878f9a1a53724ec38c5b4520|
    # 2016-05-21 13:47:11 xorg-x11-server-7.6_1.18.3-3.1.x86_64.rpm installed ok
    2016-05-21 13:47:11|install|xorg-x11-server|7.6_1.18.3-3.1|x86_64||repo-oss|7d794c899b02035159b2095e09963ea91d7a012a|
    2016-06-05 13:39:21|install|xorg-x11-server-extra|7.6_1.18.3-4.1|x86_64|root@Kaladin|repo-oss|5713a6f7b264187949282bcad1bd85f6ec9c7fd9|
    # 2016-06-05 13:39:40 xorg-x11-server-7.6_1.18.3-4.1.x86_64.rpm installed ok
    2016-06-05 13:39:40|install|xorg-x11-server|7.6_1.18.3-4.1|x86_64|root@Kaladin|repo-oss|fd2a1c72fc6156cb926941b9212de6bb2ae9b416|
    2016-07-31 07:38:54|install|xorg-x11-server-extra|7.6_1.18.3-4.2|x86_64|root@Kaladin|repo-oss|624c120720cf823f30f0f221484c5600e2ca0ae8|
    # 2016-07-31 07:38:54 xorg-x11-server-7.6_1.18.3-4.2.x86_64.rpm installed ok
    2016-07-31 07:38:54|install|xorg-x11-server|7.6_1.18.3-4.2|x86_64|root@Kaladin|repo-oss|48d98f1b67a95d755757b24b36ebf1abc0b52d20|
    2016-08-01 19:37:11|command|root@Kaladin|'zypper' 'in' 'xorg-x11-server'|
    # 2016-08-01 19:37:14 xorg-x11-server-7.6_1.18.4-1.1.x86_64.rpm installed ok
    2016-08-01 19:37:14|install|xorg-x11-server|7.6_1.18.4-1.1|x86_64|root@Kaladin|repo-oss|a7aee58c7e2e5ea4d34c8f5417e44f2737f4725b|
    2016-08-01 20:08:25|install|xorg-x11-server-extra|7.6_1.18.4-1.1|x86_64||repo-oss|8b40b60f1b3dbcb30e4147e60510df75cf7532ad|
    Seeing as the last version I used before 1.18 was '7.6_1.16.1-13.1' I typed
    sudo zypper in -f xorg-x11-server=7.6_1.16.1-13.1
    It responded by saying
    Package 'xorg-x11-server=7.6_1.16.1-13.1' not found.
    Any help would be appreciated.

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Unable to downgrade Xorg

    Tumbleweed is a rolling distro, so that old packages are REPLACED by newer ones in the repositories and you cannot downgrade as you would do e.g. in Leap.
    If you are using the default install with BTRFS, you might still have a snapshot taken before your upgrade.
    If so, you might be able to boot from that snapshot (see "Advanced Options" at the GRUB menu), lock the Xorg packages in Yast so that they don't get upgraded, then perform a "zypper dup".
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •