Results 1 to 4 of 4

Thread: Nvidia Update no module loaded

  1. #1

    Default Nvidia Update no module loaded

    After Update I get this Error:
    You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server.
    Code:
    sidro@home:~> lsmod | grep nvidia
    sidro@home:~> lsmod | grep nouveau
    Code:
    sidro@home:~> inxi -F
    System:    Host: home Kernel: 4.1.27-27-default x86_64 (64 bit) 
               Desktop N/A Distro: /etc/SuSE-release corrupted, use -% to override
    Machine:   Mobo: ASUSTeK model: P5KPL-VM version: x.xx Bios: American Megatrends version: 1003 date: 08/23/2010
    CPU:       Dual core Intel Core2 Duo CPU E8300 (-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) 
               Clock Speeds: 1: 1998.00 MHz 2: 1998.00 MHz
    Graphics:  Card: NVIDIA GM107 [GeForce GTX 750 Ti] 
               X.Org: 1.17.2 drivers: nvidia,fbdev,nv,nouveau (unloaded: vesa) Resolution: 1280x1024@77.0hz 
               GLX Renderer: N/A GLX Version: N/A
    Audio:     Card-1: Intel NM10/ICH7 Family High Definition Audio Controller driver: snd_hda_intel
               Card-2: NVIDIA Device 0fbc driver: snd_hda_intel
               Sound: Advanced Linux Sound Architecture ver: k4.1.27-27-default
    Network:   Card: Qualcomm Atheros Attansic L1 Gigabit Ethernet driver: atl1 
               IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:1e:8c:19:d1:63
    Drives:    HDD Total Size: 500.1GB (183.9% used) 1: /dev/sda SAMSUNG_HD502HJ 500.1GB 
    Partition: ID: / size: 41G used: 26G (66%) fs: btrfs ID: /tmp size: 41G used: 26G (66%) fs: btrfs 
               ID: /home size: 418G used: 371G (94%) fs: ext4 ID: swap-1 size: 1.07GB used: 0.00GB (0%) fs: swap 
    Sensors:   System Temperatures: cpu: 43.0C mobo: N/A 
               Fan Speeds (in rpm): cpu: 1739 sys-1: 0 
    Info:      Processes: 169 Uptime: 0:03 Memory: 593.8/3952.1MB Client: Shell inxi: 1.7.24 
    sidro@home:~>
    Nvidia in last time have bad rpms.
    Why I don't know. Maybe beacuase is not well packaged.

    Code:
    # modprobe nvidia
    modprobe: ERROR: could not find module by name='nvidia'
    modprobe: ERROR: could not insert 'nvidia': Function not implemented
    modprobe: FATAL: Module nvidia_uvm not found.
    mknod: missing operand after ‘0’
    Try 'mknod --help' for more information.

  2. #2

    Default Re: Nvidia Update no module loaded

    Code:
     # zypper in --force `rpm -qa "nvidia-gfx*kmp*"`
    Loading repository data...
    Reading installed packages...
    Forcing installation of 'nvidia-gfxG04-kmp-default-367.35_k4.1.12_1-25.1.x86_64' from repository 'nVidia Graphics Drivers'.
    Resolving package dependencies...
    
    The following package is going to be reinstalled:
      nvidia-gfxG04-kmp-default
    
    1 package to reinstall.
    Overall download size: 5.8 MiB. Already cached: 0 B. No additional space will be used or freed after the
    operation.
    Continue? [y/n/? shows all options] (y): y
    Retrieving package nvidia-gfxG04-kmp-default-367.35_k4.1.12_1-25.1.x86_64
                                                                             (1/1),   5.8 MiB ( 64.6 MiB unpacked)
    Retrieving: nvidia-gfxG04-kmp-default-367.35_k4.1.12_1-25.1.x86_64.rpm .................................[done]
    Checking for file conflicts: ...........................................................................[done]
    (1/1) Installing: nvidia-gfxG04-kmp-default-367.35_k4.1.12_1-25.1.x86_64 ...............................[done]
    Additional rpm output:
    make: Entering directory '/usr/src/linux-4.1.27-27-obj/x86_64/default'
      Building modules, stage 2.
      MODPOST 0 modules
    make: Leaving directory '/usr/src/linux-4.1.27-27-obj/x86_64/default'
    /usr/src/kernel-modules/nvidia-367.35-default /
    make "CC=cc" KBUILD_OUTPUT=/usr/src/linux-obj/x86_64/default KBUILD_VERBOSE= -C /lib/modules/4.1.27-27-default/source M=/usr/src/kernel-modules/nvidia-367.35-default ARCH=x86_64 NV_KERNEL_SOURCES=/lib/modules/4.1.27-27-default/source NV_KERNEL_OUTPUT=/usr/src/linux-obj/x86_64/default NV_KERNEL_MODULES="nvidia nvidia-uvm nvidia-modeset nvidia-drm" INSTALL_MOD_DIR=kernel/drivers/video modules
    make[1]: Entering directory '/usr/src/linux-4.1.27-27'
    make[2]: Entering directory '/usr/src/linux-4.1.27-27-obj/x86_64/default'
      Building modules, stage 2.
      MODPOST 4 modules
    make[2]: Leaving directory '/usr/src/linux-4.1.27-27-obj/x86_64/default'
    make[1]: Leaving directory '/usr/src/linux-4.1.27-27'
    ld -T /lib/modules/4.1.27-27-default/source/scripts/module-common.lds -r -o nv-linux.o \
      nvidia.mod.o nvidia/nv-interface.o
    /
    depmod: WARNING: could not open /lib/modules/4.1.12-1-default/modules.order: No such file or directory
    depmod: WARNING: could not open /lib/modules/4.1.12-1-default/modules.builtin: No such file or directory
    
    Modprobe blacklist files have been created at /etc/modprobe.d to prevent Nouveau from loading. This can be reverted by deleting /etc/modprobe.d/nvidia-*.conf.
    
    *** Reboot your computer and verify that the NVIDIA graphics driver can be loaded. ***
    
    depmod: WARNING: //lib/modules/4.1.27-27-default/misc/vboxvideo.ko disagrees about version of symbol VBoxGuest_RTLogBackdoorPrintf
    depmod: WARNING: //lib/modules/4.1.27-27-default/misc/vboxvideo.ko disagrees about version of symbol VBoxGuest_RTErrConvertToErrno
    depmod: WARNING: //lib/modules/4.1.27-27-default/misc/vboxvideo.ko disagrees about version of symbol VBoxGuest_RTAssertShouldPanic
    depmod: WARNING: //lib/modules/4.1.27-27-default/misc/vboxvideo.ko disagrees about version of symbol VBoxGuest_RTAssertMsg1Weak
    depmod: WARNING: //lib/modules/4.1.27-27-default/misc/vboxvideo.ko disagrees about version of symbol VBoxGuest_RTAssertMsg2Weak
    Warning: /lib/modules/4.1.27-27-default is inconsistent
    Warning: weak-updates symlinks might not be created
    
    
    Output of nvidia-gfxG04-kmp-default-367.35_k4.1.12_1-25.1.x86_64.rpm %posttrans script:
        Creating initrd: /boot/initrd-4.1.27-24-default
        Executing: /usr/bin/dracut --logfile /var/log/YaST2/mkinitrd.log --force /boot/initrd-4.1.27-24-default 4.1.27-24-default
        dracut module 'multipath' will not be installed, because command 'multipath' could not be found!
        dracut module 'multipath' will not be installed, because command 'multipath' could not be found!
        *** Including module: bash ***
        *** Including module: warpclock ***
        *** Including module: i18n ***
        *** Including module: ifcfg ***
        *** Including module: drm ***
        *** Including module: plymouth ***
        *** Including module: btrfs ***
        *** Including module: kernel-modules ***
        Omitting driver i2o_scsi
        *** Including module: resume ***
        *** Including module: rootfs-block ***
        *** Including module: terminfo ***
        *** Including module: udev-rules ***
        Skipping udev rule: 91-permissions.rules
        Skipping udev rule: 80-drivers-modprobe.rules
        *** Including module: haveged ***
        *** Including module: systemd ***
        *** Including module: usrmount ***
        *** Including module: base ***
        *** Including module: fs-lib ***
        *** Including module: shutdown ***
        *** Including module: suse ***
        *** Including modules done ***
        *** Installing kernel module dependencies and firmware ***
        *** Installing kernel module dependencies and firmware done ***
        *** Resolving executable dependencies ***
        *** Resolving executable dependencies done***
        *** Hardlinking files ***
        *** Hardlinking files done ***
        *** Stripping files ***
        *** Stripping files done ***
        *** Generating early-microcode cpio image ***
        *** Constructing GenuineIntel.bin ****
        *** Store current command line parameters ***
        Stored kernel commandline:
         resume=UUID=399efd28-3a1b-45c8-bef8-d4ae968221de
        root=UUID=ef3f88cc-0069-479b-b1b9-3ac4ca680d47 rootflags=rw,relatime,space_cache,subvolid=1430,subvol=/@/.snapshots/987/snapshot rootfstype=btrfs
        *** Creating image file ***
        *** Creating image file done ***
        Some kernel modules could not be included
        This is not necessarily an error:
        swap
        Update bootloader...
    Not Help.

  3. #3
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,804

    Default Re: Nvidia Update no module loaded

    Hi, try to uninstall virtualbox-guest-kmp-default, then uninstall the nvidia driver and reinstall it.
    Maybe you have the same problem described here: https://forums.opensuse.org/showthre...ks-to-wolfi323
    Leap 15.1 Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.2Beta

  4. #4

    Default Re: Nvidia Update no module loaded

    Thanks now works.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •