I have both KDE and GNOME installed on LEAP 42.1. Whenever I boot my computer, it always defaults to KDE - I have tried logging out of a KDE session and back into a GNOME one but that doesn't work. I have changed the DEFAULT_WM to gnome in the sysconfig in YaST, this did change the value in the text file but it still defaults to KDE on boot. I have automatic login enabled so not sure if that is interfering here...