Results 1 to 9 of 9

Thread: kmail5 fails to start

  1. #1

    Default kmail5 fails to start

    I've just upgraded form 13.2 to Tumbleweed (a new installation rather than an update). After the installation, I started kmail5 from the start menu, and was able to configure it, import archived email, and send and receive mail. However, after I quit the application, it wouldn't restart, nor would it start after a reboot. I uninstalled, rebooted, and reinstalled it, and it started OK, but on quitting, once again it failed to start. Anyone have a solution for this?

    Ben

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,462
    Blog Entries
    2

    Default Re: kmail5 fails to start

    Try invoking from a console instead of the menu item. To determine the exact command for invoking from the console inspect the menu item properties.

    When you invoke from a console, hopefully any failure will display a descriptive error.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,039
    Blog Entries
    14

    Default Re: kmail5 fails to start

    I suspect it's already running....... check the triangle in the systemtray area.
    If it indeed is, I'd still consider it a bug. Trying to start it again then should open the kmail window.
    Don't see this here though. No matter whether I actually close kmail5 from the menu, or just send it to the systemtray
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Default Re: kmail5 fails to start

    Quote Originally Posted by tsu2 View Post
    Try invoking from a console instead of the menu item. To determine the exact command for invoking from the console inspect the menu item properties.

    When you invoke from a console, hopefully any failure will display a descriptive error.

    TSU
    I did this, using the command kmail -qwindowtitle %c %u (which I got by right-clicking on the icon, as suggested). I was just returned immediately to the command prompt, with no shell messages (and no kmail, of course). I've also tried stopping Akonadi and deleting its configuration files (following the Kmail handbook's instructions for a "Clean start after a failed migration"), removing kmail, restarting, installing kmail again and reconfiguring it, with the same result--I was able to open kmail from the Start menu and configure it, but once I quit, it wouldn't restart.

  5. #5

    Default Re: kmail5 fails to start

    Quote Originally Posted by benbrewster View Post
    I did this, using the command kmail -qwindowtitle %c %u (which I got by right-clicking on the icon, as suggested).
    It's not very useful to add "-qwindowtitle %c %u" when running it manually. That's stuff that gets replaced automatically when run via the application menu...

    I was able to open kmail from the Start menu and configure it, but once I quit, it wouldn't restart.
    Try to kill it.
    It won't start if it's already running, and it may fail to quit for some reason.

    I am aware of a bug report where it won't quit if "Empty trash on exit" is enabled.
    Also, it may continue to run in the system tray (this can be configured), check that there's no kmail icon there, maybe hidden.

  6. #6

    Default Re: kmail5 fails to start

    Quote Originally Posted by wolfi323 View Post
    It's not very useful to add "-qwindowtitle %c %u" when running it manually. That's stuff that gets replaced automatically when run via the application menu...


    Try to kill it.
    It won't start if it's already running, and it may fail to quit for some reason.

    I am aware of a bug report where it won't quit if "Empty trash on exit" is enabled.
    Also, it may continue to run in the system tray (this can be configured), check that there's no kmail icon there, maybe hidden.
    Hurrah! "Empty trash on exit" was checked. I deleted and reinstalled kmail, started it, went to Settings and unchecked it. And after I had quit, I was able to reopen it. Thanks very much for your help.

  7. #7

    Default Re: kmail5 fails to start

    Quote Originally Posted by benbrewster View Post
    Hurrah! "Empty trash on exit" was checked. I deleted and reinstalled kmail, started it, went to Settings and unchecked it. And after I had quit, I was able to reopen it. Thanks very much for your help.
    You're welcome.
    I'm glad it works now again.

    But it shouldn't have been necessary to uninstall and reinstall kmail, that's the "Windows way of solving problems", and normally doesn't help much in Linux.
    As you already noticed earlier...
    Last edited by wolfi323; 31-Jul-2016 at 12:25.

  8. #8

    Default Re: kmail5 fails to start

    Quote Originally Posted by wolfi323 View Post
    You're welcome.
    I'm glad it works now again.

    But it shouldn't have been necessary to uninstall and reinstall kmail, that's the "Windows way of solving problems", and normally doesn't help much in Linux.
    As you already noticed earlier...
    No doubt it isn't kosher. But the only kmail I could get to start was a freshly installed one, so to get to the Setting menu I had to reinstall to get a running kmail. No doubt there are ways to reconfigure kmail without starting it, but I don't know what they are. I do know how to reinstall an application, so I did.

  9. #9

    Default Re: kmail5 fails to start

    Quote Originally Posted by benbrewster View Post
    No doubt it isn't kosher.
    The point is that a reinstallation won't change your user settings.
    If the problem is caused by the settings, a reinstallation won't help at all.

    What probably did help in your case was that kmail wasn't running any more, therefore you were able to start it again. (as mentioned, kmail refuses to start if it is already running)

    But just killing it or logging out and in again (or reboot) would have achieved the same. You apparently did that anyway and that "fixed" the problem, not the reinstallation.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •