Results 1 to 4 of 4

Thread: Problem with installing node.js using zypper

  1. #1

    Default Problem with installing node.js using zypper

    I am trying to install node.js using zypper. I have Opensuse 12.1.

    Zypper seems to have problem with installing any application in my system. I have set a valid proxy server value as follows:

    $HTTP_PROXY = http://singuvi:<pwd>@<proxy name>:8080

    But Zypper fails to install any application. For example adding repo for node using the following command returns the following error message:

    sudo zypper addrepo

    Timeout exceeded when accessing ''.

    Is there some other setting that i need to make for the proxy for the zypper to work.

    I would appreciate if there is any other way to install node.js in the system. I have tried installing from binary package nodejs-6.3.0-113.1.x86_64.rpm but it only install node but not the npm.

    Please help!

  2. #2
    Join Date
    Jun 2008

    Default Re: Problem with installing node.js using zypper

    I am not quite understanding what you are trying to do.

    You say you have openSUSE 12.1, but the repo is for SLE 12 SP1.

    On openSUSE 12.1: That is way out of support and while it may be possible to find the OSS and non-OSS repos for it, it might be more difficult to find other repos that where available at that time.

    On SLE 12 SP1: You re at the wrong forums. These are the openSUSE forums, not the SLES/SLED forums. Those are at (same username/password as here).

    So please find out what you have on that system e.g. using
    cat /etc/SuSE-release
    and then ask at the correct forums, while not mixing repos from a different version.
    Henk van Velden

  3. #3

    Default Re: Problem with installing node.js using zypper

    Thank you for your response. I have SUSE linux enterprise server. Will redirect the question in Suse forums. Sorry for the trouble

  4. #4
    Join Date
    Jun 2008
    San Diego, Ca, USA
    Blog Entries

    Default Re: Problem with installing node.js using zypper

    More than likely the SLES repo for nodejs will be similar to the URI for the opensSUSE repos.

    See my instructional for openSUSE

    Beginner Wiki Quickstart -
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts