Results 1 to 5 of 5

Thread: perl install Archive::Zip like going down a rabbit hole

  1. #1

    Default perl install Archive::Zip like going down a rabbit hole

    I am configuring a new install of LEAP 42.1 to act as a backup server using the backuppc software. Since I couldn't find backuppc in the repos, I downloaded the source code, and am installing the perl modules to make it work.

    I used "YAST 2" to make sure that I am up to date. After verifying that perl is installed, I setup my system to use "cpan" to download, compile and test perl modules. I was able to install "Compress::lib" and "File::RsyncP" without problem, so I have some degree of certainty that things are running OK.

    Then I tried to install "Archive::zip" and it seems to be a cascading rabbit hole of errors. "Archive::zip" requires "Test::MockModule", "Test::MockModule" requires "SUPER", SUPER requires "Algorithm:iff" and so on for "Spiffy", Text:iff and Algorithm:iff. At this point, I stopped to ask for advice. Am I missing something in my basic perl install, or should I keep on going "down this rabbit hole"?

    I tried to include the output from trying to install Archiveip (it is too long for the forum. )

    Many thanks,
    Mark

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,244
    Blog Entries
    15

    Default Re: perl install Archive::Zip like going down a rabbit hole

    Hi
    Why not just zypper in perl-Archive-Zip...? In openSUSE we add perl-some-perl-module, so a zypper se should help.

    Else if can't find one, it may be easier to add the perl development repo and install as there are more here (plus later versions) than in the distribution...
    Code:
    zypper ar -f http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_Leap_42.1/ devel:languages:perl
    zypper ref
    Else you need to continue down the rabbit hole with cpan....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: perl install Archive::Zip like going down a rabbit hole

    Sorry folks:
    The forum software interprets "::" followed by a "Z" as an emoticon and "::" followed by "D" as a different emoticon. I didn't fix the errors in time, so I'm posting this to help explain the strange looking text.

    Thanks....

  4. #4

    Default Re: perl install Archive::Zip like going down a rabbit hole

    Thank you. That solved the problem. <whew!> I've got to spend some time learning zypper.

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Why not just zypper in perl-Archive-Zip...? In openSUSE we add perl-some-perl-module, so a zypper se should help.

    Else if can't find one, it may be easier to add the perl development repo and install as there are more here (plus later versions) than in the distribution...
    Code:
    zypper ar -f http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_Leap_42.1/ devel:languages:perl
    zypper ref
    Else you need to continue down the rabbit hole with cpan....

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,399

    Default Re: perl install Archive::Zip like going down a rabbit hole

    Quote Originally Posted by MarkNei View Post
    Sorry folks:
    The forum software interprets "::" followed by a "Z" as an emoticon and "::" followed by "D" as a different emoticon. I didn't fix the errors in time, so I'm posting this to help explain the strange looking text.

    Thanks....
    Posting computer text between CODE tags will help. It is the # button in the tool bar of the post editor.

    Code:
    Text::Diff and Algorithm::Diff
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •