Results 1 to 3 of 3

Thread: Kmail 5.2.2 adds file:// url instead of attaching file.

  1. #1

    Default Kmail 5.2.2 adds file:// url instead of attaching file.

    I'm using kmail 5.2.2 from the KDE Applications repository on QT 5.6.1 and frameworks 5.2.4.0. As of the latest update, when I drag a file from Dolphin to an email I am composing, it writes a file:// url link rather than adding the file as an attachment. Until the latest update, it would always add the file as an attachment rather than write the link. Is there any way (a new setting or something) to restore it to the old behavior? When I drag a file to an e-mail I want an attachment not a reference to a file on my hard drive.

    Thanks for your help.

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,606

    Default Re: Kmail 5.2.2 adds file:// url instead of attaching file.

    Ah yes, the "KDE Applications" repository and Leap 42.1: I must admit that yesterday I had some stomach pains due to that Leap 42.1 repository.
    On my Leap 42.1 system, with the following Kontact components, I can <Ctrl-> drag files from Dolphin to a new e-Mail text content Kmail window:
    • Kontact: Version: 15.12.3-18.5; Repository: openSUSE-Leap-42.1-Update.
    • plasma-framework: Version: 5.21.0-15.1; Repository: openSUSE-Leap-42.1-Update.
    • kmail5: Version: 15.12.3-18.5; Repository: openSUSE-Leap-42.1-Update.
    • Kontact and KMail themselves, claim that they're at Version 5.1.3.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,053
    Blog Entries
    14

    Default Re: Kmail 5.2.2 adds file:// url instead of attaching file.

    Quote Originally Posted by bearymore View Post
    I'm using kmail 5.2.2 from the KDE Applications repository on QT 5.6.1 and frameworks 5.2.4.0. As of the latest update, when I drag a file from Dolphin to an email I am composing, it writes a file:// url link rather than adding the file as an attachment. Until the latest update, it would always add the file as an attachment rather than write the link. Is there any way (a new setting or something) to restore it to the old behavior? When I drag a file to an e-mail I want an attachment not a reference to a file on my hard drive.

    Thanks for your help.
    Please report a bug.
    If it's not your intention to test packages, but rather have a production environment, I suggest you don't use these repos.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •