Results 1 to 6 of 6

Thread: kicad package is not working (GCC Version?)

Hybrid View

  1. #1

    Default kicad package is not working (GCC Version?)

    I tried to post this message earlier in the week but it never got through. Not sure what mistake I make. I've been having a problem getting kicad to work from the repos. I'm on Tumbleweed. Error message: Fatal Error: Mismatch between the program and library build versions detected. The library used 3.0 (wchar_t,compiler with C++ ABI 1010,STL containers,compatible with 2.8), and your program used 3.0 (wchar_t,compiler with C++ ABI 1009,STL containers,compatible with 2.8). Aborted (core dumped)

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,703

    Default Re: kicad package is not working (GCC Version?)

    ln TW the c complier has been updated to newer version so some lib apparently has not been updated. The joy of living on the cutting edge

  3. #3

    Default Re: kicad package is not working (GCC Version?)

    Oh the joy :-( I should just install from source for the moment I guess.

  4. #4
    Join Date
    Jan 2010
    Location
    Russia
    Posts
    100

    Default Re: kicad package is not working (GCC Version?)

    Fixed version will be in Tumbleweed soon, temporary you can use electronics repository: https://software.opensuse.org/downlo...&package=kicad

  5. #5

    Default Re: kicad package is not working (GCC Version?)

    Deadly thanks for that, been missing it.

  6. #6
    Join Date
    Jan 2010
    Location
    Russia
    Posts
    100

    Default Re: kicad package is not working (GCC Version?)

    Finally fixed KiCad packages are published.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •