Results 1 to 4 of 4

Thread: Repos

  1. #1

    Default Repos

    Hi everybody:

    My system (picking from Kinfocenter) consists of KDE Plasma 5.7.1, KDE Framework 5.24.0, QT 5.6.1, Kernel 4.1.27-24-default, OS 64-bit.

    For the time being, I have the following repositories enabled: Framework5, Qt5, Main Update Repo, openSUSE-Leap-42.1-Update, and some more, which are in no connection with the previously mentioned (at least i think so). My question is, in order to get the latest Application (16.04.3), are the above mentioned repos enough, or should I enable additional such as Updated Applications only /Extra and Application). Will the repos I already enabled coexist with the new repos, and more important, are the two new repos needed at all. I did enable the Etra and Applications repos just to see what will happened, but got plenty of error messages after zypper downloaded files and tried to install them. The error msgs refer to something like, two packages try to install with different content, or something similar. I decided not to proceed further with the installation and to disable said two repos.

    I appreciate all comments and suggestions.

    Regards,
    Bojan

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,706

    Default Re: Repos

    Show what you really have with

    zypper lr -d

    please use code blocks to keep the text from reformatting (# in the tool bar)

  3. #3

    Default Re: Repos

    Quote Originally Posted by krpan View Post
    My question is, in order to get the latest Application (16.04.3), are the above mentioned repos enough, or should I enable additional such as Updated Applications only /Extra and Application).
    No, those will not be enough.

    You need to add KDE:Applications, to get the latest stable KDE Application releases (16.04.3 currently).

    KDE:Extra contains the latest versions for KDE programs that are not part of the offical KDE Application releases, like Calligra, Krita, and Digikam.
    If you want the latest versions of those "3rd party" applications, you need that repo as well, and it also contains additional KDE applications that are not part of the distribution.

    Will the repos I already enabled coexist with the new repos, and more important, are the two new repos needed at all.
    As gogalthorp already mentioned, you can only get an answer to that question if you tell us what your actual repos are.

    I did enable the Etra and Applications repos just to see what will happened, but got plenty of error messages after zypper downloaded files and tried to install them. The error msgs refer to something like, two packages try to install with different content, or something similar. I decided not to proceed further with the installation and to disable said two repos.
    What exact zypper command did you run, and what error messages do you get exactly?
    Again, without knowing that (and what repos you actually use exactly) one cannot guess what the problem may be.

    The KDE:Qt5, KDE:Frameworks5, KDE:Applications, and KDE:Extra repos should be compatible to each other, and of course also to the main repos (including the update repo).

  4. #4

    Default Re: Repos

    Thank you guys for all tips. I added Extra and Applications repos once again, ran zypper up and zypper dup, and everything went smoothly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •