Results 1 to 9 of 9

Thread: Dependency failed update

  1. #1
    Join Date
    Dec 2015
    Location
    Italy
    Posts
    43

    Default Dependency failed update

    Hello all,

    a few days ago I did a kernel update in order to solve hardware compatibility issue.

    Now I had a failure in KDE Plasma 5 update notification. The update is: kernel-source (4.1.26-21.1).
    The error message says: "Dependency resolution failed...".

    I have to deselect the update each time there are new updates in general, to successfully end the upgrade process.
    Can you give any hint to solve this issue?

    If it can be of some help, here is my uname cmd result:

    Code:
    Linux linux-tqxv.suse 4.6.3-1.gd4bcf2a-default #1 SMP PREEMPT Sun Jun 26 07:34:33 UTC 2016 (d4bcf2a) x86_64 x86_64 x86_64 GNU/Linux
    
    Then, the error message says: "check log for more detail".
    Can you please point out the right place where to find logs about updates?

    Thanks a lot.

    Matteo

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,370
    Blog Entries
    3

    Default Re: Dependency failed update

    You are using the KDE update applet to update. That's fine, except that it does not always give useful information.

    I suggest that you try:
    Yast --> Online Update

    for this particular update. You will get a more detailed message about what the confict involves. Then post that message, and somebody might be able to provide useful advice on what to do.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3
    Join Date
    Dec 2015
    Location
    Italy
    Posts
    43

    Default Re: Dependency failed update

    Hello nrickert,

    ok I'll follow the steps you suggest.

    Thank you

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,662
    Blog Entries
    14

    Default Re: Dependency failed update

    Uninstalling anything re. the default Leap kernel should fix this.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Dec 2015
    Location
    Italy
    Posts
    43

    Default Re: Dependency failed update

    hello,

    sorry, I can't understand: "Uninstalling anything re."

    can you further explain??

    Thanks

  6. #6
    Join Date
    Dec 2015
    Location
    Italy
    Posts
    43

    Default Re: Dependency failed update

    hello,

    sorry, I can't understand: "Uninstalling anything re."

    can you further explain??

    Thanks

  7. #7
    Join Date
    Dec 2015
    Location
    Italy
    Posts
    43

    Default Re: Dependency failed update

    Hello,

    is there anybody who faced the same issue and solved it?

    Can anybody explain the update conflict?

    Thanks

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,370
    Blog Entries
    3

    Default Re: Dependency failed update

    Quote Originally Posted by interpeo View Post
    Hello,

    is there anybody who faced the same issue and solved it?

    Can anybody explain the update conflict?

    Thanks
    Check this mailing list thread:
    "zypper patch" wants to change my system from X86_64 to i586?????

    It seems that there was a bad patch that was later pulled.
    openSUSE Leap 15.1; KDE Plasma 5;

  9. #9
    Join Date
    Dec 2015
    Location
    Italy
    Posts
    43

    Default Re: Dependency failed update

    ok,thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •