Results 1 to 5 of 5

Thread: Odd "could not launch" errors & new escalation requirements on new install less than 2 weeks old

  1. #1

    Question Odd "could not launch" errors & new escalation requirements on new install less than 2 weeks old

    Hello thanks for reading
    Fresh TW (network) install, fully updated as of this AM.

    some examples:

    When running package install :
    KDEInit could not launch 'gpk-install-local-file':

    Could not open library 'libkdeinit5_gpk-install-local-file'.

    Cannot load library libkdeinit5_gpk-install-local-file: (libkdeinit5_gpk-install-local-file: cannot open shared object file: No such file or directory)

    a search of the repositories do not return a result for libkdeinit5.anything

    when running quickusbformatL
    Failed: /bin/bash: mkdosfs: command not found
    or similar replace mkdosfs with ntfs etc..

    I quick search of my drive shows mkdosfs, ntfs etc.. installed,

    Code:
    cnf mkdosfs
                           
    Program 'mkdosfs' is present in package 'dosfstools', which is installed on your system.
    
    Absolute path to 'mkdosfs' is '/usr/sbin/mkdosfs',
    Kshutdown now asks for root PW, but it never did before, and its not in the sbin directory, so it likely should not need root pw?

    Code:
    Program 'kshutdown' is present in package 'kshutdown', which is installed on your system.
    
    Absolute path to 'kshutdown' is '/usr/bin/kshutdown'.



    any help is appreciated
    thanks

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,760

    Default Re: Odd "could not launch" errors & new escalation requirements on new install less than 2 weeks ol

    Be sure yo don't have mixed repos

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,366
    Blog Entries
    2

    Default Re: Odd "could not launch" errors & new escalation requirements on new install less than 2 weeks ol

    Maybe an incomplete update/upgrade?
    You didn't say how you updated, whether you relied on an app or manually invoked.

    Update from the command line again to see if you have detected old packages...
    Code:
    zypper dup
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  4. #4

    Default Re: Odd "could not launch" errors & new escalation requirements on new install less than 2 weeks ol

    Quote Originally Posted by tsu2 View Post
    Maybe an incomplete update/upgrade?
    You didn't say how you updated, whether you relied on an app or manually invoked.

    I used the gui updater used to be called apper, but not sure anymore


    Update from the command line again to see if you have detected old packages...
    Code:
    zypper dup
    TSU

    zypper dup

    Code:
    88 packages to upgrade, 35 new, 10 to remove, 87  to change vendor.
    Overall download size: 144.5 MiB. Already cached: 0 B. After the operation, additional
    70.1 MiB will be used.
    looks like I have an issue.


    Code:
    linux-ags8:/home/Kilbert # zypper lr
    #  | Alias                            | Name                                                                 | Enabled | GPG Check | Refresh                                                                                                                                                     
    ---+----------------------------------+----------------------------------------------------------------------+---------+-----------+--------                                                                                                                                                     
     1 | KDE_Extra                        | Additional packages maintained by the KDE team (openSUSE_Tumbleweed) | Yes     | (r ) Yes  | No                                                                                                                                                          
     2 | PlexRepo                         | PlexRepo                                                             | No      | ----      | No                                                                                                                                                          
     3 | http-ftp.gwdg.de-3a136d5e        | Packman Repository                                                   | Yes     | (r ) Yes  | Yes                                                                                                                                                         
     4 | http-opensuse-guide.org-dbe5751c | libdvdcss repository                                                 | Yes     | (r ) Yes  | Yes                                                                                                                                                         
     5 | openSUSE-20160607-0              | openSUSE-20160607-0                                                  | Yes     | (r ) Yes  | Yes                                                                                                                                                         
     6 | packman                          | packman                                                              | No      | ----      | No                                                                                                                                                          
     7 | repo-debug                       | openSUSE-Tumbleweed-Debug                                            | No      | ----      | Yes                                                                                                                                                         
     8 | repo-non-oss                     | openSUSE-Tumbleweed-Non-Oss                                          | Yes     | (r ) Yes  | Yes                                                                                                                                                         
     9 | repo-source                      | openSUSE-Tumbleweed-Source                                           | No      | ----      | Yes                                                                                                                                                         
    10 | repo-update                      | openSUSE-Tumbleweed-Update                                           | Yes     | (r ) Yes  | Yes

    At this point, I am assuming I need to allow zypper dup do its thing. somehow I have mixed vendors?
    thanks
    john kilbert

  5. #5

    Default Re: Odd "could not launch" errors & new escalation requirements on new install less than 2 weeks ol

    perfomred the zipper dup seemed logical:
    now :

    Code:
    linux-ags8:/home/Kilbert # zypper dup
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    
    Nothing to do.
    I still get the same errors, and the same odd kshutdown needing root.

    thansk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •