Results 1 to 8 of 8

Thread: Line wrapping not working with HTML formatted mails in Evolution

  1. #1

    Default Line wrapping not working with HTML formatted mails in Evolution

    For a long while now, I am experiencing the phenomenon that line wrapping is not working properly with HTML-formatted mails in Evolution. Shouldn't I expect the text to 'fit' into the preview window however wide the window is?
    But this is not happening. Even when I open an HTML-formatted mail in a separate window, I am having to stretch the window in order to see the complete lines. On the other hand, when the window width is larger than some (unknown) size, the line wrapping begins to take effect.

    On the other hand, plain text mails do line wrapping correctly depending on the width of the window, no matter how wide.

    Is the HTML behaviour normal?

    I am using
    OpenSUSE Leap 42.1 (64-bit)
    Gnome 3.16.2
    Evolution 3.16.5-4.8

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,171

    Default Re: Line wrapping not working with HTML formatted mails in Evolution

    What when you open it in e.g. Firefox?
    Henk van Velden

  3. #3

    Default Re: Line wrapping not working with HTML formatted mails in Evolution

    Quote Originally Posted by hcvv View Post
    What when you open it in e.g. Firefox?
    Do you mean: save a mail as mbox file and then open the mbox file in Firefox? In that case, firerfox offers the options to open the file in evolution or save it (i.e. the 'download' scenario). With the evolution option the 'import' process is started (i,e, 'import' window opens)

  4. #4
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,451

    Default Re: Line wrapping not working with HTML formatted mails in Evolution

    Are you talking about emails you have formatted or ones that other people have formatted? I regularly use Evolution to check bulk emails I am about to send out and I have never had a problem using post 2011 HTML. However, I know a lot of people (and email editors) who use obsolete HTML tags in emails and I wonder if this is the real problem.

  5. #5

    Default Re: Line wrapping not working with HTML formatted mails in Evolution

    Quote Originally Posted by john_hudson View Post
    Are you talking about emails you have formatted or ones that other people have formatted? I regularly use Evolution to check bulk emails I am about to send out and I have never had a problem using post 2011 HTML. However, I know a lot of people (and email editors) who use obsolete HTML tags in emails and I wonder if this is the real problem.

    I am certainly talking about most of my incoming mails, i.e. formatted by other people. My own Evolution HTML emails seem not to suffer with this problem

  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,171

    Default Re: Line wrapping not working with HTML formatted mails in Evolution

    Sorry, I am not using Evolution, but Kmail.

    It shows a list of the MIME parts of an e-mail below the text. When I there right click on an HTML part, I am given the possibility Open with ... and there I can of course use FF or another mail browser. Is such a thing not possible in Evolution?

    This is of course nice to see what other HTML renderers then Evolurion make out of it. Could help in deciding if it is Evolution, or badly written HTML.

    As john_hudson writes, bad HTML is produced very often (not restricted to "pre 2011"). And not all browsers are able to make the best out of it.
    Henk van Velden

  7. #7

    Default Re: Line wrapping not working with HTML formatted mails in Evolution

    Quote Originally Posted by hcvv View Post
    Sorry, I am not using Evolution, but Kmail.

    It shows a list of the MIME parts of an e-mail below the text. When I there right click on an HTML part, I am given the possibility Open with ... and there I can of course use FF or another mail browser. Is such a thing not possible in Evolution?

    This is of course nice to see what other HTML renderers then Evolurion make out of it. Could help in deciding if it is Evolution, or badly written HTML.

    As john_hudson writes, bad HTML is produced very often (not restricted to "pre 2011"). And not all browsers are able to make the best out of it.
    Well, now that you say it, some of my (incoming) HTML mails behave well. Some do not, for example, mails from my NAS server supplier (surprising, isn't it?). So maybe the HTML history is indeed the source of the problem.

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,171

    Default Re: Line wrapping not working with HTML formatted mails in Evolution

    Check some random web pages with the W3C Markup Validation Service at https://validator.w3.org/ and shiver.

    Even the home page of these forums returns 20 Errors, 11 warnings.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •