Results 1 to 10 of 10

Thread: Any text selected is automaticly copied to clipboard

  1. #1

    Default Any text selected is automaticly copied to clipboard

    For the last couple months, I've battled this annoying feature that has somehow gotten itself turned on. It wasn't like this when OpenSuse13.2 was instealled, or the year following that. Only in the recent several months. How do I turn this off? I've tried changing, one by one, all the options under Klipper->Configure, but the behaviour will not stop. What this means is that its now impossible to double click a word and paste another word in its place.

  2. #2

    Default Re: Any text selected is automaticly copied to clipboard

    Quote Originally Posted by gariann View Post
    For the last couple months, I've battled this annoying feature that has somehow gotten itself turned on. It wasn't like this when OpenSuse13.2 was instealled, or the year following that. Only in the recent several months. How do I turn this off? I've tried changing, one by one, all the options under Klipper->Configure, but the behaviour will not stop. What this means is that its now impossible to double click a word and paste another word in its place.
    It also means its impossible to copy something, then select a block of text and do a replace-in-selection, since selecting the second block of text replaces the clipboard contents.

    This is in KDE. Is this maybe a global hotkey/feature that I somehow accidentally toggled on? It makes my life as a programmer miserable.

  3. #3
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,254
    Blog Entries
    2

    Default Re: Any text selected is automaticly copied to clipboard

    Out of curiousity,
    Are you using a touchpad, touchscreen or mouse?
    And, how are you selecting your text, swiping or using a keystroke combination (ie CTL-click, CTL-****, CTL-a, a menu item, etc)
    Also, have you updated your system anytime? If you haven't done so, run the following in a root console
    Code:
    zypper update
    If you still have issues after running a system update, you might closely inspect your repos, the following displays your repos and the specific path which will also specify the distro version in most cases
    Code:
    zypper lr -d
    And, assume that this is on a physical machine and not a virtual machine.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,114

    Default Re: Any text selected is automaticly copied to clipboard

    I am afraid this dos not help much, but this behaviour is normal to my experience with KDE since at least openSUSE10.1.
    I have now openSUSE 13.1 running and when I in the Klipper (after right-click on the icon) choose Configure Klipper, I get a window that has a section (all translated back from Dutch, so your text may differ) called Selection and clipboard. It gives me the choice between
    • Ignore selection
    • Only selected text
    • Synchronise clipboard contents and the selection

    The second one is on. I never changed anything here. I have no idea what the third option means, but the first one looks to me (about) what you want. Thus if you have the same I have...., but KDE on Leap is different and lost some functionality.
    Henk van Velden

  5. #5

    Default Re: Any text selected is automaticly copied to clipboard

    Quote Originally Posted by tsu2 View Post
    Out of curiousity,
    Are you using a touchpad, touchscreen or mouse?
    And, how are you selecting your text, swiping or using a keystroke combination (ie CTL-click, CTL-****, CTL-a, a menu item, etc)
    Also, have you updated your system anytime? If you haven't done so, run the following in a root console
    Code:
    zypper update
    If you still have issues after running a system update, you might closely inspect your repos, the following displays your repos and the specific path which will also specify the distro version in most cases
    Code:
    zypper lr -d
    And, assume that this is on a physical machine and not a virtual machine.

    TSU
    I use a mouse and a keyboard, on a physical desktop machine (not a VM).

    Typically I select text using either shift+arrow keys, dragging the mouse over words, or double-clicking or triple-clicking to quickly select whole words or whole lines. All of these methods update the clipboard contents. Instead, I'd like to go back to where the clipboard is only updated on control+C, control+X, or menu options (Edit->Copy).

    My system is fully up to date as of yesterday morning. But the behavior started months ago.

  6. #6

    Default Re: Any text selected is automaticly copied to clipboard

    Quote Originally Posted by hcvv View Post
    I am afraid this dos not help much, but this behaviour is normal to my experience with KDE since at least openSUSE10.1.
    I have now openSUSE 13.1 running and when I in the Klipper (after right-click on the icon) choose Configure Klipper, I get a window that has a section (all translated back from Dutch, so your text may differ) called Selection and clipboard. It gives me the choice between
    • Ignore selection
    • Only selected text
    • Synchronise clipboard contents and the selection

    The second one is on. I never changed anything here. I have no idea what the third option means, but the first one looks to me (about) what you want. Thus if you have the same I have...., but KDE on Leap is different and lost some functionality.
    Sorry If my original posts weren't clear enough.

    As I indicated, this behavior is not normal to me. The default install of openSuse 13.2 did not behave this way. Actually, I dont recall this behavior in openSuse 10.3, 11.2, or 12.1 either, and its frustrating enough that I'd probably remember.

    Also, as my original post said, I've tried changing all the Klipper configuration options (even the ones you list), both individually and together. None of them have stopped the behavior. The only thing I have not done is to change the options and log out and back in between each change to see if that makes any difference.

  7. #7

    Default Re: Any text selected is automaticly copied to clipboard

    Quote Originally Posted by gariann View Post
    Sorry If my original posts weren't clear enough.

    As I indicated, this behavior is not normal to me. The default install of openSuse 13.2 did not behave this way. Actually, I dont recall this behavior in openSuse 10.3, 11.2, or 12.1 either, and its frustrating enough that I'd probably remember.

    Also, as my original post said, I've tried changing all the Klipper configuration options (even the ones you list), both individually and together. None of them have stopped the behavior. The only thing I have not done is to change the options and log out and back in between each change to see if that makes any difference.
    To be thorough, I reverified that the Klipper's "Synchronize selection" was disabled, yet the behavior continued. I re-enabled it and disabled it again, and the behavior continued. So I logged out and logged back in, and now the behavior is gone. After the fresh login, I tried multiple re-enabling and disabling the "Synchronize selection", and in a fresh login with out much else going on, I can't reproduce the problem again.

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,742

    Default Re: Any text selected is automaticly copied to clipboard

    If you updated from 13.2 sometimes old configs are not fully updated. You can test buy creating a test user and see if the problem is there also. But apparently now all is refreshed for you now.

  9. #9

    Default Re: Any text selected is automaticly copied to clipboard

    Quote Originally Posted by gariann View Post
    To be thorough, I reverified that the Klipper's "Synchronize selection" was disabled, yet the behavior continued. I re-enabled it and disabled it again, and the behavior continued. So I logged out and logged back in, and now the behavior is gone. After the fresh login, I tried multiple re-enabling and disabling the "Synchronize selection", and in a fresh login with out much else going on, I can't reproduce the problem again.
    After about 7 hours of use, now that I'm deep in work with about 20 windows open, I was in the middle of typing an email in Thunderbird when now I notice that the behavior is back. Klipper's config options still have clipboard syncing disabled, and I still have "ignore selection" enabled, but any piece of text I highlight is automatically placed on the clipboard, again. And its not just Thunderbird. In any program, if I select -any- text, its automatically placed in the clipboard. And I doubt that Thunderbirds somehow triggered the issue, because its been running all day. Its one of the first programs I started after logging in this morning, had this issue didn't reoccur until hours later.

  10. #10
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,254
    Blog Entries
    2

    Default Re: Any text selected is automaticly copied to clipboard

    If you have enough disk space,
    Maybe it's time to install an alternate Desktop and see if your problems re-occur in that Desktop...

    Recommend trying either LXDE (which should have a somewhat similar look and feel to KDE).
    You should be able to continue to run your same already installed apps in your new Desktop.

    If the problems persist, then maybe try a different display manager and maybe a different window manager (easily switchable in YAST > /etc/sysconfig editor).

    Or, you can experiment a little with a different display manager before installing a new Desktop...

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •