Results 1 to 7 of 7

Thread: Libreoffice slow

  1. #1

    Default Libreoffice slow

    System is LEAP 42.1 with updates.
    All, is your LIbreoffice working as per normal? or lets say, at a normal speed. I found Libreoffice Draw to be dog slow at the moment. I am currently using 5.0.4. having down graded because of this problem. Unfortunately this made no difference. I also attempted to install 5.2 beta from FACTORY but ran into dependency problems. When I open the application it goes through a slow process of loading the menus and setting up its screen or window. System is an i7 processor and 16gig of ram. Any ideas what may be happening? Libreoffice Writer might be working a bit faster, but it to suffers from a similar problem.

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,555

    Default Re: Libreoffice slow

    In the LibreOffice settings under "LibreOffice/Advanced" check that you've selected a Java Runtime Environment (JRE).
    • Yes, if you do not explicitly do this, LibreOffice is not as fast as it should be . . .

  3. #3

    Default Re: Libreoffice slow

    Quote Originally Posted by dcurtisfra View Post
    In the LibreOffice settings under "LibreOffice/Advanced" check that you've selected a Java Runtime Environment (JRE).
    • Yes, if you do not explicitly do this, LibreOffice is not as fast as it should be . . .
    Tried this but it did not have the effect I was hoping for. The "Advanced" tab showed - - use java runtime environment. Beneath this were two versions both 1.7 and 1.8 by Oracle Corporation. Tried both - - required a restart - - but did not speed things up much.
    Still going on this one.

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,555

    Default Re: Libreoffice slow

    LibreOffice is currently sensitive to the memory usage configuration values:
    • In the LibreOffice settings under "LibreOffice/Memory" increase the default values to large values.


    On my current systems with 8 GB memory, I use the following values with the LibreOffice versions available from the 13.2 and Leap 42.1 update repositories:


    • Number of "undo" steps: 100 (possibly the default value).
    • Memory used for graphics:
      • LibreOffice: 512 MB (not the default value);
      • Memory per object: 4.0 MB (possibly not the default but not really sure);
      • Remove from memory after: 10 minutes (possibly the default value).

    • Memory for inserted objects: number of objects: 128 (not the default value).


    Maybe I should have mentioned the following rules in my 1st post:


    • LibreOffice on Linux systems demands that the JRE be explicitly set.
    • The default memory usage values of LibreOffice on Linux systems are way too small for "normal" modern desktops and laptops (> 2 GB main memory).

  5. #5
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    921

    Default Re: Libreoffice slow

    I'm also having performance issues with LibreOffice 5.2. Adding memory hasn't helped and JRE 1.8 is turned on. I posted a question on the LibreOffice forums so maybe I'll learn something. There's also two folders in ~/.config/libreoffice named 4 and 4-suse. I moved both of them out of that directory but 4 is recreated every time LO is started. Currently 4 is the only one in that directory but that hasn't made a difference.

  6. #6
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,674

    Default Re: Libreoffice slow

    Quote Originally Posted by dcurtisfra View Post
    LibreOffice is currently sensitive to the memory usage configuration values:
    • In the LibreOffice settings under "LibreOffice/Memory" increase the default values to large values.


    On my current systems with 8 GB memory, I use the following values with the LibreOffice versions available from the 13.2 and Leap 42.1 update repositories:


    • Number of "undo" steps: 100 (possibly the default value).
    • Memory used for graphics:
      • LibreOffice: 512 MB (not the default value);
      • Memory per object: 4.0 MB (possibly not the default but not really sure);
      • Remove from memory after: 10 minutes (possibly the default value).

    • Memory for inserted objects: number of objects: 128 (not the default value).


    Maybe I should have mentioned the following rules in my 1st post:


    • LibreOffice on Linux systems demands that the JRE be explicitly set.
    • The default memory usage values of LibreOffice on Linux systems are way too small for "normal" modern desktops and laptops (> 2 GB main memory).
    LibreOffice 5.1.3 is way faster than 5.0.4 here on Leap 42.1 with default memory settings (AFAIK, never touched that) on a 16 GB i7 4720 laptop.

    Graphics Cache:
    LibreOffice: 20 MB;
    Memory per object: 5.2 MB;
    Remove from memory after: 10 minutes.

    Memory for inserted objects: number of objects: 20.

    Number of "undo" steps: 100 (but it is in the "Expert Configuration" now).

    Oracle Corporation jre1.8.0_91

    So the problem might not be as simple as that.
    Main: Leap 15 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: Libreoffice slow

    Quote Originally Posted by dcurtisfra View Post
    LibreOffice is currently sensitive to the memory usage configuration values:
    • In the LibreOffice settings under "LibreOffice/Memory" increase the default values to large values.


    On my current systems with 8 GB memory, I use the following values with the LibreOffice versions available from the 13.2 and Leap 42.1 update repositories:


    • Number of "undo" steps: 100 (possibly the default value).
    • Memory used for graphics:
      • LibreOffice: 512 MB (not the default value);
      • Memory per object: 4.0 MB (possibly not the default but not really sure);
      • Remove from memory after: 10 minutes (possibly the default value).

    • Memory for inserted objects: number of objects: 128 (not the default value).


    Maybe I should have mentioned the following rules in my 1st post:


    • LibreOffice on Linux systems demands that the JRE be explicitly set.
    • The default memory usage values of LibreOffice on Linux systems are way too small for "normal" modern desktops and laptops (> 2 GB main memory).
    Thanks -- makes a big difference
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •