Results 1 to 3 of 3

Thread: Upgrade to Samba 4.2.4-18.1 is now muderously complex

  1. #1

    Default Upgrade to Samba 4.2.4-18.1 is now muderously complex

    Some time ago I posted a query related to the erroneous behaviour of evolution-ews 3.16.5-5.1. Solution to the problem, I was told, was to regress samba from 4.2.4-15-1 back to 4.2.4-12-1. I did just that and everything my evolution-ews worked again. So I thought I should 'lock' samba to version 4.2.4-12-1 until an update beyond 4.2.4.-15.1 appeared.

    Now samba 4.2.4-18.1 is available, but....the update is proving to be murderously complex, since there are endless libraries to be adjusted as well and I have no way of knowing which of the dependency solutions I should choose. Does anyone know what my best strategy would be?

    My current configuration:
    OpenSuse Leap 42.1 (64-bit)
    Linux kernel 4.1.21-14-default
    Gnome version 3.16.2

    It may be relevant to say that I had the same EWS problem on a laptop configuration and I followed the same approach of 'locking' the samba version to 4.2.4-12.1. The upgrade to samba 4.2.4-18.1 was considerably less problematical, and evolution-ews works fine with it.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,703

    Default Re: Upgrade to Samba 4.2.4-18.1 is now muderously complex

    Show zypper lr -d

  3. #3

    Default Re: Upgrade to Samba 4.2.4-18.1 is now muderously complex

    Quote Originally Posted by gogalthorp View Post
    Show zypper lr -d
    Code:
    # | Alias                               | Name                               | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                              | Service
    --+-------------------------------------+------------------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------------------------+--------
    1 | download.opensuse.org-Apps          | openSUSE BuildService - GNOME:Apps | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_Leap_42.1/        |        
    2 | download.opensuse.org-non-oss       | Main Repository (NON-OSS)          | Yes     | (r ) Yes  | No      |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/                |        
    3 | download.opensuse.org-non-oss_1     | Update Repository (Non-Oss)        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/non-oss/                           |        
    4 | download.opensuse.org-oss_1         | Main Update Repository             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss                                |        
    5 | download.opensuse.org-oss_2         | Main Repository (OSS)              | Yes     | (r ) Yes  | No      |   99     | yast2  | http://download.opensuse.org/distribution/leap/42.1/repo/oss/                    |        
    6 | ftp.gwdg.de-suse                    | Packman Repository                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Leap_42.1/                    |        
    7 | http-download.opensuse.org-852e26f5 | openSUSE:Leap:42.1                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Leap:/42.1/standard/         |        
    8 | http-download.opensuse.org-c2d701ab | home:-miska-:arm                   | No      | ----      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/-miska-:/arm/openSUSE_Leap_42.1/ |        
    9 | repo-update                         | openSUSE-Leap-42.1-Update          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/42.1/oss/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •