Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: KDE Plasma 5.6.90 update??????

  1. #1
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default KDE Plasma 5.6.90 update??????

    I'm running the Plasma5 Frameworks5 repo and the Qt5 repo. Today, I did a zypper up and was presented with a huge update with 280 packages to upgrade. I approved the update and rebooted afterwards. The results were not good with the breeze login screen presenting an ugly blue login screen. So, I went into settings and the breeze login screen theme was not found or undefined (I don't remember the exact wording but it was not there). Then, I noticed that the launcher did not work at all - completely FUBAR'd. My info center icon worked though and reported that I was running Plasma 5.6.90. In any event, I had backed up my system immediately before the update and so I immediately reverted to my backup which is working great.

    So, my question is, what is going on with the Frameworks 5 repo? Here is the repo url:

    http://download.opensuse.org/reposit...USE_Leap_42.1/

    FWIW, I have not touched any my repos in months so I am fairly confident that this was not caused by anything that I have done, at least recently.

    Thanks,

    Gordon
    Laptop #1: OpenSUSE Leap 15.0 (x86_64) | HP ZBook 17 G2 (17")
    Laptop #2: OpenSUSE Leap 15.0 (x86_64) | System76 Darter (14")

  2. #2

    Default Re: KDE Plasma 5.6.90 update??????

    Quote Originally Posted by gldickens3 View Post

    So, my question is, what is going on with the Frameworks 5 repo?

    Thanks,

    Gordon
    I think the repo is OK
    You got the beta version of Plasma 5.7. They changed the login and splash screen.
    Please read: https://www.kde.org/announcements/plasma-5.6.95.php

    login screen is ugly (my personal view) and "Agenda items in Calendar" does not work for me actually.

    Kind regards
    Florian

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,803
    Blog Entries
    14

    Default Re: KDE Plasma 5.6.90 update??????

    Quote Originally Posted by gldickens3 View Post
    I'm running the Plasma5 Frameworks5 repo and the Qt5 repo. Today, I did a zypper up and was presented with a huge update with 280 packages to upgrade. I approved the update and rebooted afterwards. The results were not good with the breeze login screen presenting an ugly blue login screen. So, I went into settings and the breeze login screen theme was not found or undefined (I don't remember the exact wording but it was not there). Then, I noticed that the launcher did not work at all - completely FUBAR'd. My info center icon worked though and reported that I was running Plasma 5.6.90. In any event, I had backed up my system immediately before the update and so I immediately reverted to my backup which is working great.

    So, my question is, what is going on with the Frameworks 5 repo? Here is the repo url:

    http://download.opensuse.org/reposit...USE_Leap_42.1/

    FWIW, I have not touched any my repos in months so I am fairly confident that this was not caused by anything that I have done, at least recently.

    Thanks,

    Gordon
    Take this as a warning sign. The KDE updates that appear through the Update repo ( yes, they do ) are just a tad behind upstream stable, and all these packages will only appear in those repos after succesful testing in openQA. Enabling repos like the ones you added is breaking that. Which ( very rarely, but still ) can come at a cost.
    If you intend to actually test the beta packages, report bugs. If you want a stable system, either use Tumbleweed ( openQA tested as well ) or stick to the packages Leap serves.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Re: KDE Plasma 5.6.90 update??????

    Thanks Knurpht and alfaflo for your replies!

    Knurpht, I successfully used the KDE4 repos with 13.1/13.2 and had been having a similar successful experience with the Plasma5/Frameworks5 repo on Leap 42.1 until now. I had no idea that beta versions of the Plasma 5.x software were now being pushed to these repos. So, I will revert back to the update repo ASAP as you recommended.

    Thanks again,

    Gordon
    Laptop #1: OpenSUSE Leap 15.0 (x86_64) | HP ZBook 17 G2 (17")
    Laptop #2: OpenSUSE Leap 15.0 (x86_64) | System76 Darter (14")

  5. #5
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,102

    Default Re: KDE Plasma 5.6.90 update??????

    No help at all but I did the same upddate using the latest iso of tumbelweed 13062016 and it worked fine. Do agree with you about the blue sddm screen.

  6. #6

    Default Re: KDE Plasma 5.6.90 update??????

    There is nothing wrong with that update or the repo. I had the same update and while I dislike the upstream branding for sddm, and there is no image preview available, you can still select a background of your choice for it and change from the ugly blue colour.

    The annoying part is the next splash directly after login still being blue and no way of changing that though.

    The launcher must just be plasma corruption I would have thought.
    .
    ✶ PC: P55 - i5 760 ✶ W7 / Leap 42.1 Dual Boot ✶/ (ext4). /home (ext4) ✶ KF5 & Plasma 5 Repo - Plasma 5.8.x Qt 5.7 ✶

  7. #7
    Join Date
    Jun 2008
    Location
    Wellington, NZ
    Posts
    28

    Default Re: KDE Plasma 5.6.90 update??????

    Quote Originally Posted by david_banner View Post
    There is nothing wrong with that update or the repo. I had the same update and while I dislike the upstream branding for sddm, and there is no image preview available, you can still select a background of your choice for it and change from the ugly blue colour.

    The annoying part is the next splash directly after login still being blue and no way of changing that though.

    The launcher must just be plasma corruption I would have thought.
    No; I have it too after the same update. The application icons on the panel still work, but the launcher doesn't; and the task manager notifications have also quit. The error message I get is this:

    Error loading QML file: file:///usr/share/plasma/plasmoids/org.kde.plasma.kicker/contents/ui/main.qml:27:1: plugin cannot be loaded for module "org.kde.plasma.private.kicker": Cannot load library /usr/lib64/qt5/qml/org/kde/plasma/private/kicker/libkickerplugin.so: (libKF5ActivitiesStats.so.1: cannot open shared object file: No such file or directory)


  8. #8
    Join Date
    Jul 2011
    Location
    Alpharetta, Georgia, USA
    Posts
    289

    Default Re: KDE Plasma 5.6.90 update??????

    Its a shame that something this buggy was posted to the Frameworks5 repo for Leap 42.1. I found it completely unusable.
    Laptop #1: OpenSUSE Leap 15.0 (x86_64) | HP ZBook 17 G2 (17")
    Laptop #2: OpenSUSE Leap 15.0 (x86_64) | System76 Darter (14")

  9. #9
    Join Date
    Jun 2008
    Location
    Wellington, NZ
    Posts
    28

    Default Re: KDE Plasma 5.6.90 update??????

    I submitted a bug to the KDE folk, and they advise that:

    this is a packaging/installation issue on your distro:
    It looks like your Task Manager and Application Menu packages
    were built against a different version of the ActivitiesStats
    library from KDE Frameworks than you have installed.
    .... so I've re-submitted it all to the openSUSE folk.

  10. #10
    Join Date
    Jun 2008
    Location
    Wellington, NZ
    Posts
    28

    Default Re: KDE Plasma 5.6.90 update??????

    OK; it turns out that the problem was that I had the
    wrong version of the libKF5ActivitiesStats1 package installed.
    Upon replacing it with version
    5.23.0-9.1 from the official
    ....KDE:/Frameworks5/ repo, it fixed the problem.

    So it wasn't a packaging error as much as a PEBKAC error!

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •