Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Unable to install HPLip for printer. Missing some dependencies

  1. #1

    Default Unable to install HPLip for printer. Missing some dependencies

    When i try to install hplip, I get the errors:

    Code:
    error: A required dependency 'libnetsnmp-devel (libnetsnmp-devel - SNMP networking library development files)' is still missing.
    error: A required dependency 'sane-devel (SANE - Scanning library development files)' is still missing.
    
    I am unable to find the packages to install those. Where would I get those packages?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,832
    Blog Entries
    15

    Default Re: Unable to install HPLip for printer. Missing some dependencies

    Hi
    Installing, you mean by compiling yourself? The development packages are net-snmp-devel and sane-backends-devel for openSUSE.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Unable to install HPLip for printer. Missing some dependencies

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Installing, you mean by compiling yourself? The development packages are net-snmp-devel and sane-backends-devel for openSUSE.
    I'm using HPLip's installer. I assume it is doing compiling.

    When i try to install "net-snmp-devel", I get the popup from YAST:

    Code:
    Problem: net-snmp-devel-5.7.3-4.1.x86_64 requires libopenssl-devel, but this requirement cannot be provided
      uninstallable providers: libopenssl-devel-1.0.1i-4.1.x86_64[repo-oss]
                       libopenssl-devel-1.0.1i-12.1.x86_64[repo-update]
                       libopenssl-devel-1.0.1i-15.1.x86_64[repo-update]
                       libopenssl-devel-1.0.1i-6.1.x86_64[repo-update]
                       libopenssl-devel-1.0.1i-9.1.x86_64[repo-update]
     Solution 1: deinstallation of libressl-devel-2.3.0-7.1.x86_64
     Solution 2: do not install net-snmp-devel-5.7.3-4.1.x86_64
     Solution 3: break net-snmp-devel-5.7.3-4.1.x86_64 by ignoring some of its dependencies
    
    


    What should I choose?

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,832
    Blog Entries
    15

    Default Re: Unable to install HPLip for printer. Missing some dependencies

    Hi
    Have you built something with libressl-devel? It could probably be uninstalled (since it's a devel package).

    Why build, assuming your after the latest version, use the Printing repo?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Unable to install HPLip for printer. Missing some dependencies

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Have you built something with libressl-devel? It could probably be uninstalled (since it's a devel package).

    Why build, assuming your after the latest version, use the Printing repo?
    I don't think I have.

    And I'm not building, I'm simply running the hplip install script that I downloaded from HP's website. This is how they say to install on a LEAP computer. (I tried the HPLip from YAST, but it wasn't able to see my printer)

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,832
    Blog Entries
    15

    Default Re: Unable to install HPLip for printer. Missing some dependencies

    Quote Originally Posted by 6tr6tr View Post
    I don't think I have.

    And I'm not building, I'm simply running the hplip install script that I downloaded from HP's website. This is how they say to install on a LEAP computer. (I tried the HPLip from YAST, but it wasn't able to see my printer)
    Hi
    Nope it's building hplip, I suggest you add the Printing repo and update hplip from there, if that doesn't work, raise a bug for sure.

    Code:
    zypper ar -f http://download.opensuse.org/repositories/Printing/openSUSE_Leap_42.1/ Printing
    zypper ref
    zypper up
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,382
    Blog Entries
    1

    Default Re: Unable to install HPLip for printer. Missing some dependencies

    Quote Originally Posted by 6tr6tr View Post
    I don't think I have.

    And I'm not building, I'm simply running the hplip install script that I downloaded from HP's website. This is how they say to install on a LEAP computer. (I tried the HPLip from YAST, but it wasn't able to see my printer)
    Are you sure that wasn't just due to the firewall blocking discovery?
    https://forums.opensuse.org/showthre...etwork-printer

  8. #8

    Default Re: Unable to install HPLip for printer. Missing some dependencies

    Quote Originally Posted by deano_ferrari View Post
    Are you sure that wasn't just due to the firewall blocking discovery?
    https://forums.opensuse.org/showthre...etwork-printer
    I entered the IP address directly and it still couldn't find it

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,382
    Blog Entries
    1

    Default Re: Unable to install HPLip for printer. Missing some dependencies

    Quote Originally Posted by 6tr6tr View Post
    I entered the IP address directly and it still couldn't find it
    Run nmap with printer IP address and report back
    Code:
    nmap <printer IP address>

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,846
    Blog Entries
    14

    Default Re: Unable to install HPLip for printer. Missing some dependencies

    Question: Why not use the hplip that Leap has available ?

    Other question: are you on the same network ? I.e. connected to the same router?
    Silent question: is the printer on?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •