Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: NVIDIA 367.27-24.1

  1. #11

    Default Re: NVIDIA 367.27-24.1

    I tried the x11failsafe and that didn't work. I uninstalled all nvidia packages and upon booting I still get no desktop, just a black screen. When I get to console and also boot into yast the font is now absolutely tiny!

    Hmmm, where to go from here? Cheers

  2. #12
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,481
    Blog Entries
    3

    Default Re: NVIDIA 367.27-24.1

    Quote Originally Posted by wolfi323 View Post
    Do you have virtualbox-guest-kmp-default installed?
    Yes. But I think I'll just stick with nouveau for the present (see the other thread for details of what I did).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #13

    Default Re: NVIDIA 367.27-24.1

    Quote Originally Posted by thestig View Post
    I tried the x11failsafe and that didn't work. I uninstalled all nvidia packages and upon booting I still get no desktop, just a black screen.
    Well, then your problem seems to be unrelated to the nvidia driver. (or maybe nouveau has a problem as well)
    But just in case: if you have an /etc/X11/xorg.conf, you need to remove/rename it, as it will tell Xorg to load the nvidia driver (which fails if it isn't installed).

    Adding "nomodeset" to the boot options should help to get to graphics mode.
    Please post /var/log/Xorg.0.log.old then.

    Also, try to reinstall the nvidia driver then (the kmp in particular) and post the output.
    Code:
    sudo zypper in nvidia-gfxG04-kmp-default
    When I get to console and also boot into yast the font is now absolutely tiny!
    The font should be the same (pixel) size as ever.
    But nouveau will use your monitor's native resolution, while with the nvidia driver the console is using 640x480 by default.

  4. #14

    Default Re: NVIDIA 367.27-24.1

    Quote Originally Posted by wolfi323 View Post
    Well, then your problem seems to be unrelated to the nvidia driver. (or maybe nouveau has a problem as well)
    But just in case: if you have an /etc/X11/xorg.conf, you need to remove/rename it, as it will tell Xorg to load the nvidia driver (which fails if it isn't installed).

    Adding "nomodeset" to the boot options should help to get to graphics mode.
    Please post /var/log/Xorg.0.log.old then.

    Also, try to reinstall the nvidia driver then (the kmp in particular) and post the output.
    Code:
    sudo zypper in nvidia-gfxG04-kmp-default

    The font should be the same (pixel) size as ever.
    But nouveau will use your monitor's native resolution, while with the nvidia driver the console is using 640x480 by default.
    I went to remove /etc/X11/xorg.conf and it said no such file or directory. Using yast I've reinstalled nvidia drivers so I'm back to square one.

    If I press "e" at the bootloader screen it comes up with a lot of various text..... And typing nomodeset and pressing F10 says something along the lines of command not found.

    Cheers

  5. #15

    Default Re: NVIDIA 367.27-24.1

    Quote Originally Posted by thestig View Post
    If I press "e" at the bootloader screen it comes up with a lot of various text..... And typing nomodeset and pressing F10 says something along the lines of command not found.
    You should move the cursor to the line starting with "linux" (or "linuxefi"), and append "nomodeset" at the end.
    Then press F10.

    But that was intended to prevent nouveau from loading and using a fallback driver instead to get to a graphical system.
    With the nvidia driver installed again, it doesn't really make sense (although it might help if there's a problem with the blacklist).

    So again uninstall the 4 nvidia packages, reboot and add "nomodeset" to the boot options, then if you (hopefully) get into graphical system post /var/log/Xorg.0.log.old.
    And please also run "sudo zypper in nvidia-gfxG04-kmp-default" and post the output.

  6. #16
    Join Date
    Jun 2008
    Location
    Yorkshire
    Posts
    328

    Default Re: NVIDIA 367.27-24.1

    I've downloaded the nvidia run file and installed "the hard way". It installs and works fine on leap with kernel 4.6.
    In Tumbleweed I have kernel 4.7 rc3 and I had to tweak the nvidia run file to install it. You can find the tweaks by googling "nvidia patch kernel 4.7". It works just fine.
    Pete

  7. #17
    Join Date
    Feb 2016
    Location
    Germany
    Posts
    43

    Default Re: NVIDIA 367.27-24.1

    Quote Originally Posted by SUSEtoad View Post
    I see that NVIDIA drivers 367.27-24.1 are now available.

    The previous driver updates had bugs that resulted in a black screen at boot.

    Has anyone installed this new version and can confirm that it is working correctly?

    (Perhaps this post belongs in "Hardware"? Move if appropriate.)
    I've updated the nvidia drivers to 367.27, rebooted with crossed fingers and it's working fine as it looks like. I did have problems after upgrading the first time last weekend but I didn't had the problem with the black screen, just plasma crashing but this was related to vbox drivers that prevent installing the nvidia drivers.

  8. #18

    Default Re: NVIDIA 367.27-24.1

    Quote Originally Posted by wolfi323 View Post
    You should move the cursor to the line starting with "linux" (or "linuxefi"), and append "nomodeset" at the end.
    Then press F10.

    But that was intended to prevent nouveau from loading and using a fallback driver instead to get to a graphical system.
    With the nvidia driver installed again, it doesn't really make sense (although it might help if there's a problem with the blacklist).

    So again uninstall the 4 nvidia packages, reboot and add "nomodeset" to the boot options, then if you (hopefully) get into graphical system post /var/log/Xorg.0.log.old.
    And please also run "sudo zypper in nvidia-gfxG04-kmp-default" and post the output.
    Hi,

    I went into yast and deleted the nvidia packages, and started using nomodeset and..... Still, I'm left with a black screen.

    Many thanks. Getting a bit annoyed with this now. I've had more problems with this than Windows 10 which I'm dual booting!

  9. #19

    Default Re: NVIDIA 367.27-24.1

    Quote Originally Posted by thestig View Post
    I went into yast and deleted the nvidia packages, and started using nomodeset and..... Still, I'm left with a black screen.
    Well, I suppose we can safely assume that the nvidia driver is *not* the problem then, and it's probably not related to the graphics driver at all.

    Unfortunately with the (lack of) information available so far (i.e. that you get a black screen...), it's rather impossible to give any further suggestions (except a reinstall).

    For a start, what exactly do you mean with a black screen?
    Is it completely black?
    Or is there a mouse pointer at least?
    Does pressing Ctrl+Alt+Backspace twice bring you back to the login screen?

    As you created a different thread yourself, please let's continue there though:
    https://forums.opensuse.org/showthre...No-hdmi-signal

    Discussing the same problem in two different threads just creates chaos.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •